[REQUEST] Acer Nitro 5 AN515-41 AGESA Update

Hi. I have this laptop and it has AGESA StoneyPI 1.3.0.A, which is kinda old at this point, the latest bios version is 1.08 but right now I have 1.09 (my laptop came with 1.06, upgraded to 1.08 and maybe sometime in the last 2 year windows update updated my bios, anyways, i guess you have to name it 1.10 cuz I can’t flash 1.08 because of this). Here’s a pic about the bios (down)
I saw that Coreboot and other bioses have Agesa StoneyPI 1.3.0.9 (github .com/coreboot/blobs/blob/master/pi/amd/00670F00/FP4/AGESA_Release_Notes.txt) and also 1.3.0.9 partial from 2018 march (compared to normal 2017 november) but with much less tool and it shows only for FT4 (not FP4 socket, even if it’s there in the 1.3.0.9 partial notes)
github .com/coreboot/blobs/blob/master/pi/amd/00670F00/FT4/AGESA_Release_Notes.txt

Also, there is this version on Microcode repo, but it says for 6006705 meanwhile these shows 6006704 from Coreboot, and I don’t know which rev I have. (right now it says MIcrocode update revision 600611A… so maybe the one from here is the latest?
github .com/platomav/CPUMicrocodes/blob/master/AMD/cpu00670F00_ver06006705_2018-02-20_1026F331.bin

I would be good only with the 1.3.0.9, but if partial one can be integrated with all the packages from 1.3.0.9 its good.

Here it would be the agesa bin for FP4 socket which I have: github .com/coreboot/blobs/tree/master/pi/amd/00670F00/FP4
(or if you need more to it, I’m sure you will find in this github page)


Thank you very much! In the FIles you have a picture about the BIOS, the microcode from the github repo, and the 1.3.0.9 from coreboot

BIOS_Acer_1.08_A_A.zip (5.79 MB)

Files.rar (4.58 MB)

Aparently these are still impossible to do :smiley: well, sad.

Hi friend, use this tool run it as Admin and upload the result file here , i will give a look :

https://www.mediafire.com/file/4s2lp3ig8…ools20h.7z/file

Let me know
Regards



Ill run it when I’ll get in touch with the laptop, btw out of curiosity I checked with VirusTotal and it got detected by 31/68 as a malware, what is that file (even Microsoft Defender deleted it, I restored it but I’ll wait for your response :D)?

Edit: it doesn’t have appropriate permission to open it.

edit2: tried this, still doesn’t work: https:// www. majorgeeks.com/files/details/universal_bios_backup_toolkit.html

Hi friend,
it’s a false positive as anti-virus looked to core tool that get the bios backup and make alert.
This tool checks all the ways to reflash the bios mod into eeprom , you can unpack too by winrar or 7zip.
let me know
Regards

Hi.



It shows that the program doesn’t have appropiate permission to open it, I tried the one from majorgeek, link in my other post, and it shows unsupported BIOS.

results20.rar (77.3 KB)

Here is the result, can anyone else check it out please, to see what it can be done? AGESA update would be enough, but if others can be updated, it would be great!