[Request] Acer TC-1660 (B560 - b56h5-ad by ECS Elitgroup) - BIOS Unlock

Greetings to the forum community
I have a computer board based on the b560 chipset from a ready-made Acer TC-1660 computer (LGA 1200/11700)
Everything is fine, it works, if not for one thing.
Bios is worse than on cheap laptops.
I don’t even see the necessary minimum in the bios menu. Everything is hidden.
There is no way to configure the operating memory, there are no XMP profiles, there is no manual setting of memory.
You can’t set up a warm package via PL1 PL2.
You can’t control fan speed.
You can’t choose boot variant - Legacy+Uefi.

I try edit it through AMIBCP.
The only thing that worked was running one of the XMP profiles. But it is still impossible to select the frequency.
I try to bought a JEDEC 3200 MHz memory, but it works only 2933.
Other settings after AMIBCP are simply not accepted by the motherboard, it starts up without error but no changes are made.

It is not possible to dump or flash it via USB flash drive - it won’t boot.
I use a programmer CH341, but this is extremely inconvenient, because it is not always possible to connect to the chip quickly.
The only option is to flash the bios update from the manufacturer’s website.

Are there any variants to open the bios hidden settings so as not to write them into the dump programmatically?

Thankful in advance

My worked dump - 7.08 MB file on MEGA
BIOS update from ACER support - 16.72 MB file on MEGA