[ REQUEST ] AMI Aptio V BIOS -- AcePC GKV3 Mini PC -- Unlock ALL Menus & Options

Greetings all,

I recently picked up a white-labeled generic Chinese mini PC sold under the brand “Guzila” by AcePC, marketed as the model: GK3V mini PC with a Celeron J4125 CPU + Intel HD Graphics 600 ( SEE HERE: h t t p s : / / snipboard . i o /tjegEQ.jpg ). I am trying to get all BIOS menus unlocked so I can mod the CPU TDP and other performance characteristics. Based on this article here ( h t t p s : / / techtablets . c o m /2017/08/increase-apollo-lake-tdp-boost-intel-hd-graphics-performance-80/ ), if I can unlock the TDP and/or OC this mini PC, there should be some decent gains to be had so long as I keep it cool. :slight_smile:

I extracted the original bios *.rom file using the AFUWINGUIx64.exe (v5.14.01.0015). I subsequently used AMIBCP64.exe (v5.01.0014) to flip all available menu options from “default” to “USER”. I tried flashing it back using AFUWINGUIx64’s GUI from within Windows 10 and it did reveal a few additional things in the BIOS but certainly not all that I flipped to “USER”. I also noticed after doing that, when entering BIOS, the BIOS complains about an incomplete update has been flashed and asks if I wish to clear the NVRAM and/or update the boot firmware. I tried letting it do those, but nothing changed, still only a few extra items shown, the BIOS still complains, no “Advanced” tab or other tabs added, and the system still works and boots normally otherwise. After re-flashing the original *.rom dump, all is back to stock, no complaints from BIOS, no issues booting, etc.

I just recently stumbled across ( h t t p s : / / w w w . win-raid . c o m /t4009f16-Unlock-Aptio-V-Z-Board-Menu-Chipset-unhide-and-other-Menu.html#msg60856 ), suggesting that AMIBCP up to v5.2.0.31 or v5.02.0031 are bugged and do not allow for the simple " flip from ‘default’ to ‘USER’ " method of modding AMI Aptio V BIOS.

So, for now I am requesting help modding my BIOS from all the experts here while I continue reading and learning so I can hopefully do this myself someday soon. I tried to attach my original BIOS dump “original.rom” for your examination but the forum says it is too large to host and due to my account being new I am unable to post links to it right now. Here is my “original.rom” hosted externally: ( h t t p s : / / anonfiles . c o m /p8J4c0tbu5/original_rom ). I also attached screenshots of my BIOS landing screen with version information and the “complaint” screen I mentioned above for you to see as well.

I hope to get this figured out and learn from the experts in the process as I want to get more into low level hardware mods in the future after I get my programming degree. :slight_smile: Also, please advise which hardware FPT / clip is sufficient so I may purchase it in case it is needed at some point during this process. I have other machines I would like to attempt BIOS mods on in the future as well.


I believe my BIOS chip is this here: h t t p s : / / w w w . gigadevice . c o m /flash-memory/gd25lb64c/
Its data sheet can be found here: h t t p s : / / w w w . gigadevice . c o m /datasheet/gd25lb64c/
I have attached a picture of the chip itself ( GigaDevice 25LB64CV1G AP2A191 HJ2028 ) as well as its location on the corner of the mainboard near the heatsink exhaust outlet.