[Request] Aorus 15p XD Bios Unlock

Hi! I’m trying to fully unlock the my new laptop’s BIOS but I never have done that before. Could you please help me? I try to use the Backup tool but it gives me the 167 error. I already deleted the sec. records from secure boot menu (now it is in setup mode) - I’m not able to fully disable the secure boot in BIOS. Also I disabled the TPM but the error persists. Nevertheless I’ll attach the result file just in case. I aplied the Dump.bat from the known program and revieved the Biosreg file - I’ll attach it here.
Thanks everyone in advance!

results20.rar (4.63 MB)

biosreg.rar (4.48 MB)

Hey, @SeN ,

Did anyone help you with unlocking? I am looking to unlocking my bios too for the same laptop.

I hope you don’t mind if I attach my bios dump here too? :slight_smile:

results20.rar (4.61 MB)

I am trying to unlock my Aero 17 HDR XD. Maybe I can help a little bit. Error 167 indicates that you firstly have to unlock the bios so that it can be flashed.

In principle, here is how to do it: You need to delete security variables in your bios. Then you need to boot RU (it worked for me using a card reader).

Subsequently, you need to unlock the BIOS with RU. See http://forum.notebookreview.com/threads/…-issues.812372/ and here [Request] Gigabyte AORUS 15G BIOS unlocked

The key question is where to exactly unlock the bios. This what I still need to figure out in my “own” thread now that I have installed a new bios version so that I am “locked” again: Gigabyte Aero 17 HDR XD (Intel 11 Gen) - Bios Unlock (2)

Hope this helps a little bit.

Hi guys!
@George! Unfortunately not =( Still waiting for that’s not too much information about this model bios unlocking.
@Tiz, Thanks for you help, friend! Working on it with your tips!

If anyone can provide some help , PLZ!

Have you already worked around error 167?

You should use the RU.EFI shell to allow writing BIOS to SPI flash.

BIOS Lock VarOffset - 0x1C
Flash Protection Range Registers VarOffset - 0x683
Change 01 to 00
You will find this variable in a store named “PchSetup”.

Here’s a useful example of using the program.


Do you fully understand this part of the tutorial?

I basically got stuck in my Aero 17 unlocking thread because I do not fully understand which steps and tools I have to use to find the relevant locations and apply the patches suggested by BDMaster (

). It is also not entirely clear to me whether I can directly patch the bios dump produced with ftpw or whether I firstly have to extract a bios module, then patch it and, subsequently reinsert into the dumped bios module (prior to flashing back the now modified module).

Thanks for any help!


Yes, after spending a whole evening understanding Aptio BIOS. But I still cannot figure out the 4th version of Aptio. Glad that most of the new devices use the 5th version.



I managed to get around the error 176. I found step by step instructions.

since there is already a post in the forum, I posted it there: #29 | RE: [Request] Bios unlock for Aorus 15p xd