[REQUEST] Aorus 15p yd bios unlock

Hi guys!
I would like to excuse for my incompetence in advance… I’ve been reading almost all threads concerning unlocking the bios of the above mentioned laptop, but it seem that I’m just too dumb to do it ^^
I just want my ram to run at the advertised speed via the appropriate xmp setting, nothing more, though I won’t be upset if other setting will be unlocked. seems to me that this might be harder than I thought…

So would anyone PLEASE be so kind as to guide me, step by step, through the whole process? I don’t want to brick my laptop…

Thank you all in advance and best regards!

this is what I have accomplished so far, dumped current bios:

https: //www .sendspace.com/file/9m6wkp

Is it possible to flash the bios linked at the end of this thread "https:// www .win-raid.com/t9868f54-REQUEST-Gigabyte-Aorus-P-YD.html#msg155398", or is it made specifically for a single laptop?

"Zitat von Marcil im Beitrag #7
Actually, I downloaded something from a wrong link, I have the same problem of @Dragonviper

@553349149 can you upload the result in a non chinese drive to make things easy for us?

I hope I can help you: @Sweet_Kitten @Marcil https:// drive.google.com/file/d/1pjR7nW7...iew?usp=sharing"

anyone up for the task, please?
Rest assured fellow companions, the universe will protect you from whichever danger lurks within your future endeavors!


You should use the RU.EFI shell to allow writing BIOS to SPI flash.

BIOS Lock VarOffset - 0x1C
Flash Protection Range Registers VarOffset - 0x683
Change 01 to 00
You will find this variable in a store named “PchSetup”.

Here’s a useful example of using the program.

Thank you for your respone! Seems like ru.efi keeps crashing as soon as I enter PchSetup… Is there anything I can do about that?

ok I managed to do it and hopefully unlock everything, at least my laptop still works hehe
thanks again @Sweet_Kitten !

The archive weighs only 80 kilobytes, so something went wrong. I can’t know if it’s because of antivirus or just a random error.
Still need your BIOS dump. FPTW

Sorry, I thought it worked…
New link:

btw I can’t thank you enough for your time and help!
is there any way I can compensate you for your effort?

BIOS mod for you: Odin-von-Asgard.zip.

I don’t accept donations.

ok, thank you nevertheless! You’re awesome! I’ll try and flash it immediately

it worked perfectly fine! thank you very much!