[Request] Asrock X79 Extreme 4 Bios with NVMe Support


Can someone add NVMe support for the Asrock Extreme 4 X79 ?

Thank you very much in advance.

attached the stock bios.

X79 Extreme4(3.70)ROM.zip (4.79 MB)

@StormRaider - Asrock X79 Extreme4(3.70)ROM-NVME-Only-Mod
Flash via Instant Flash, don’t rename sometimes that makes it invisible to Instant Flash.

* Mirrors - For both sites, be sure you click download the file and not on ads by mistake ie use ad blockers

I will give it a try and give you a feedback.

Thank you for helping me

Working perfectly. Wow.
No bootfailures or errors.



is detected and listed as Microsoft Windows and sometimes as Windows boot manager in Bios window

Thanks for report back
Glad to see it’s all working well now, enjoy that NVME Speed!

Can you repost that bios somewhere we could download it i have the same problem :slight_smile: thanks in advance. Download link doesnt work :frowning:

@dzivo - Mirror added at original post. Hopefully tinyupload comes back soon!

Thx man i will let you know if it works for me :slight_smile:

For me it didnt work i did the same thing as you and tried some other modules using UEFI Tool.

I think my problem is hardware issue i am using x79 e4 and orico NVME M.2 expansion card and i get d6 error on my mbo whatever i do.
I will try another expansion card first than iwill try to see if ssd is working.

Thanks a lot for fast reply and new mirros :slight_smile:

@dzivo - You’re welcome! Sorry you’re having an issue! Yes, it may be a faulty or incompatible adapter card, since this mod BIOS is already tested and confirmed working by above user
Can you test the card and or NVME on another system? If it works, it may be some compatibility issue?

Debug code D6 that means no graphics display issue, so maybe move device to slot that’s not sharing with the graphics card
Did you try, clear CMOS, then boot to BIOS and load optimized, if you can get to BIOS? Did you try all slots one by one?

Try one of these, they work in everything I’ve put them into (you can get on ebay even cheaper, in black too, but China shipped so 3-4 weeks)

Hi there,

Thanks a lot for sharing this file, Nvme works perfectly on my old X79 asrock, it boots in very fews seconds, wouh !

I’m trying to install a Samsung 970 EVO NVMe M.2 into my PC with an Asrock Extreme 4 x79 mobo. I am using a Lycom DT-120 Host adapter, details attached.

I have installed the BIOS modified in this thread but can’t boot from the SSD. The SSD works OK when windows is running (it worked before installing the updated BIOS) so it works as a storage device with no problems but the only option I get in the boot menu is PATA.

Any help you could give me with this would be greatly appreciated.

Thanks very much.


@Brentster : You will be able to boot off your NVMe SSD after having followed point 4 of the “This is what you should do” list of my Guide, which can be found >here<.

Thank you very much Fernando, that’s great I will give it a go tomorrow and let you know what happens.

Hi Fernando,

I’m still having problems. I have attached pictures of the options I get while using Rufus. I don’t appear to have the Image option that you have in the example in your instuctions.
Originally I cloned my old C: drive to the new SSD using Samsung Magician but have now wiped the drive to try and start again. Sorry to bother you with this/



@Brentster : What do you want to say to me with your recent 2 posts? The appearance of a tool is not important. The main thing is that it does what it should. Did it work? If not, what happened?
This is a BIOS modding request thread and not a thread about how to get an NVMe SSD bootable.
By the way - I have merged your last 2 posts and additionally resized the inserted pictures. If you want to know how to get a perfect screenshot of the Rufus GUI or the content of any other open window, please read the start post of >this< thread.

Hi Fernando,

I’m quite new to this and managed to get myself confused. After reading your instuctions (properly) I succesfully got the SSD working.
Thanks very much for your help.

Could someone re-post these files? Both mirrors have expired.

I’m amazed to have come across this mod for my motherboard’s firmware!


Hello, I have an Asrock X79 Extreme 3 but the boot with NVMe does not work, you could help me

X79 Extreme3(2.90A)ROM.zip (4.84 MB)

The Asrock X79 Extreme3 with bios version 2.90A already has support for NVMe.
The use of a NVMe drive as bootable device, requires a full UEFI environment (CSM OFF), a x64 OS and GPT partition drive.

None are working links. Can you @Lost_N_BIOS please reupload them?

@Joh14vers6 : Welcome to the Win-RAID Forum!

It is rather unlikely, that you will get a response/reaction from Lost_N_BIOS, because he hasn’t been online since January.
Why don’t you do the required BIOS modification yourself? >Here< is the related easy to follow step-by-step guide.
Good luck!
Dieter (alias Fernando)