[Request] ASRock X99 Taichi - Adding IntelRCSetup to UEFI (BIOS) GUI

Agree. Drivers insertion is also a way to do that. But not the only one.

In the ECX, no?

Hope you succeed with Core and Cache voltages.

No. You talking about cpu register but we need the memory address where its data reading from to it. Eax actually. Ecx stores access to mbr o something. Not home to check it up but anyway it is not about our quest

Sorry for my ignorance, I don’t understand what you mean.

CPU has it’s own memory.

Yes, that mbr registers setting up cpu. But if bios does not write any data to it there is no point where to read it from. Someone need to write it before but that is all we need. If voltages saved to cpu no need to rewrite it again - - quest is already done.
Asrok bois just ignoring this sort of settings and that means the cpu stores nothing about voltages (default). I want to find where data placed to cmos and force it to cpu by driver.

How come that ASUS alow it and ASRock doesn’t ?
What does ASRock suppress here ? Where does it check this value ? CPU memory ? Maybe if we can circumvent the value somehow and this condition becomes false it will not only show this menu item but also will allow us to apply our settings ?
For overclockable CPUs it works, I don’t think that CPU registers are different for FIVR voltage settings for overclockable CPUs and non-overclockable.
ASUS allow to apply FIVR settings for both overclockable and non-overclockable CPUs, so it seems to me this is ASRock bios issue.

IFR extractor shows where the data is saved in CMOS. You can even read and white those values without going in to bios settings, just use grub tool setup_var.

It is not difficult, we can try. Wanna know the offset?
But I doubt that it’ll allow to apply settings after all. NVRAM is at a higher level than registers.

Yes, tell me how to proceed, so that “suppress if” returns false, like it does for overclockable CPUs.

Create a separate topic for this please.
Make it brief. No need to duplicate this one, so refer to the issue with voltages, not unlocking.


@Eugene @Sweet_Kitten

Apologies for necro’n this thread… But Is there anyway you can provide this bios? This is exactly what i’ve been looking for and would like to use this, I just dont have the skill to do this. I would appreciate it

I don’t know how did he install ths BIOS.

Which way did you followed?
I want to do the same on my MSI X99A Godlike Gaming but the IntelRCSetup is located in Platform and not Setup.
If you can show us how you managed to make it worked.
I tried to follow this guide but it doesn’t seems right to me OverPowered TONGFANG CyberPower Machrevo MACHENIKE - Unlocked BIOS Guide W/ Files

I noticed you questioned again how to unlock RCSetup.

If @Eugene doesn’t respond, I’ll do.

As well as for asrock x99 bios, IntelRCSetup is indeed located in Platform driver.
To unlock the menu the OP followed the pdf document from this post. Its contents are based on the guide for tongfang mobos. The pdf shows 1 out 3 unlock methods I know.

Hi there,

Eugene did replied me in PM but this method doesn’t seems to work or i just don’t understand really on how to unlock it successfully.
By this method, i’m not really sure if i should write the RCSetup hex 43 D6 87 EC A4 EB B5 4B A1 E5 3F 3E 36 B2 0D A9 to AMITSE into blank hex after this pattern shown in the pdf or add it in the file (and make it bigger)

Even if i add it i don’t know where i could manage to access it from the main setup.

If you have other methods to manage to make it i’ll take it.

BTW i published my current work on this board at GitHub - Dok-T/MS-7883: MSI X99A Godlike Gaming BIOS Mod + Schematics

Regards, DokT

Using this method you should write the hex numbers into blank space.

I see. This MSI bios uses a different Setup screen ui.
From now on I will write in PM.

1 Like

Hey @Sweet_Kitten,
I would love to try to see if I can get the IntelRCSetup on my Asus mainboard.
Also in my case I have the section installed into another Volume.

So for what I understand I “just” need to add the GUID to the "top layer"menu and it should show up. The original bios has already different sections stored in others volumes. (Event Viewer and Server Mgmt).

I’ve never modded a BIOS so I’m a bit lost on where I should put the GUID.
There are multiple sections where the IDs shows up.

Can you guide/provide me with some more precise infos?


Is this a modding request or you want to mod the bios yourself? If second, I’ll just add you to the conversation with DokT as I’m kind of lazy to explain everything again.

I would love to do it myself just to learn something new!

Ok for me to be added to the conversation.

Hope you’ll find any use of our conversation.