[Request] ASRock X99 Taichi - Adding IntelRCSetup to UEFI (BIOS) GUI

The question is how can we adjust cpu/cache voltage offset from the original bios. And why it works on Asus from its original bios and doesn’t work on ASRock.
We are aware of those third-party dxe drivers that hard codes those values for core/cache voltage offsent and cpu multiplier, that are gone btw after resuming from S3 sleep mode, but the question is how to make it adjustable from ASRock bios, the same way as we do it on ASUS boards.

What’s the other way to access IntelRCSetup ?
I was able to replace “Security” with “IntelRCSetup” but I was not able to move Security to a different place (maybe didn’t try hard enough). I don’t want to lose access to Security. What if I need it some day ? :wink:

Because ASUS allow it. Intel’s limitations to OCing is just a reccomendation.

I think it’s all about memory registers. You know, like a multiplier limit on some H77 boards.
I don’t know how exactly make the voltages adjustable, we need to study things better.

UniversalAMDFormBrowser app.
Or the way genius239 unlock external forms.

It doesn’t work after sleep. That why people (me too) using PAI or RAW driver. As my mobo accept only raw I decompiled its topology for investigating, its assembly code is quite simple and almost the same as dxe. I already tried to modify it by hex it works just fine so all I need is correct address where settings(cmos) holds required data saved by user at bios settings

You keep talking about your mobo. But what is it?

It is already known how to set voltages up. Drivers do that. Dxe, pai, raw, whatever I can compile it too but where is data stored?

My mobo is extreme 4

Agree. Drivers insertion is also a way to do that. But not the only one.

In the ECX, no?

Hope you succeed with Core and Cache voltages.

No. You talking about cpu register but we need the memory address where its data reading from to it. Eax actually. Ecx stores access to mbr o something. Not home to check it up but anyway it is not about our quest

Sorry for my ignorance, I don’t understand what you mean.

CPU has it’s own memory.

Yes, that mbr registers setting up cpu. But if bios does not write any data to it there is no point where to read it from. Someone need to write it before but that is all we need. If voltages saved to cpu no need to rewrite it again - - quest is already done.
Asrok bois just ignoring this sort of settings and that means the cpu stores nothing about voltages (default). I want to find where data placed to cmos and force it to cpu by driver.

How come that ASUS alow it and ASRock doesn’t ?
What does ASRock suppress here ? Where does it check this value ? CPU memory ? Maybe if we can circumvent the value somehow and this condition becomes false it will not only show this menu item but also will allow us to apply our settings ?
For overclockable CPUs it works, I don’t think that CPU registers are different for FIVR voltage settings for overclockable CPUs and non-overclockable.
ASUS allow to apply FIVR settings for both overclockable and non-overclockable CPUs, so it seems to me this is ASRock bios issue.

IFR extractor shows where the data is saved in CMOS. You can even read and white those values without going in to bios settings, just use grub tool setup_var.

It is not difficult, we can try. Wanna know the offset?
But I doubt that it’ll allow to apply settings after all. NVRAM is at a higher level than registers.

Yes, tell me how to proceed, so that “suppress if” returns false, like it does for overclockable CPUs.

Create a separate topic for this please.
Make it brief. No need to duplicate this one, so refer to the issue with voltages, not unlocking.


@Eugene @Sweet_Kitten

Apologies for necro’n this thread… But Is there anyway you can provide this bios? This is exactly what i’ve been looking for and would like to use this, I just dont have the skill to do this. I would appreciate it

I don’t know how did he install ths BIOS.

Which way did you followed?
I want to do the same on my MSI X99A Godlike Gaming but the IntelRCSetup is located in Platform and not Setup.
If you can show us how you managed to make it worked.
I tried to follow this guide but it doesn’t seems right to me OverPowered TONGFANG CyberPower Machrevo MACHENIKE - Unlocked BIOS Guide W/ Files

I noticed you questioned again how to unlock RCSetup.

If @Eugene doesn’t respond, I’ll do.

As well as for asrock x99 bios, IntelRCSetup is indeed located in Platform driver.
To unlock the menu the OP followed the pdf document from this post. Its contents are based on the guide for tongfang mobos. The pdf shows 1 out 3 unlock methods I know.