[Request] ASUS H81T BIOS modules update


I need to update via UBU tool latest BIOS modules, but I have some questions and need help.

  • First, i don’t understand what OROM Intel RST module I have to choose (mine is I downloaded, it is fine to me?

  • I can’t update EFI Realtek UNDI Driver, I put latest (tested with x64 and x86 version) on corresponding folder and I get “unknown” version.

  • Where I can get Video OnBoard updates? Please, check attachment photo to see my actual versions.

Thanks a lot!

Intel RST OROM is used by a RAID configuration, not a standard AHCI/SATA system.
UBU only cant deal with the latest RTL OROM, not newer, the tool is not updated since 2021, this module is only useful for remote boot.
[Updated] Latest ROM Modules (Not AHCI/RAID related) - BIOS/UEFI Modding / BIOS modules (PCI ROM, EFI and others) - Win-Raid Forum (level1techs.com)

VBIOS/VBT modules updates requires further steps and work (Not the GOP driver):
EFI LAN BIOS + Intel GopDriver modules - BIOS/UEFI Modding / BIOS modules (PCI ROM, EFI and others) - Win-Raid Forum (level1techs.com)


Thanks for the info. I’m not an super-advance user, but I get this using manual modules downloads (except EFI GOP and Realtek OROM, this are from UBU database):


Do you think there is all OK?

  • RST modules are up to date (even if I don’t use a RAID configuration, I like to update all the modules).
  • VBIOS/VBT are good after this UBU update? are the same versions, but I think I have to do nothing of your link instructions.
  • Only issue is REALTEK UNDI driver. It remains Unknown after 2.059 update (i download this module from Realtek because UBU Tools includes oldest one). How can fix this?

Thanks again

No… you must know your chipset, IRST 8/9 series for H81 is v13/14 series
Some v14 wont work on some 8 series motherboards.

AHCI & RAID Option ROM Modules - BIOS/UEFI Modding / BIOS modules (PCI ROM, EFI and others) - Win-Raid Forum (level1techs.com)

RTL LOM already explained to you, UBU cant deal with 2.0.59, use the 2.057 or proceed at your own risk.

Thanks again,
Now I understand better.
I will expose RST question on AHCI & ROM topic and I will stay with your Realtek recommendation.

Why the hell a new post? v19 are for Intel 600/700 series, there is no inquirires to do about this.
About the 13 or 14, its user choice each version benchmark, again NOT USEFUL if no RAID is used. This ROM is ONLY used in RAID MODE.

Sorry man, so with EFI Intel RST is the same history? Well… Then I have to stay on v13/14 too?

My first language is not English, so I have some troubles to understand some technical points.


I updated CPU microcode, Realtek network, OROM vbios and GOP driver through UBU tool. Flashed it and system boots well to UEFI, but in the next reboot there is not signal, and I have to reset CMOS. Same again…

I tried to mod only with one update, for example, update only MC and then test. Same result… I can’t boot on second reboot…

Why this occurred? There is any protection from ASUS to avoid modded BIOSes?

Any help?


You should try not to touch the entire SPI image (EC/Bios region/ME FW etc…)
The best way to debug this is FPT operations only in bios region, of course it requires the access unlocked.

EDIT: UBU operations as regular… but on an FPT dumped bios region ONLY.
And again ONLY if the access is unlocked and FPT can write it back…but this you already know, you’re not a ‘new’ user forum…

You can also try the bios region UEFI tool extracted…but as secondary option and only if FPT can write it.

1 Like

It is not easy to me to understand. I’m not an advanced user…
I’m flashing modded BIOS on pure DOS.
Are you telling me that I have to flash via programmer into the chip?