[Request] Asus Rampage IV Extreme X79 issue with the new NVME module

I am trying to mod the stock BIOS file with this new module NvmExpressDxe_5 for the NVME support on the X79 board called Asus rampage iv extreme.

I have followed the guide [HowTo] Get full NVMe support for all Systems with an AMI UEFI BIOS to insert the module.
I have attached the modded bios file called R4E.CAP (it is zipped).
If anyone could review it or point me towards the right direction on how to make it work that would be brilliant.

My modified BIOS file does flash fine via the BIOS FlashBack - LED is blinking and it seems that the file is being flashed fine, but system would not boot (black screen of death), does not get to BIOS stage.

I have tried to prepare the bios file twice with the same result (redownloaded fresh copy of bios from the asus page etc.)

R4E.zip (4.54 MB)

The DXE driver is in the right bios volume but describe what tools used and versions (MMtool/UEFItool).
This mod is easy on this motherboards generation.
The ASUS Bios FlashBack starts blinking, increasing rate blinking till it stops, thats the operation conclude in about 2m.

Hi @meatwar
I am using a FAT32 formatted 2GB usb stick, flashed the stock BIOS once my modded BIOS failed and it worked OK, it must be to do with the BIOS file I am trying to use.
I have used the MMTool and UEFItool NE Alpha 59 (Oct 14 2021).

When the file is flashed, PC turns on, but there is nothing on screen, it would not boot to BIOS stage.

Try the NvmExpressDxe_4 inserted with MMtool, assuming that the bios has no other mods not described by you… users some times forget to tell us or deliberated omit it.
Use UEFItool to compare and check for pad changes.
Usually it can be done from the CAP but you can also try the UEFItool method extract/replace bios region mod.

[OFFER] Asus Rampage IV Extreme - Nvme Bios mod (4901)