[Request] ASUS Z170-AR BIOS to support CoffeeLake CPU


This is as far as we can go as the Z170-AR does not have USB flashback to recover from bad flash (although it says it does in the manual and on Asus web site!!!).

I’m afraid you will need to buy a programmer, I would suggest getting a ch134A with the green PCB (not black, it over volts).

[̶E̶d̶i̶t̶]̶ ̶M̶a̶k̶e̶ ̶s̶u̶r̶e̶ ̶y̶o̶u̶ ̶a̶l̶s̶o̶ ̶b̶u̶y̶ ̶a̶ ̶S̶O̶I̶C̶ ̶8̶ ̶t̶e̶s̶t̶ ̶c̶l̶i̶p̶ ̶s̶o̶ ̶t̶h̶a̶t̶ ̶y̶o̶u̶ ̶c̶a̶n̶ ̶p̶r̶o̶g̶r̶a̶m̶ ̶t̶h̶e̶ ̶B̶I̶O̶S̶ ̶c̶h̶i̶p̶ ̶w̶i̶t̶h̶o̶u̶t̶ ̶r̶e̶m̶o̶v̶i̶n̶g̶ ̶i̶t̶ ̶f̶r̶o̶m̶ ̶t̶h̶e̶ ̶b̶o̶a̶r̶d̶.̶

[Edit] The BIOS chip is actually socketed (as shown here) so can be extracted and flashed externally as Lost_N_BIOS has pointed out.

Did you try with your old CPU? If yes, then sounds like the BIOS region you flashed in was a bad BIOS edit (or FPTw64 issue)
From what I see here, if no FPTw64 caused issue, reboot should have been fine (unless bad BIOS region was flashed in)
Give me your mod BIOS, I will check it vs stock and tell you if I see anything that normally causes bricked BIOS (ie missing padding files, added padding files, other issues etc) << This is VERY common issue = brick, usually due to incorrect microcode edit method

Thanks. Yes, I’ve never installed the new CPU. This was all done with the (old) Celeron in place. I’ll send it in PM.

Will do. Looking forward to getting this sorted; I’ll look into ordering the programmer and, in the meantime, will swap out the second motherboard for this one for "round two." I can take my time getting this one back to life if we can get the other one working.

I can’t guarantee which ME the other will have, but I’ll find out, probably tomorrow.

If you order a U Type Flat IC extractor ($1 on ebay), you can pull chip from one board and put in the other.
So you can revive both by booting to BIOS on working one, pull the chip out while in BIOS, put in the bad flash chip, then enter EZ Flash and reflash the bad chip with stock BIOS.
Then shut down and pull chip and put back in other board.

You should go ahead and order CH341A now + U Type Flat IC Extractor. You’re going to need it anyway, unless you plan to do pinmod.
You don’t need SOIC8 test clip with cable, at least not for this board because it’s BIOS is in a socket, but they are only $3.50 and you’ll want one in the future for other boards with soldered in-place BIOS
If you need links to examples of these on ebay let me know. Once you have these tools you are in control and there will be nothing you need to work around or try to fight to flash this or that etc.

* Edit - @MentalNomad - What you sent me is a stock BIOS that’s been modified, this should not be FPT Flashed (for starters)
Only FPT Dumped BIOS should be reflashed with FPT, even if you insert some (or all) system details back into the BIOS, it’s still incomplete and would be missing all your original NVRAM
None of that would cause brick, usually, but sometimes missing NVRAM can if certain things are not in the stock BIOS “Upgrade” Downloaded from Asus.

This mod BIOS is missing your system details in one area. Aside from that stuff, which may be non-critical (NVRAM May be, only testing later can confirm or not), I do not see any usual issues that might cause a brick.
So, possibly FPTw64 caused issue, I always suggest against using x64 version for this. Please send me dump of the now bricked BIOS on this board so I can see what’s in there and possibly tell you what happened/why etc.
Also, send me your original FPT Dumped BIOS from BEFORE you did any of this, hopefully you made a backup!

* Edit - Sorry, I forgot to tell you how to send me the dumped chips contents without a flash programmer. Ideally it would be best if you had the chip puller, because if you pull chip without it you can easily damage the legs.
It’s possible, and if you are VERY careful you can do it, but just when you think it’s almost out it can all go terribly wrong VERY quickly. So, if you attempt, be SUPER careful. Rock chip back and forth from side to side, with slight upward pressure.
Use something hard, small, and plastic, like maybe pointed pin cap or small wedge tool corner etc. Be extra light on the upward pressure as you get it more and more out, because if you pop it out too quickly from one side it will bend the legs all terribly.
Once it’s almost out, try to slide a thin ribbon or piece of string underneath it and then you can pull up and out from straight above with equal pressure on both sides at once.

So, if you try that, or wait on chip puller, here’s what you do to dump the dead chips contents (unless you have flash programmer, if you get one of those just dump it with that)
Pull chip out of working board carefully, then set it back in slightly, just enough so there is good contact but so that it can easily be pulled out.
While you have it out, before you put it back for this, you could attach some string, or tape around it etc, so you can easily pull up and out from straight above. Do this with both chips.
So, you boot to windows with the good chip in place. Once in windows at desktop pull the good chip out, and carefully set in the dead one (make sure it’s slightly snug so good contact, and be sure you set in carefully so no shorts)

Also, while doing any and all of this, pay attention to the chip orientation. on the edge of the BIOS socket there is a notch, and on the BIOS chip itself there is a notch/half-moon on the top side.
Always make sure these line up/match as you insert BIOS. Notch in socket always same side as notch/half-moon on BIOS chip.

Once you’ve swapped in dead chip, dump it with FPT >> FPTw.exe -d Bricked.bin
if you get permission error on that, dump each part one by one, probably ME region will be the fail/error (skip/carry on if it errors, get the rest and package it up to send to me)
FPTw.exe -desc -d FD.bin
FPTw.exe -gbe -d gbe.bin
FPTw.exe -me -d me.bin
FPTw.exe -bios -d brickedBIOSregion.bin

So I’m back on this project now, have the two mobos at hand.

I only see one significant socketed chip, but am looking for positive confirmation that it’s the BIOS chip. I’m 99%, because it’s next to the Flashback Header, but looking for 100%.

I’m an old-timer and feel confident about pulling/setting these ICs… just never expected to do it while the mobo is hot!

edit found 100% confirmation - it’s not mentioned in the manual’s, but the diagram shows the chip next to the FLBK_HEADER as BIOS, as expected.

I may have an old IC puller from 25 years ago, if not, I’ll rig something. Wish me luck!

@MentalNomad Pull as slowly as possible directly upwards, it usually comes out pretty quick when it lets go and that’s the danger time to bend the legs - Good luck!

Good Luck, and be careful if not using a chip puller (even then, be careful too)! @MentalNomad - it’s the one directly above PCIE slot, should be only socketed chip on the board I think.

Yes, indeedy - I used a fancy IC puller from (no joke) 30 years ago. Spring loaded, contoured handles, textured grip. Still works.

But when that chip "lets go," you can still bend the pins. Fortunately, the pins are also easy to straighten.


BIOS transplant was a success; machine is booted; I made a backup of the second mobo’s BIOS chip just for good measure.

C:\Tools\Intel\Flash Programming Tool\WIN32>fptw.exe -d untouched.bin

Intel (R) Flash Programming Tool. Version:
Copyright (c) 2007 - 2019, Intel Corporation. All rights reserved.

Reading HSFSTS register… Flash Descriptor: Valid

— Flash Devices Found —
GD25B128C ID:0xC84018 Size: 16384KB (131072Kb)

- Reading Flash [0x1000000] 16384KB of 16384KB - 100 percent complete.
Writing flash contents to file "untouched.bin"…

Memory Dump Complete
FPT Operation Successful.

BIOS re-transplant was a success; FPTW.exe dumped the bricked BIOS without any error.

C:\Tools\Intel\Flash Programming Tool\WIN32>fptw.exe -d bricked.bin

Intel (R) Flash Programming Tool. Version:
Copyright (c) 2007 - 2019, Intel Corporation. All rights reserved.

Reading HSFSTS register… Flash Descriptor: Valid

— Flash Devices Found —
GD25B128C ID:0xC84018 Size: 16384KB (131072Kb)

- Reading Flash [0x1000000] 16384KB of 16384KB - 100 percent complete.
Writing flash contents to file "bricked.bin"…

Memory Dump Complete
FPT Operation Successful.

I’ve sent you a link to the file in PM.


Note that the actual flash command that bricked the BIOS chip was:

fptw64 - bios -f z170-ar-asus-3504.mod1.bin

FPT Operation Successful

So I only flashed the BIOS, not the other areas.

I did this after several attempts to flash the whole thing failed, both with FPTW64 and under a DOS boot, with this error:

Unable to detect ME disabled…

Error 451: The host CPU does not have write access to the target flash area. To enable write access for this operation you must modify the descriptor settings to give host access to this region.

We shall see, IF I can tell what went wrong. If dumped BIOS region is match to the mod you flashed (minus expected NVRAM area changes due to boot attempt), then it’s just bad mod, it happens to the best of us, so nothing against anybody!
If BIOS region does not match or is corrupted etc, then something went wrong during flash, due to random glitch, or FPTw64, or some screw up with the previous issues you mentioned (or combo of all that) * Edit - OR, this system doesn’t like to boot with ONLY stock NVRAM (ie stock BIOS flashed via FPT)
If FD + ME missing, and BIOS region starts in it’s place, you left out -bios flag (this also happens to the best of us, so don’t feel bad if this is the case either ) << This did NOT happen, so all good there - still checking, but doesn’t look corrupted, may just be random issue or this ^^, or FPT/Previous issue etc
I will update thread soon with my findings

The old ME FW is in there still, so it’s possible mod BIOS also bricks without the ME FW edit flashed in.
Generally I’ve always thought this just meant Coffee mod wouldn’t work, but old CPU and BIOS still would, but I guess it would require lots of testing to confirm this if someone has not already.
And all instances may not be same so may have to be tested out on this exact board with this exact BIOS/Mod/ME FW etc.

Still checking, will update more as I check.

* Edit - @MentalNomad - OK - Bricked BIOS, aside from FD/ME and expected NVRAM is 100% hex match, system info padding left in place oddly, unsure how that is possible with FPT but it’s good to see.
So, this either bad mod for some unknown reason, or it’s OK mod but wont work without the updated FD and ME flashed in at same exact time. Or, there was some issue with FPTw64, or previous attempts, that messed something up in FD or ME and caused this glitched fail
I suspect, if BIOS OK, it may need FD+ME in there at same time (which is a KNOWN given for Coffee mod to function), unsure what is general expected outcome for old CPU in instance like this without the FD/ME flash during BIOS update.
I think this may vary from board to board, I see some users I KNOW didn’t flash FD/ME so their Coffee CPU isn’t working, but old CPU is, however I don’t know for certain this can be accepted as a will always be like that for all BIOS/systems type of thing.

To move forward, without flash programmer, you will have to do pinmod, unless what I mentioned to you about S3 bug in PM works
Once you have unlocked FD or flash programmer, we can re-test this BIOS mod as a whole, and or I can make you another that will work for sure and you don’t have to try testing/sorting this out etc.
All up to you, and of course depends on what options you have possible right now. Without unlocked FD via programmer or pinmod, you can’t use Coffee CPU anyway, so your standstill is there for now.

Brief update:

Sorry for delay, busy times.

I began a test re: S3 bug. I learned that the machine will not emerge from S3 sleep if the bricked BIOS is in place when it goes to sleep (or perhaps it never properly enters S3 sleep.)

I’m going to try these tests today:
1. Swap in the good BIOS; boot Windows; go to S3 Sleep
2. Wake
3. check for S3 bug / FD unlock
4. Hot-Swap in the bricked BIOS
5. check for S3 bug / FD unlock

If failed:

1. Swap in the good BIOS; boot Windows; go to S3 Sleep
2. Wake
3. Swap in the bricked BIOS
4. check for S3 bug / FD unlock

If failed again:

1. Swap in the good BIOS; boot Windows; got to S3 Sleep
2. Swap in the bricked BIOS
3. Wake
4. check for S3 bug / FD unlock

If those fail, and nobody suggest another option, I plan to boot on the good BIOS, swap in the bad BIOS, and flash in the -BIOS section from the backup to see if I’ve restored the bad BIOS chips to normal function. Perhaps I should do that first; then I can avoid all the nonsense above… hmmm… [EDIT: Yes, I’m going to try to restore that original BIOS chip, first. It’s not like I’m going to double-brick it, and it will remove unknowns from the rest of the process.)

If the S3 bug is not present for me, I’ll plan on PinMod. If PinMod doesn’t work, I’ll use a programmer. (I have a personal interest in attempting to do this without having to use external hardware.)

OK, I have failed to get the BIOS sections on the bricked chip flashed back to the original state.

Almost, though. It would not even begin to flash until I did the following:

1. POST on good BIOS chip.
2. Delete Secure Boot keys, Exit to shell.efi on USB
3. Modify setup_var 0x8c6 0x00; remove USB
4. POST/boot on good BIOS chip, allow Windows to load.
5. hot-swap the bricked BIOS chip in place of the good BIOS chip.
6. Run fptw64. Here is the output:

C:\Tools\Intel\Flash Programming Tool\WIN64>fptw64 -bios -f backup.bin

Intel (R) Flash Programming Tool. Version:
Copyright (c) 2007 - 2019, Intel Corporation. All rights reserved.

Reading HSFSTS register… Flash Descriptor: Valid

— Flash Devices Found —
GD25B128C ID:0xC84018 Size: 16384KB (131072Kb)

- Reading Flash [0x1000000] 13824KB of 13824KB - 100 percent complete.
- Erasing Flash Block [0x29A000] - 100 percent complete.
- Programming Flash [0x029A000] 104KB of 104KB - 100 percent complete.
- Erasing Flash Block [0x2C1000] - 100 percent complete.
- Programming Flash [0x02C1000] 136KB of 136KB - 100 percent complete.
- Erasing Flash Block [0x2F0000] - 100 percent complete.
- Programming Flash [0x02F0000] 64KB of 64KB - 100 percent complete.
- Erasing Flash Block [0x640000] - 100 percent complete.
- Programming Flash [0x0640000] 2900KB of 2900KB - 100 percent complete.
- Erasing Flash Block [0x66C000] - 100 percent complete.
- Programming Flash [0x066C000] 172KB of 172KB - 100 percent complete.
- Erasing Flash Block [0x7FE000] - 100 percent complete.
- Programming Flash [0x0686000] 96KB of 1600KB - 6 percent complete.
Error 317: Hardware sequencing failed. Make sure that you have access to target flash area!
Error 317: Hardware sequencing failed. Make sure that you have access to target flash area!
FPT Operation Failed.

C:\Tools\Intel\Flash Programming Tool\WIN64>

Interesting note: during the actual flash, I did not get the Error 317. Rather, the screen went blank at:
- Programming Flash [0x0686000] 96KB of 1600KB - 6 percent complete.

The machine would not respond, reboot, or POST. I swapped in the good BIOS chip to get it to boot… and my Admin command prompt was there with the Error 317 messages, still on-screen for me to copy.

So, restoring the original BIOS to the bricked chip has failed.

I’ll try again with fptw.exe, just to be sure.

EDIT: same results with fptw.exe.

Next: will boot on good BIOS chip and look for S3 bug.

@MentalNomad - “Bricked BIOS” = brick, this BIOS shouldn’t start system, let alone sleep??? So, what do you mean you tested this BIOS for S3 sleep bug? Is this bricked or not?
Maybe you misunderstood what I said for you to test? S3 sleep bug should be tested on working system only, with working BIOS only. Sorry if there was any confusion here

So, your comments above are confusing to me about this due to all the unnecessary BIOS swapping and info. Please redo test with working system, working BIOS only.
Then do as I mentioned in PM.

If you simply want to “Fix” the other board, do the hot swap while in BIOS. Boot to BIOS, enter EZ Flash, switch chips here, program in stock BIOS from Asus (renamed to Z170AR.CAP), reboot done.
Then once in windows, you can reflash the BIOS region from your original dump of that system using FPTw, before all this, to fix your serial info (LAN MAC ID we can fix later via FPT too.) << For this, you will need to redo the BIOS/SMI Lock stuff in grub once more first (at this stage, not before here)

The S3 sleep bug test, was meant so we could see if you could do two things. Do sleep 1+ minute, wake system up to windows, using FPTw (not FPTw64) do the following
Dump and write back FD (FPTw.exe -desc -d fd.bin >> FPTw.exe -desc -f fd.bin) and see if you could dump and write back ME (FPTw.exe -me -d me.bin >> FPTw.exe -me -f me.bin)
If either of those fail, you do not have S3 sleep bug in this BIOS, OR, it only allows to bypass SMI/BIOS lock (writing BIOS region locks, nothing we are concerned with here, we only care about above fail/pass)

If you can do both of those things, due to S3 sleep bug, then we can unlock your FD and reprogram FD/ME/BIOS all at once so the coffee mod can be used on this system.
At this point, it’s still not 100% mod BIOS is OK, so up to you if you want to retest flashing that in again as test, and have to recover again, or have me make you another mod one to try?

If you do not have S3 bug (ie write back of FD and or ME fails at S3 test), then pinmod or programmer is only method to unlock FD. Once FD unlocked you can do it all with FPT

* Edit - Sorry, I didn’t see above post until my reply posted. First, please stop using FPTw64. Then, see what I outlined above for you to fix the other BIOS chip so both boards are in working state

Well, I was trying to use the other (good) BIOS chip to check for the S3 sleep bug.

And I was trying to use the other (good) BIOS chip to boot the machine into windows, after which I thought I could hot-swap to the Bricked BIOS to restore the original BIOS section backup to it.

But no luck… along the way, I got to the point where neither BIOS chip will boot. I get:
B1InitializeLibrary failed 0xc0000001

It happens on either BIOS chip.

I tried going into EZ-flash and restored BIO 3504, which was originally on the chip. But I still get B1InitializeLibrary failed 0xc0000001.

I think I need to clear CMOS.

Yes, that is valid for S3 test, you can use good BIOS to check for this bug (but do not involve the bricked BIOS chip, it’s bricked )

For bricked BIOS chip, S3 test aside, you can fix it how I mentioned.
Make sure you are setting BIOS chips in carefully, correctly, and so that the legs are 100% straight and not shorting out on the edge of next pin metal clip thingie

Did you order these yet? If not, order now, that way they arrive sometime soon. And you can get on amazon or ebay shipped faster, these are just cheapest example so you know what you need

OK, update:

Sorry for the delay. Life is busy, and the world is crazy right now.

I finally had time to fix the unbootable mobo problem -would not boot with either BIOS chip; would not POST or enter BIOS setup; it just kept giving me error B1InitializeLibrary failed 0xc0000001

Finally resolved this by removing CMOS battery and shorting CLRTC.

Then I was able to reflash the “Bricked” BIOS chip by swapping chips while in EZ FLash as you suggested.

Afterwards, I booted into windows and things were working again.

I booted into BIOS to use the SMI BIOS lock bypass… after which I was able to restore the BIOS from my original backup, like this:

C:\Tools\Intel\Flash Programming Tool\WIN64>fptw -bios -f backup.bin

This also worked fine, and after reboot, the machine is back to original state - the UUID and MAC match the original settings, and the other BIOS chips is safely in its original motherboard.

NOW, I was ready to begin trying again.

I performed the S3 test.

I do not have the S3 bug i cannot write to FD or to ME.

I would like to make a second attempt at flashing just the BIOS, if you would be so kind as to provide.

I’ve already looked into pinmod prospects… can’t figure out how to pry the CrystalSound steel cover off the sound chip; I believe the chip is under there.

Yes, chip would be under there You really need flash programmer, maybe you’ll get lucky but I doubt it.
* Edit - I asked in PM, but I didn’t see info was possibly here in post one! Please confirm the following is still valid and I will make you BIOS, but I assume above is true

Old CPU = G3900
New CPU = i5-9400F

Old CPU = G3930
New CPU = i5-9400F

Full details in PM.

Yeah, that cover is spring steel. I’ll work on it (on the spare board) a little longer to see if I can find a technique, but it may be time for a programmer. :frowning:

It’s a shame, I really wanted to be able to make my hardware work without having to buy more tools (it’s the principal of the thing.)

If I can’t get it open this morning, I’m ordering a programmer.

Programmer w/cable has been ordered.

Will still try BIOS-only flash, and will still work on that cover for pinmod if time allows.

@MentalNomad - Here is mod BIOS, 906EA+906E9 only, for now, later if you want other microcode can be added back (maybe 1 or 2)
Until you get programmer, all you can do is try Flash BIOS region only via FPTw.exe -bios -f filename.bin

FD/ME will need programmed in, I assume, before you can use the new CPU. You can try it without this, maybe you will get lucky since you are already on old ME FW (my doubts due to FD needs changes flashed in as well)

You may damage the board/PCB or traces etc in the middle of the board, trying to rip that cover out, I’d not mess with it. It may go through PCB, or it may be glued to top of chip etc.

OK, did lock bypass & BIOS region flash was successful… Windows reboots just fine, but I’m still on the old CPU. I think it’s now time to try the new CPU…

Is there any other test I can do to see if it’s pointless trying the new chip? I have a slight desire not to muck up the thermal paste on the (stock) cooler.

On the other hand, I don’t want to wait for Friday (programmer arrives Friday)…

Decisions, decisions.

Well, no good. Got the new i5 in but the behavior was:

Hit power button.
Lights flash and Fans spin for 1/4 second and stop.
Then nothing.

I put the old Celerion CPU back in, now the behavior is:

Hit power button.
Lights flash and Fans spin for 1/4 second and stop.
1 second passes.
Lights flash and Fans spin and system boots.

So, my question becomes:
Is this a sign that we need to flash ME FW?
Or is this a sign that I need to re-check my taping and tracing on the new i5?

@MentalNomad - Great, at least we now know BIOS is OK and you can boot old CPU, in this instance at least

Sounds like you need a good 4-8g tube of paste, you can get cheap 30g of paste on ebay/amazon for $2-3 for testing and save good stuff for final mounts (This what I always use in testing, $2 30g tube last forever)

You may have damaged the board, with incorrect tape previously, or incorrect pads connected, because it should have started right back up when you put in the old CPU again. Clear CMOS to be sure, then try old CPU once more.

The behaviors exhibited with the new CPU, could be what I said above about tape/connected pads, and or as I’ve mentioned all along FD and ME region need programmed in with programmer or unlocked FD before new CPU can function.
But, your lack of function when now putting back in the old CPU makes me think something was off on your CPU modifications. Hopefully you didn’t blow out any traces, check back of board and front, look for lifted or burn traces across the PCB. Check bottom of CPU as well.
Then recheck your taping to be sure that is correct, and confirm you connected the correct pins. Also, look at CPU socket pins, do you see any burned?

Show me image of your CPU Bottom, before you try to adjust anything, so we can see if initial tape and connection was 100% correct.