[Request] ASUS Z170-AR BIOS to support CoffeeLake CPU

Perhaps I was unclear…

With the old Celeron processor reinstalled, the system boots up into Windows just fine:
1. I hit power.
2. Lights flash and fans spin momentarily, then stop.
3. One second passes.
4. Lights flash and fans spin again, system booted into BIOS and then Windows started normally. All is fine.

Subsequent reboots after this do not have the one second pause - when fans and lights turn on, they stay on.

With the new i5 processor installed, the system did this:
1. I hit power.
2. Lights flash and fans spin momentarily, then stop.
3. Nothing else every happens.

I’ll try to get a good picture of the taping/tracing.


@Lost_N_BIOS , pic here.


Hard to get a good photo, but when I did, I saw some dust/adhesive on a neighboring contact which I did not see by eye, even while wearing magnifiers.

I’ll let you confirm I have the correct locations before trying any cleanup, in case I’m in the wrong spot entirely. I don’t believe so, but it’s possible.

I needed to clean off and re-do the silver ink trace several times to avoid bleeding onto neighboring contacts, and it’s possible I "drifted" to the wrong spot over time.

@MentalNomad - Please edit your posts if you want to add more info and no one has replied yet, especially if same day, thanks

I understood with the old CPU all was fine… Until you put in the new CPU. And then yes, I understood all that changed after you put in new CPU, then tried old again too. So yes, I understood all you re-affirmed above

With new CPU, the systems you describe could be short as I mentioned, or you need FD/ME regions written in via programmer.
OR, it may also mean 3504 BIOS wont work at all with that new CPU for some reason, but I doubt this has anything to do with it, and if this was the ONLY issue, then putting back in old CPU would restart system to working state as it was before.
Since putting old CPU back in and you then do not get proper function like you had before, that was why I said possibly something went wrong (short, wrong pads taped/not taped, wrong pads connected etc)

Dust on CPU pads is OK, but clean with alc if you are worried it may be something other than dust
I checked your image, it’s hard to tell if you have the “connect” pads connected good enough. What is that you have on there? If solder paste, add more and heat it up more, does not look melted.
Ohh, silver ink?? Does that dry? If yes, tape off all pads around there, so you can only see those two pins, then you can glob on a good amount and let it dry, then remove tape.
Other than that, it looks correctly done

Maybe do nothing, wait until programmer arrives, then program in BIOS as I sent you and try again.
Since your CPU mod looks OK to me, other than maybe not good connect on those connect pads (but this would only cause non-start), the old CPU should be working again and it’s not, so maybe once you tried new CPU it changed something in BIOS or corrupted it etc.
Right now I will make you new/latest BIOS version too. This way you can try that as BIOS region only flash too, to rule out any issue with 3504, otherwise, wait for programmer so you’re not giving yourself headache over this for nothing.

* Edit - Never mind, I’d prefer you flash that BIOS version and dump then send to me, and you can’t due to no BIOS switches or secondary BIOS, so board is bricked right now
I guess we wait for programmer

Will do.

Putting the Celeron CPU does, indeed, restart system to a working state, but it has a pause on first boot. Do you mean it would have no pause?

Have been using acetone.

Yes, it dries nicely. Good idea for masking off… it’s a fine-point pen, so I’ve been writing with it, but it spreads. Masking should work nicely. I can also test for short with multimeter to confirm those contacts and no others are shorted.

But it does boot with the old CPU. It is not bricked. I’ll go ahead and flash to new BIOS and dump that to you in the morning.

I’ll let you know if the programmer starts moving… the order is made, but I’m getting no shipment confirmation. I suspect nobody is working because of the virus. :frowning:

Ahh, great to hear that Celeron starts OK. Pause on first boot is fine, it probably has to reset some things, then reboots after that should be normal.
Great to hear this, I thought you were bricked and couldn’t even get the Celeron to work anymore. So, all is OK for now, wait on programmer and then just program in the full BIOS I sent you then you will be able to use the new CPU

Yes, sadly many places have been forced to close due to virus, so may have to wait on that for a bit At least you can still use the old CPU and use this board now, which is nice, I thought you were bricked or damaged

I got a tracking notification! It took several days, but the programmer has shipped.

Yes, that’s exactly what it’s doing.

I have flashed the BIOS using EZ Flash 3 to version 3801 and did a dump.

Am sending you the dump; link is in DM.

Nice, hopefully it will arrive soon! I will redo mod on your EZ Flashed 2801 BIOS.
And to answer your previous now edited out question, yes, that is why I wanted you to use EZ Flash to flash the stock BIOS files and then dump with FPT, so all board specifics remained in place.
How did you dump this, and how did you dump the previous backup you sent me, both same way?

It arrived today!

It was flashed with EZ Flash after booting into BIOS.

It was dumped with fptw.exe.

(The earlier backup was dumped with fptw64.exe, but I don’t use that any more, at your suggestion.)

@MentalNomad - Great your programmer arrived! What is your BIOS chip ID? Ohh, it looks like GD25B128C from page one, correct?
I will do your BIOS now… Wait, actually, give me a BIOS dump with your programmer and I’ll edit that, this way you get used to using. Use software version 1.34 and BIOS ID GD25Q128

Here is guide on using - [GUIDE] Flash BIOS with CH341A programmer
And here is general CH341A software, driver needs installed once only, before you start using - http://s000.tinyupload.com/index.php?fil…695330485827902

ASProgrammer 1.41 will also work, and has your exact chip ID - https://github.com/nofeletru/UsbAsp-flash/releases/

Got the programmer working to read; sending links in DM.

Both chips were flashed to 3801, dumped, and 7z together a Ultra.

Links in DM, @Lost_N_BIOS . Thanks, again.

Fixed BIOS sent in PM, let me know how it goes out here in case anyone else needs a variant of this BIOS later (I will rebuild it on stock BIOS for others)

Life got in the way, but I finally got around to getting the chip programmed (with Colibri) and I improved my CPU mod.

I took the advice to use tape to mask off the two pads I need to short, and then applying the silver conductive ink more heavily. Worked great.

New system boots into BIOS and Windows 10, no problems!

Will share pics another night… imgur keeps failing with errors.

THANKS A BILLION, Lost_N_BIOS and chinobino!


Photos on imgbb.com.


It’s OK, life has been a bit of a weird one for us all lately I’m sure, hope you are staying healthy!
Great to hear the masking off of the pads helped a lot with that conductive ink How much did that conductive ink pen cost you?

Also great to hear the mod BIOS is working good for you You’re welcome! Stay safe out there!

Staying safe is getting harder - I’m in a hot spot.

The pen was about $10 US.

@MentalNomad - Hope you can keep healthy my friend!! Thanks, I will have to look into these pens, always mean to get one for random quick tests, but forget to pick one up.

I wonder if he still has the bios. If not or how to modify it correctly. I have the asus z170 p, and the I 5 9400f

@adrianferna Hi and welcome to Win-Raid forums.

I wonder if he still has the bios.

As the final BIOS was sent by Lost_N_BIOS via PM I don’t have a copy of it.

I have the asus z170 p, and the I 5 9400f

It looks like you need a BIOS mod for the Z170P anyway, take note that you will need to isolate some CPU socket pins for the 9400F (as I mentioned above) and must use BIOS v2003 or later (it must have Kaby Lake support).

You should make a complete backup of your current BIOS before you start, using Intel’s FPT (Flash Programming Tool) which I described in this post above.

You can create the modified BIOS yourself using CoffeeTime v0.99 which has a nice GUI that is easy to use.

You can modify the backed up BIOS with CoffeeTime but I would suggest to reset everything to defaults before you make the backup.

You should also record/backup your motherboard’s serial number and UUID somewhere so you can’t lose them (e.g. write them down in a text file).

If you load the backup BIOS you made with FPT into CoffeeTime you should see the serial number & UUID (if you use a stock BIOS from Asus website it will not have your serial number or UUID).

In CoffeeTime you will need to change the Intel ME firmware to version 11.7.1xxx and insert the microcode for CPUID 906EA (make sure to keep 506E3 and 906E9 to support your old Skylake or Kaby Lake CPU).

You then need to patch each of the red areas (i.e. PCIe, SKU, Sync cores, ACPI, FD locks and disable NVRAM lock on the ‘Extra’ tab).

You can optionally patch for Init 8+ CPU cores and 16 thread support (only used for 9900K/9900KS).

Flashing the modified BIOS will be the hard part - I recommend using a hardware programmer as Asus seems to implement mutliple BIOS locks on the Z170 series (as evidenced by MentalNomad in this thread).

It’s almost all there but my Intel ME version is 11.8xxx and I can’t find the 11.7.1xxx version. Any idea where to find it?

@adrianferna Here is ME firmware and 1.5 MB for Consumer H chipsets: (2.8 MB)

You can use Intel FIT (Flash Image Tool) v11.8.86.3877 to downgrade the firmware (or use CoffeeTime as I suggested above, which is a lot easier).

1 Like

Any ideas?
I’m using the CH341A programmer