[Request]B450 GIGABYTE B450M-DS3H enable hidden settings (spread spectrum e.g.)

Hello,
I bought an B450-DS3H and it is missing some BIOS settings.
I’m looking for disabling spread spectrum especially. I’ve absolutely no idea how to do that and if it’s even possible. I just found this forum and saw here are some people who are willing to help out random internet people, wich is amazing. Neither I have any idea what kind of magic you guys are doing, but I just wanted to kindly ask if anyone can help me out with that? It would be awesome

BIOS Version F50
regards

would it be possible?

@MrHugelberg _ I see only the following Spread Spectrum option, please confirm this is what you want disabled

SB Clock Spread Spectrum

It does have a setting under it, but I think it only applies when above is in auto or enabled
SB Clock Spread Spectrum Option >> 0.362% - 075%


This is exactly what I want! I don’t quite understand what you mean by 0.362% - 075% though

I found that you have to set [CPU Host Clock Control] to [Manual] to disable “Spread Spectrum” on other gigabyte mainboards. But I am not able to change that value either. I think I dont even see it on my model

That is the possible settings for spread spectrum when it’s enabled, you can control how much is being applied.
Your BIOS only has CPU Clock Control & Host Clock Value, separability. But, this does not matter, I will hard disable Spread Spectrum for you and it will not matter what other settings are set to or not
Please wait, I will make you BIOS now, be done in maybe 10 minutes

awesome!

Thank you very much for taking the time and helping people out w/o expecting anything in return. Cool to see that!
Probably a dumb question but is it safe to flash that modified BIOS? I mean you will know what you are doing… I just dont want to damage anything so I better ask before.

As long I don’t permanently damage anything and can go back to the original BIOS everything’s fine

Here, flash via Qflash, then shut down, clear CMOS and then boot to BIOS and load optimized defaults. Then save and reboot back to BIOS to make any other changes you need
http://s000.tinyupload.com/index.php?fil…504548202893544

You’re welcome!! I try to help when I can, as much as I can Yes, mod BIOS will be safe to flash
If it was a risky edit, I would tell you in advance, but this kind of edit is not risky. So only risk you have is normal risk of flashing any of BIOS, which even stock BIOS is a risk, so do not flash in thunderstorm etc.
Yes, I know what I’m doing, you’re safe and good to go with this kind of edit

And yes, you can flash back to stock BIOS anytime

@Lost_N_BIOS hmm the BIOS flash worked without a problem, but spread spectrum still seems somehow enabled. My BCLK should be 100MHz flat, but it’s 99.8MHz still unfortunately

That is not related to Bclk, Spread Spectrum locks down leaking or emitting electrical frequencies “Noise” from your system

The only thing that controls Bclk in Intel Systems now is sometimes microcode can affect it, or ME FW mainly (Some versions more than others).
You can never get 100 flat anymore, even if we edit ME FW and try to adjust it’s always going to fluctuate some. Hold on, I will look at your ME FW and see if I can tighten it down for you

Sorry, never mind, this is AMD system! Nothing we can do here Well, you can try other CPU microcode versions if you want, but they’re all going to vary a little bit.
Best to set manually close as you can if it bothers you, sometimes add 0.002 will fix, other times you need to add 0.003-0.004 etc, or sometimes less always = more/better, tinker with Bclk and you will find best you can.

@Lost_N_BIOS Are you sure about that? On my main System (X570 Aorus Ultra) I do have disable spread spectrum as an seperate option and I get 100 flat instead of 99.8 as soon as I disable it.

See my edits above, sorry I was editing while you replied.
If that works on your X570, it’s because that is a more high end board, and probably has the actual Spread Spectrum setting that may be tied to Bclk on AMD (This one apparently does not).
This is budget board and the only Spread Spectrum option is a bug one for SB Spread Spectrum, surely not the same one you adjust on X570 Arous Ultra, I will check it to confirm

* Edit @MrHugelberg - confirmed, those are two different things on the X570 BIOS
Main one you said you changed on X570 - not a setting for this one in B450
Spread Spectrum Control, VarStoreInfo (VarOffset/VarName): 0xE2, VarStore: 0x1, QuestionId: 0x14, Size: 4, Min: 0x0, Max 0x2, Step: 0x0 {05 9A 33 01 34 01 14 00 01 00 E2 00 10 12 00 00 00 00 02 00 00 00 00 00 00 00}
0x29295 One Of Option: Auto, Value (32 bit): 0x0 (default) {09 0A 05 00 32 02 00 00 00 00}
0x2929F One Of Option: Enabled, Value (32 bit): 0x1 {09 0A 03 00 02 02 01 00 00 00}
0x292A9 One Of Option: Disabled, Value (32 bit): 0x2 {09 0A 04 00 02 02 02 00 00 00}

Hidden one from you on your B450 (at least), not same as above one, and this one here is the only one in your B450 BIOS.
SB Clock Spread Spectrum, VarStoreInfo (VarOffset/VarName): 0xB9, VarStore: 0x1, QuestionId: 0x216, Size: 1, Min: 0x0, Max 0xFF, Step: 0x0 {05 91 AF 05 B0 05 16 02 01 00 B9 00 10 10 00 FF 00}
0x314E6 One Of Option: Disabled, Value (8 bit): 0x0 {09 07 04 00 00 00 00}
0x314ED One Of Option: Enabled, Value (8 bit): 0x1 {09 07 03 00 00 00 01}
0x314F4 One Of Option: Auto, Value (8 bit): 0xFF (default) {09 07 05 00 30 00 FF}

Ohh okay. I thought its a setting they are just hiding without a reason, cause you know… companies. Well sorry for wasting your time then :neutral_face:

See my edit above. No worries, sorry this board does not have what you need

I guess you use a Zen or Zen+ CPU? Sadly the SB Clock Spread Spectrum is only working with Zen2 CPUs.


No, I’m using a Ryzen 5 3600.