[Request] Bios (.Bin/.Rom) Z68 Extreme3 Gen3

I think my bios was corrupted (ME Firmware) after updating to P2.30 from P1.30. the problem is like the pc can’t be completely shut down (Dr. debug code 05), it can restart but there is a freeze for a while (Dr. debug code 05/05) and I can’t use a discrete GPU (error code 43) after installing the graphic driver.

I have bought the CH341A Flash Programmer and tried to flash it with bios from the asrock website, then the pc won’t display (dr. debug code 69). Meanwhile, when using the previous bios (the corrupted bios that I have backed up), the PC works but still has problems before.

The bios from the asrock website are of type .30 while the bios I have backed up is of type .bin. So, I don’t think I can directly use the CH341A Flash Programmer with bios from the Asrcok website, and can only use backed up bios. can anyone help me convert bios.30 to bios.bin (not just the type), or send the bios you have backed up?


Note: I prefer the P1.30 bios if it’s possible
Corrupted Bios: https://drive.google.com/open?id=1x9RVSr…bVJfWNTxh9BpcAv
Asrock Bios (P2.30): https://www.asrock.com/mb/Intel/Z68%20Ex…/index.asp#BIOS

Motherboard: Z68 Extreme3 ​​Gen3
Processor: Intel Celeron G530 (Sandy Bridge)

@MKCOTM - All the BIOS being discussed here are actual bin files, BIOS from Asrock named .22 or .40 etc are simply bin file renamed to BIOS version as the extension. Before I do anything, are you SURE you want 1.30??
Or, are you just saying/thinking that now because you had issue flashing to 2.30? 2.30 BIOS may be fine, and would be suggested by me because it’s latest, BIOS issues like that can happen any time you flash so it’s not due to 2.30 version
If you are 100% certain you want 1.30, you’ll have to find that BIOS and give me a link, but again I do suggest you stick with latest for many reasons. If you upload anything else for me, please put it in an archive

What is your BIOS chip ID? And what version software are you using to backup/write? Hopefully your backup is valid and proper, if not This should have been checked before you erased or wrote anything. But, sounds like it’s OK, since you’ve written it back already and then was back to square one.
You probably just needed to re-write a proper ME region, if you think the ME was messed up, but that could only be confirmed by a MEInfoWin report on the original BIOS.
Entire BIOS rewrite was not needed, nor was flash programmer, but since you have it that does make fixing things much easier, sometimes fixing ME is a pain without one.

I see, you tried to update ME FW somehow, correct? Did you have these issue before you did that, or only after?
ME FW version in your backup is newer than the one in 2.30 BIOS, so definitely is not the old one from your original 1.30 BIOS and since newer than one in 2.30 BIOS, you’ve done something other than flash BIOS.
Please confirm and fill in the details of stuff you’ve left out here. For now, here is my questions on this topic >> How did you update ME FW exactly, why did you not choose latest version, what did you do to the ME FW file if anything (Should be something!), and where did you get it?
And now, do you have any backup from before you started messing with the BIOS? This can be from any software, anytime, only needs to be before you did anything.
If you do not, do you have a backup of the ME FW before you did anything to it? A backup of this after BIOS flash, but before you updated it would be preferred, but it may be OK depending on how you did the update