[REQUEST] BIOS for Supermicro X11DPi-NT to support Xeon ES QJW0

Hi, first I want thank you for the work to help people without great knowledge like me.

I have a MB Supermicro X11DPi-NT (supermicro.com/en/products/motherboard/X11DPi-NT) and two Xeon ES QJW0 [CPUID 050651h]. I need modify the bios to add the microcodes for these processors.

The plate has not been used and is as good from the factory, with the seals on the connectors to power of CPUS.

I would like to be able update the bios by IPMI. I already have the key to do it. I have the MB without memory or processors and I can enter without problems by IPMI.

The bios currently in the MB is the latest from Supermicro: supermicro.com/about/policies/disclaimer.cfm?SoftwareItemID=11401


BIOS FILE: https://www.sendspace.com/file/wohj86


I would really appreciate if someone could help me and modify the bios so that it works with two QJW0s.





Greetings to all, Antonio.

Hi, I got an older BIOS for this MB (version 2.1). I know Xeon ES QJW0 on other X11 Supermicro models with this version works.

Anyone know if whit this BIOS will work QJW0 on the MB X11DPi-NT?

Sorry for not doing the test in my MB but before modifying the bios, I want to read your opinion.

Some eBay vendors say that QJW0 requires the latest modified BIOS version and others that an old one will work. That is why I have the doubt.

Thank you for reading

@Fray-Mad - Possibly both will work, old BIOS or new mod BIOS, hard to say without testing. Make sure the old BIOS is for this exact model board!
Test and confirm the old BIOS is working, and then if so I will make you one or two new mod BIOS from new version (only one if you do not have flash programmer)
Microcode is not always the only thing that makes CPU function or be blocked etc.

Thank you very much, I will try and tell you the result. I don’t have a programmer and I can modify by IPMI, so I only need a modified one

it is important to know: Skylake ES are supported by most supermicro X11 UP/DP boards with bios 2.x and older.
the x11dpi-n(t) is one of the boards that DON’T support Skylake ES with any factory bios.
the x11dpi-n(t) needs a modded bios to run Skylake ES.

Not relevant

Not relevant




Hi, already tried both BIOS,

- -This x11dpi_0652.zip BIOS which includes SKL B0 (cpuid 50652) without modifying microcode 50652 to 50651 because I don’t know how to do it.

The result has been that the computer turns on as soon as it has power without pressing the button and does not turn off when the off button is pressed.

Supermicro logo and “Initializing system” message appear in the IPMI remote console preview and don’t progress. I have waited a long time but the screen does not change.

BIOS post is ‘e8’.

In this manual AMI BIOS POST CODES, indicates that this could be the reason:
S3 Resume Error Codes → [0xE8] S3 Resume Failed


– And also tried an unmodified official BIOS v2.1 for this MB and it does the exact same thing.

I ask you for help with this issue and leave you the link so that when you can modify the Latest Version of BIOS, put the 50651 microcodes for the XEON QJW0

Thank you very much for your help.



That’s right, after reading about it, it is one of the few Supermicros that will not work with old Bios

Hi, still have the same problem: I’m not able to get a BIOS for Supermicro X11DPi-NT with microcode 50651 for Xeon ES QJW0.

The Chinovino user offers this ZIP intel_microcodes.zip where apear intel 50651 microcodes for LGA2066. Would work for LGA3647?, suspect not.

I mentioned, have this BIOS x11dpi_0652.zip with the 50652 microcodes but don’t work. I require someone who understands and can replace the microcode name 50652 to 50651. Maybe it works.

Looked at the manuals and tools but only find a way to insert a new complete microcode, not a way to rename an existing one.

I also have the BIOS V 2.1 and Latest Version of BIOS, someone try can put the XEON QJW0 50651 microcodes in some?.

Besides, don’t understand these things and know I’m going to break something.

Would really appreciate your help.


I have the same question. Have you successfully done it?

@Fray-Mad - sorry I missed your post until now!! Do you still need a mod test BIOS made? If yes, what BIOS (link me, or give me post #)
50652 does not need removed, just need to add 50651 (if microcode added is all that’s needed) + Fix FIT Table, if needed

God, I HATE Supermicro’s BIOS naming scheme, or super lack of I guess it would be!!
For X11DPi-NT - I have this BIOS package, what version is that!!??? X11DPI-N_3.3_AS17111_SUM240
Neither of the files you linked in post #10 look anything similar to this (I have not downloaded, just saying based on file name there)
What version is “Latest BIOS” you linked, and what version is that I named above??

Thanks for taking up the problem.

Summary:

- Motherboard (second hand): Supermicro X11DPi-NT
- Processors: XEON QJW0
- Microcode Type: 50651
- Official Bios V 2.1: Link V 2.1 NO WORKING
- Modified Bios (I don’t know the version): x11dpi_0652.zip NO WORKING
- Latest Official Bios: Link Latest Version of BIOS NO WORKING
- How to update bios: Via IPMI
- PROBLEM: I need a BIOS with the 50651 microcodes to publish the XEON QJW0.

Also asqk if it´s normal that removing the microprocessors and memory and updating the firmware, when accessing by IPMI, it says has installed two processors (that I do not have), all the memory modules and a Supermicro power supply. I never installed any of that. Could it be the last configuration that worked correctly or is it that the board is bad?

Thank you very much.
Merry Christmas and Happy New Year.