[REQUEST] BIOS for Supermicro X11DPi-NT to support Xeon ES QL1M


I have the Supermicro X11DPi-NT (revision 2.00) board with two QL1M processors. The motherboard came to me with bios version 3.5 (the latest version). And I haven’t been able to get it to boot.
Up till now I tried the following:

0. I tried downgrading to lower versions of the bios among which was 2.0b trough IPMI with the board’s jumper in manufacturing mode.
1. I tried the same thing with a SPI programmer, I also compared if the chip after flashing with IPMI did contain the chosen bios: they were identical so IPMI flashing is a reliable method.
2. I used MMTool to extract microcode from a older bios in which the microcode for 650, 651, 654 and 652 were still present as well as new microcode from bios 3.5 aka 654, 655, 656, 657, then I opened up the microcodes and the bios 3.5 in HxD hex editor. I used the the microcode files extracted from bios 3.5 to find where the microcode was and replaced it with the microcode from the old bios. Then I padded the modified 3.5 bios with FFs to it’s original size. Finally I fixed the FIT location to reflect the start of each of the 4 microcodes. I then checked with MMtool if the old microcodes were detected on the new modified 3.5 bios and they were. Flashed it but the machine still wouldn’t boot.

In other posts about this motherboard there seems to have been no solution found and I’m not sure what else to try. I’m pretty sure I did the required steps to mod the 3.5 bios as described I attached it to the post (named “3.5replaceAll”).
The original 3.5 bios is also attached named “BIOS_X11DPi-N-0917_20210629_3.5_STD”.
Seems like I’m not yet allowed to post links and the files are too large to upload even when zipped so here are the zippyshare strings.
6nWY2Xow <- modified 3.5 bios
fdYBU5Og <- original 3.5 bios

I hope someone can give some pointers on what else there is to try and if there is any hope to get these ES procs working at all. Or that I’m better of buying something like a 8124M or a cascade lake ES.