[Request] Bios MOD for GA-Z68X-UD3H-B3 (rev. 1.3) UEFI BIOS (USB 3.0 fix, OC setings missing & NVME Support)

Hi Guys !

I wish you a happy new year with many mods and tuning! I am very glad to find you.

I have updated my GA-Z68X-UD3H-B3 (rev. 1.3) from f12 old award BIOS to UEFI U1n AMI BIOS (BETA). Unfortunately there are no OC options anymore like LLC, PLL etc and the 2 rear USB 3.0 ports (Etron EJ168 chip) are not working at all (the 2 front are working great). Also if someone could make me a modded BIOS so these things could work again it would be great if i could have also NVME support.

This is the new UEFI BIOS that i need to mod : https://download.gigabyte.com/FileList/B…ud3h-b3_u1n.zip
This is the old f12 award BIOS (non UEFI) that was OK in OC options and the 2 rear USB 3.0 ports: https://download.gigabyte.com/FileList/B…ud3h-b3_f12.exe

Many thanks!

Happy New Year to you as well

USB 3.0 is a known issue since UEFI launch (2012 or 2013 I think, no fix available other than don’t use the UEFI BIOS)
I can make options visible to you in BIOS, if they are there and hidden. LLC and PLL for OC, this unrelated really Well, I get what you mean, but it’s not something required for overclocking
And yes, I can do the NVME Mod to this BIOS as well (Actually, already did that mod Here)

Show me image of your Advanced CPU Core Features BIOS page & your Advanced Voltage Settings page
There is no LLC to reveal, but I can give you back PLL voltage setting and Internal CPU PLL Overvoltage
While you are taking images, go ahead and show me all of Peripherals scroll up/down as needed, I’m sure there is some hidden USB settings there, so I’ll make them all visible and maybe that can help you get USB 3 working again
Sadly, it probably needs some other modification like ACPI tables or something, which I can’t do

Goodmorning Lost_N_BIOS,

Many thanks for your prompt response
For OC settings i was realy meant the option for not droping the voltage when the CPU is in full load. I have a sandy 2700K and with this BIOS i have a major voltage drop when i do video render. The only solution is to increase a lot the voltage (1.41V i think in idle - i will post the images from BIOS you asked for later tonight ) so when the CPU is @ 100% the voltage will drop to 1.27V for 4.5ghz and 1.32V for 4.6Ghz OC (see attached pics). After that it will fail (4.7Ghz and above) and i do not want to add more vontage than 1.41V. If you see the temps are realy fine (51-52 celcius stable for many hours of 100% CPU usage) and i use just air not water (Be Quiet Dark Rock Pro 3) so i quess that if i had a continuous voltage near to 1.35 - 1.38 i could jump to 5.00Ghz with this beautiful 2700K chip.
For USB 3.0 issue the craziest thing is that the onboard controller works perfect (for the front USB 3.0 panel) and only the 2 rear USB 3.0 are not…



THX again!

Yes, sorry, I was kidding a bit, I know what LLC is for Sorry, it’s not in the UEFI BIOS and it’s not something that can be added on our end.

USB3, it’s probably some mapping issue needs corrected in the ACPI tables, but I don’t know anything about those kind of edits. Some people here do though, but sorry I don’t know them enough to know who to tag to come in here and look for you
I did see over at the MAC forums, they’ve fixed it for MAC via remapping stuff in the files they use in bootloader kexts etc. So it is possible to do in BIOS too I’m sure, but I don’'t know anything about that kind of editing.

I can do the NVME mod and PLL stuff for you though, once you get me those BIOS images. It’s possible some of the hidden USB Settings I’ll reveal to you may help too, but I really think another kind of edit like I mentioned above is needed.
Or, you can go back to the older BIOS and I could update that for you, but on there you can’t do NVME booting unless you use USB Bootloader

The reasons that i don’t want to go back to the F12 Award BIOS is that i have to reinstall OS and loads of software (i have an UEFI installation right now), the old school look (it is a very nice looking mobo to have and old school BIOS - ) and finaly the NVME booting extra
Do you suggest to test the modded bios that you have made for @it.omri ? As he said the factory U1n BIOS worked great for him (he didn’t mention any USB 3.0 issues with U1n - he had those issues with U1m).
In the other hand if nothing works with the UEFI BIOS is it possible to change the boot logo of the old award bios with the new UEFI one? Maybe i could find a way to migrate my UEFI installation to Legacy in order to work with the old BIOS (with no NVME support of course but i choose the USB 3.0 full functionality and the OC settings )

I don’t think you would have to reinstall OS to use older legacy BIOS, but I’m not 100% sure how going backwards works (i’ve written out a short guide on how to clone current MBR OS from SSD to GPT NVME, unsure if it’s that easy other way around?

But yes, NVME booting with USB is nice. I didn’t even notice/remember if he mentioned USB issues at all. Are you saying he specifically mentioned all USB 3 working for him on U1N? If yes, then it should be working for you too.
Ohh yes, I see that now! So, you may need to talk with him about the USB3 then, maybe you need to set something specific in BIOS? You did start with optimized defaults correct?

Yes, I can change logo of the old BIOS if you wanted. And yes, I can write you out a guide how to go back to MBR via clone current NVME to spare SSD with EaseUS software.
I’ve not used NVME with the USB Bootloaders, so not really sure how that works. Have you used it before you moved to the UEFI BIOS? If yes, were you able to boot to GPT partition from the USB Bootloader?
I assume so, seems the only way possible, so I don’t even think you’d have to clone or do a clean install, maybe only edit BCD or something in the bootloader.
I could tag in noInk if you want, I’m sure he could probably tell you what needs done to boot that way and preserve your current OS install.

Yes, if you want, test that BIOS. How are you booting to NVME now, USB method?

I am not booting to NVME (i wanted to do the mod if i was staying to the UEFI BIOS) so it is OK for me staying to SSD. Of course i have started with optimized defaults because you cannot keep anything when passing from legacy to UEFI
I will pm it.omri to ask him about the integrity of his factory U1n BIOS and if he tested your modded BIOS and if nothing works for me then i will flash the old F12 BIOS with modded post logo from you I will keep you up to date

If you did specifically not load optimized defaults after flashing U1N then you are using fail safe, you have to choose to load optimized in the BIOS.
This has nothing to do with flashing BIOS, other than you should start by loading optimized defaults after you flash the BIOS

I have not modified any F12 BIOS with logo? I assume you mean once I do, then you will use it? Keep in mind, old BIOS has much lower res on the boot image, so it will probably not look the same as how it looks on the UEFI BIOS.
I’m not even sure what the U1N logo looks like, I forget and will have to check, it may be OK as low res BMP

Since you are not booting to NVME then it will be easy for you to go back to legacy/MBR.
All you have to do is clone current OS with Macrium Reflect, boot to DOS and use EaseUS to wipe current GPT/partitions (or do same with windows installer media and desktpart) and then initialize it as MBR, then boot to Macrium DOS and restore your cloned image back to MBR
Anyway, if you need help doing that, I can write you out a step by step guide that will make more sense and be easier to follow along

I think that i did load optimized defaults but i can do it again for sure. I will keep screenshots of my OC settings so i can use them again.
About the F12 yes, i meant if you do it, but if the logo looks like ATARI then keep your energy for other projects and not for my trash The U1n logo is the classic Gigabyte UEFI (the same as it.omri’s BIOS)
Maybe there is another way through Acronis True Image for converting GPT to MBR. We shall see when all solutions for keeping the UEFI fails and go back to f12.


Hello to everyone!

I have some updates from yesterday night…
-Loaded Optimized Defaults to my current BIOS U1n but nothing happened with the rear USB 3.0 ports (still dead)
-Flashed your modded bios, loaded optimized defaults and still no USB 3.0 rear ports…
After that i did all the OC settings as before, rebooted and guess what? This is the end, beautiful friend - The End Familiar Gigabyte post loops for ever… After clearing the CMOS with no result i tried a different old 2GB RAM DIMM and finally recovery BIOS appear but when i was placing back the 2X8GB HyperX Savage i could n t boot again. I flashed back the factory U1n BIOS from Gigabyte, my RAM Dimms worked fine, i booted into Windows and guess what? The rear USB 3.0 ports are working fine… Generally everything is working fine, still i have no full list of OC settings but for now i OCed the CPU just to 4.2Ghz with 1.3V and it goes fine.

@kentaurosk8 - Great you got all that sorted out So what do you think, the BIOS I made boots fine right, but then “later” some issue with your memory or OC or something? And then, WTH how does all that fix the USB 3?? Amazing!

@Lost_N_BIOS Yes, your BIOS boots fine, i have booted into windows with stock CPU settings and XMP RAM profile (@1600mhz 9-9-9-27) but after OCed the CPU it crashed and never came back with my RAM installed. I really don’t know if it was your BIOS after clearing the CMOS or the second back up BIOS.

hi, i have the same problem, I have updated from f12 old award BIOS to UEFI U1n. but the 2 rear USB 3.0 ports (Etron EJ168 chip) are not working :frowning:

i have a core i7 2600 , not a 2600k

What do you do for fix th USB 3??


sorry for my english, i speak spanish, i´m from Colombia :smiley:

Try reflash of U1n from within BIOS using Qflash, then if same reflash from DOS using FlashEFI.
After each try, load optimized and save/reboot back to BIOS before checking things out

Hi to all!

Yes, that’s what i did and worked after reflashing using Qflash

A couple of days ago i swapped the GA Z68X with an ASUS Maximus V.
She keeps the 2700K @ 4.8Ghz and 1.35V 100% stable and @50-52 Celsius after many hours of stress. (On air with a Be Quiet Dark Rock Pro 3).
I will try a 5.00GHz OC and let you know

@dieguii ^^ See above ^^