[Request] bios mod nvme for MSI Z77MA-G45

hai. does anyone have bios mod for z77ma-g45 to be able boot from pcie adapter nvme. my current bios version is ms7759 v.1.11 (2013-10-24). Thanks to u all :smiley:

Start working and follow the guide, its a quite easy mod, you can share here your mod file for verification before the flash, perform backups of the current bios on system for safe keeping the motherboard original data.
The resulted mod can be then flashed with M-Flash utility in bios post.

[HowTo] Get full NVMe support for all Systems with an AMI UEFI BIOS - Special Topics / NVMe Support for old Systems - Win-Raid Forum (level1techs.com)

EDIT: So go for it, users who performed the mod on their own Intel_image bios region, will not share it as it contains its own motherboard data, only the ones with a mod from the “Blank” MSI bios update file.

yes, initially I wanted to try it, but still in doubt. so I try to open this feed, for requests, who knows someone has it :sweat_smile:

Do not use M-Flash as it could corrupt the system (tried in both Z68A GD65 G3 and B75 G43), flash it by using intel fpt using the command "fptw64 -f -bios E7759IMS.1B1 " (copy paste the bios file to Win64 on flash programming tool\Win64 folder, then run cmd as admin, then redirect using cd /d Directory to Win64 folder of Flash Programmer Tool (example: cd /d D:\FPT)), then reboot or do fptw64 -greset.

OR you could try to flash using DOS version of intelfpt, just make a dos drive using a pen drive and rufus, copy paste the contents of DOS folder directly to the DOS pen drive and copy paste the bios you want to flash to the pen drive, and use the same command i told above. DWYOR

Bios and the required FPT:
Z77MA-G45 Mod.rar (5.4 MB)

Is safe for z77ma-g45?

it should be safe. just read the post.

Why use ftp not m flash?!

If use MMTool v4.50 is safe for pad module?

Because there is a chance that the M-Flash would corrupt the bios.

I myself have experience it using Z68A-GD65 G3, my friend too using B75A-G44. so dwyor.

MMTool. UEFITool is involved but only for updating some modules. replaced needed files from dirty updated bios to a clean bios using mmtool, verified no padding destroyed.

Can i run FTP on windows 10 x64, legacy mode. And after mod bios, can i flash back again official bios by m flash

yes, u can safely flash official bios using mflash even after u flash modded bios using ftp. im just saying that mflash at that era (6-7 chipset) tends to corrupt modded bios.

the hex code structure became wierd/destoryed if mflash used, ik that after i extract the corrupted bios after a failed flash using mflash.

Done…fix and solved, but if i use nvme max mode, my vga card run pcie3 x8, and nvme run pcie3 x4. Its best option for msi z77ma-g45

So in the end did my bios work? also, what method you use?

Yep, it ran on bifurication because it was listed as 16 or 8+8:

I flashed it from oficial B0 to B1 (mod bios). But the shutdown took a while, do I need to remove the cmos battery? Or is it because the windows on the HDD are running legacy MBR format, so I have to install new windows with uefi and GPT format? Usually windows shutdown takes a while due to software or driver problems

how long does it take?

30-60 second
I’ve been buying nvme+adapter, so im not yet test with nvme

Thank…bro, for your mod bios…good job👍. Shutdown fix, now just under 15 second…return to normally.
Where are you get SAMSUNG_M2_DXE driver? Official?

extracted from asrock bios (haswell chipsets), the same that is being shared here.

For your long shutdown, i dont really have a clue abt that, since the bios is just mostly adding the nvme and m2 ahci support, with GOP updated for efi and orom (you could check on gpuz for the igpu it is version 2171). But the thing is, i always do a clean install of windows whenever i want to use the new ssd for OS.

With that said, you could manually install chipset driver from here (install manually because this is .inf file) and management engine driver here

the driver i gave to you is the latest available for those chipsets, far from msi and WU driver.