[REQUEST] Bios Mod to Support Ivy-EP on Old x79 Mobo

Hello. I’m stuck with my motherboard, i bought a cpu (Xeon E5-1650 v2) that won’t work. The cpu works with other motherboards but not with mine.

Assuming that this CPU works with other motherboards like Xtreme4(atx), extreme6 and xtreme11, is possible to make it work with my mobo?

I can pay for that, is anyway easier than sell it out and buy a new CPU. The motherboard is ASRock X79 Extreme4-M.

I attach the Zip of my Bios actually installed. Hoping someone can help me. Cheers and thanks, E.

Edit: I tried to: Update microcode with UBU, nothing; Swap CoreDXE and CorePEI from x79 extreme4 regular BIOS : no results.

X79 Extreme4-M(3.40)ROM.zip (4.81 MB)

Seems that was already tried…and u checked/posted


Yes, i followed up DeathBringer’s instructions, but intel ME won’t update at all, it just stay at the same version after the update, i really don’t know what to do …

U advise to sell it out or you think i can get it to work? Error code 00 made me really mad, i really can’t understand why every other x79 boards support it and my motherboard not… :frowning:

I wouldn’t give up. Maybe cross flash bios from Asrock mobo working with your cpu - if you have programmer in hand?
If it wouldnt work, maybe get ME from Asrock working mobo, put it in FITC tool and transfer settings accordingly to make the new ME image, than flash.
I would bet your Bios has the code working with Xeon already, even my obsolete old H61 OEM bios, it has support for Xeon cpu’s
Here is example how to transfer ME settings from @plutomaniac
Little help with update H61 chipset to ME 8 version for Ivy bridge support
I am not sure if it could help, but chipsec has module that can verify if your uefi is white listed against the standard uefi images.

I’m not giving up man ! I really want to make this CPU working on my mobo, is really weird that isn’t working.

Intel ME is the second weird thing. I updated me with the right procedure, but it just stays the same. It not updates at all.

Using UEFITool every board has the same ME version, , even the board where xeon works .

@DaCou how can i take the ME region from a bios to another? BTW my intel ME verison is the same of other boards that support xeon v2 : , and this version should support IVY-E

Its so weird. I injected EVERY uCode of x2 Xeons: nothing. Same 00 Error.

Sorry for my english

Its not bios related as its never even processed, as long as u see 00 code.
So no ME or newer uCodes will effect on bios, as the system cant even process bios/post.
The cpuid 206D7 (Sandy-Bridge 32nm) and 306E4 (Ivy-Bridge 22nm) is already in latest bios…so it has to be a design limitation due to Asrock choice.

Ok, so i will sell out the CPU and buy a new one.

I want to thank you all to the help you gave me, i’m grateful and happy to see expert people in this tricky things help out dummies like me.

Cheers, E

ME is black box, and the same version of firmware doesn’t mean ME is same.
There are some manufactured fuses stored, the boot guard starting here for example and many more. At the link I send you can find approximate guide for transfer settings.
I would even don’t worry about flash ME from different mobo if you had programmer and time for it.
The error 00 is for for debate, how would pc send the message if Bios not inicialized at all?
But maybe it is right, but again I searched Bios of Lenovo B320 in disassembler (look what the machine crap is) and there are some setup strings which are for Xeons to get inicialized.
You told you inserted bunch of ucodes and nothing. I would recommend you keep checking the ucode version (maybe in CPU-Z?) after your attempts as well.
You can phisically get ME from different machine by “fptw64 -ME -d ME.bin” if it has unlocked FD region.

I got a CH314A programmer. I think i will try to flash the xtreme4 (ATX) bios into my mobo, just to see if it works. If the machine boots with the Xtreme4 bios, i will think up to make an hybrid bios to make it work properly.
If it not boots, the CPU is already on the Bay, i will sell it out

I flashed the Extreme4 Last bios. Nada. Nisba. Nothing. It boots up with my 3820 but with the 1650 v2 no way to make it work. 00 error. Bad choice for me to buy this cpu.

Appreciate your help. E

Okay so that bios is working with Xeon but on the different machine?
Than ME could be on the blame. It is hard to say…