[Request] Bios modding for M5A97 LE R20 for NVME disks OR NVME modules.

Hi everyone i am new on this forum, I want to install windows 10 to NVME disk with PCI adapter and i dont find the correct modules, please can you help me?

The link with the Bios download is: asus.com/gr/Motherboards/M5A97_R20/HelpDesk_Download/

Bios Flashback ONLY, NVME inserted, modules and mCode updated.

Asus M5A97 R2.0 Bios 2603

*Even after the user provided wrong info on the model upon his initial request (M5A97 LE R2.0), ill keep here here this mod
as the others related threads (M5A97 R2.0) offering same mod are not totally valid.

Sorry for the delay but the bios didn’t work, in BIOS update stop and Pop up message security verification failed, i think this isn’t correct because the model is M5A97 LE R2.0. Thanks in advance.


*Please do correct the topic of ur post to the right model

Well not my fault if u provided the wrong model of ur motherboard, u SHOULDNT even try to flash another bios model, off course it fails…its not he right model and i said ONLY for Bios FlashBack as its a CAPSULE bios, i didn’t told to use in bios Asus EZ function update.
The M5A97 LE 2.0 doesn’t have Asus Biosflash Back feature, so i will not provide here a bios mod for it.
Ull have to do it urself and follow the guidance provided here:



Sorry it was my fault from the beginning, i tried to do it myself before opening the topic but the module files from ( How to get full NVMe support for all Systems with an AMI UEFI BIOS ) do not open. Can you help me or send me where I can find those files.
Thank you very much for your time.

Seems that u do not like to read, i gave u the links regarding what to do and how to do it, everything needed is there and the download links r working.

I read very thoroughly. module files from all DX_3 and DX_4 do not open. I made the change to the BIOS with DX_2. As soon as I can test if it works I will upload the results here. Thanks again.

Well…maybe u dont care if u broke a motherboard…but guidelines r provided there for reading and to try to minimize the risks of the operation, i learn when i read information…how do u learn? foto memory or simply dont care about it?

Only one module is need, the standard size or the small size, depends on space available in volume bios.

a) “NvmExpressDxe_4” module (bigger sized, but completely optimized for the purpose of this thread):


b) “NvmExpressDxe_Small” module (much smaller sized, but with full functionality):

The files you keep sending me the links have a problem, here is a photo.
If you can, upload them again so that I can do the mod.

Thanks again.

Ur problem on ur side only, file/rar archive opens correctly…seems only u cant open the files, since i dont see any complains about it from other users.

You need to update your Winrar version, or use 7zip From the top of the spoiler >> You have to use WinRAR v5.xx or 7-Zip from v18xx up to be able to unzip the offered RAR archives

I did the winrar upgrade and it opened just fine. I feel so stupid. sorry for all your inconvenience. I also thought that only I wrote complaints and fortunately only I had a problem. I honestly did not even think about winrar. i am so sorry.

@nikos_pc - It’s OK, you just missed the notice on how the files were packaged
Good luck on the modification, flashing, and system setup now that you can carry on

I modified my BIOS and in flash it wthout any problem. Now after all BIOS settings is done and triple check i try to install the windows 10 and in the last page they show this problem. Window’s cannot be installed to this disk. The computers hardware may not support booting to this disk. Ensure that the disks controller is enable in the computers BIOS menu.

My current settings in BIOS is
Fast boot disable
Secure boot other os
Launch csm enable
Boot device control uefi and legacy oprom
Boot from storage device both uefi first
Can you understand what I am doing wrong? Thanks again.

Hi Meatwar. I was browsing the forum and was WAY above my skill-level. But then I saw that you had modded and posted a BIOS for my Mainboard!
But the link, on www85.zippyshare.com/ gives a 403 FORBIDDEN error.
Would you be kind enough to post it again somewhere, please! (or send it to me?)
Thank you!
I promise I have checked, it is the correct M/B and BIOS!

(I am not allowed to post links or pics, yet, even in quotes!)

I just tried it via a VPN/Proxy (the zippy site is blocked in the UK,) And it tells me that the file is expired and no longer exists…!

Vielen Dank!

Hi MeatWar !

I saw that you uploaded the modded bios for M5A97 R2.0 on the first page, but the link doesn’t work anymore and I can’t find nowhere …

Can you re-upload or pm me the file please ?

Thank you !

[HowTo] Get full NVMe support for all Systems with an AMI UEFI BIOS