[REQUEST] BIOS To remove UEFI boot option from XFX RX 580 4GB


I have a Gigabyte GA-Z77X-UD3H motherboard and the RX580 does not post or boot. I’ve tried updating my mobo bios, changing around CSM settings, disabling secure boot, downloading windows in legacy only, downloading in UEFI only (using a GTX 660 which does work and has signal). The same RX 580 boots on my other computer in legacy mode. Nothing seems to work and from a look online it seems to be a common issue.

I think the motherboard is trying to boot in UEFI but not able to successfully. So, I think my only resort is to have the bios modded for the RX580 so it only boots in legacy mode. I tried myself but I am not sure what I am doing. I’ve attached the bios on my card currently.

bios.rar (50 KB)

@RoadToS - This is confusing, what do you mean >> downloading windows in legacy only, downloading in UEFI only << Do you mean OS Type setting >> Win8 = GOP/UEFI mode or Other (= Legacy mode)
If trying Legacy mode, you should set OS Type to Win8 + CSM enabled (Other PCI Device ROM Priority should be set to legacy as well, but you can try both)
OR OS Type to Other + CSM enabled + Other PCI Device ROM Priority set to legacy + Secure Boot Disabled
If trying to boot GOP/UEFI mode >> OS type set Win8 (not WHQL) + CSM Disabled + Other PCI Device ROM Priority set to UEFI + Secure Boot Enabled or disabled
Be sure you are using latest BIOS, F20e suggested!

What revision motherboard do you have? It’s in bottom left corner.

Here is three vBIOS mods, one with updated GOP, one with updated magic GOP, and one with GOP removed.
With any of these, you may need to patch the driver, but especially so if you want to use one with either of the updated GOP’s
Atikmdag-Patcher is what you need, see first spoiler here - https://www.overclock.net/forum/67-amd/1…x5xx-rx4xx.html
BIOS does not need patched, only the drivers, so do not rename the file when you download it, just run atikmdag-patcher.exe

Wait a minute! What is the above vBIOS, have you edited it at all, where did you get it? What brand and exact model is this?
This is either a pre-modified vBIOS with GOP removed already, or a broken vBIOS maybe? There is no GOP module in there, which I’ve never heard of or seen with card this modern!??!

If you modified it, please give me the original dumped vBIOS, so I can edit it and so I can check your edit.
It looks OK, maybe, but unsure without seeing the untouched vBIOS, that is a lot of 00 fill where I would assume should have been FF fill


Thank you for the detailed response!! Sorry about the convoluted message! I am a bit confused myself after trying to put together this computer. What I meant was that I tried various different solutions that worked for others in forums around the internet such a the OS type Setting but none of them seemed to work for me. I tried both firmware F20e and F18 and they didn’t seem to do anything either in terms of allowing the RX580 to post.

The revision of the motherboard is 1.1.

I bought the card second hand from a seller locally last week and he pulled it out from a working computer. He bought it from eBay and was selling as he upgraded. I looked at the vBIOS code in a Hex Editor but I didn’t change anything at all. I tried finding the GOP section using Ctrl-F but nothing came up which seemed a bit odd.

I have attached the GPU Z screenshot, let me know if you need anything else. I’ll attempt the 3 vBIOS linked and let you know how that goes. Thanks once again for your response!

EDIT: I can’t seem to find the vBIOS files, are they attached to the message?


@RoadToS - So you saw this card running, when pulled out? If yes, OK
This is either rare XFX stock BIOS with no GOP, or someone already removed it incorrectly (or in odd/not how I would do way) << probably for mining or something, and this may be why it’s not working smoothly for you too.
I did not attach the three BIOS I mentioned above. I wrote that above before I looked at your file, then I stopped to ask what was really going on there

Is this the card - https://www.techpowerup.com/gpu-specs/xf…lack-wolf.b6404

I don’t see any vBIOS that match the above spec (all diff core speeds) - https://www.techpowerup.com/vgabios/?arc…ize=4096&since=
Even the 8GB version speeds don’t match that. So not sure what to grab for you to test as a proper stock BIOS, or which to check to see if these should have GOP or not

Aha! Here is correct matching vBIOS (however, sadly, this may be the exact same legacy vBIOS that does not work for your system!?)

I checked this vBIOS ^^, and it’s 59KB, with no GOP either! But, it’s 100% hex match to the first 59KB of the BIOS you provided, so this is exact same stock BIOS, but without the added stuff and incorrect padding yours has
In the BIOS you attached at post #1, I am not sure what the info is starting at 0x37000h - Maybe @Sylar76 can check and let us know?

Meantime, please try one of these two BIOS, both with GOP added (one normal, one magic). As mentioned above, once in windows, you may need to apply mod/edit to drivers before they will load.
For BIOS, set BIOS stuff to UEFI Boot, CSM disabled, OS Type Win8 - this way the GOP is used instead of the legacy vBIOS, which we already know is a fail on your board. This is the above linked 59KB BIOS, with GOP’s added as noted + padded out.
Ignore the “may be corrupted” message in the info image for the Magic GOP UPD, this is normal and expected, because that is a magic GOP

Additionally, here is that same vBIOS, but just as-is, padded out to 256KB, without that added info/table I mentioned above, in case that is what’s breaking compatibility with your system
This is legacy vBIOS only, so cannot be used in UEFI / Secure boot mode, unless you enable CSM and legacy video option rom loading. Sorry, I didn’t think to make this until later, so not included with above GOP UPD package

@Lost_N_BIOS Yep, that is exactly what the card looks like.

I appear to have bricked the card, there is no signal at all on either system I have. I tried using the little switch on the card to use the other BIOS but the switch broke.

So I think my only option is to flash a different vBIOS on to the card? But, I can’t do that with the system that was able to detect the card as it does not have onboard graphics so I have no display. I can’t add another GPU to that either as it only has 1 PCI-Express slot.

I only have onboard graphics on the motherboard that doesn’t seem to detect the RX 580. When I try opening ATI flash on this I get a message similar to “cannot find discrete ati video card.” So, I tried booting in FreeDos with atiflash and force flashing but it can’t find the RX 580 and I get the message “no adapter found”.

I think my options are quite limited so I’ll try to get hold of another motherboard with onboard graphics to try flash the other vBIOS unless there is some other option?

@RoadToS - How did you break the switch!! You never confirmed >>So you saw this card running, when pulled out and sold to you?

Your best bet is to get this on another board with two PCIE slots using a second main card, or a PCI + PCIE slot and use PCI card from old system. Onboard graphics are often not ideal for this.
What a minute! Z77X-UD3H has more than one PCI and PCIE slot, find a second card in another older system to borrow, then try using that as main graphics source, disable the onboard, then connect this 580 as second card

Are you sure it’s bricked? Did you flash any vBIOS, if yes, which one? And, after that, did you then run the graphics driver patcher I linked you to (This is a MUST, otherwise it will not let AMD driver load)
As for DOS, it should work there, but I’m only positive about that if/when using a second PCI or PCIE card, I’ve never done from onboard graphics so not sure if that is an expected fail or there is some other issue (ie something, like BIOS, shorted out when you broke the switch)

@Lost_N_BIOS Alright, this has been a roller coaster but the card is booting at last!!

So today, I bought another RX 580 (Sapphire Nitro+) for another build and I tested on the Gigabyte Z77 motherboard and I had the same issue as with the XFX RX580. The motherboard was not detecting the card at all. So, just out of curiosity I pulled the motherboard out of the case and tried the second PCIE slot on the motherboard and for some reason that worked allowing the Sapphire RX580 to display. Then I tried the first slot again and same issue the card just would not detect at all.

Using this knowledge, I put the “bricked” XFX RX580 in the second PCIE port and it started detecting in windows (while using onboard graphics) but there was still no display. So I went through flashing all 3 vBIOS (Normal added GOP, Magic GOP and the OG BIOS Padded) but all of them led to black screens upon booting. Then I tried the original 59kb ROM and that allowed the card to display.

So it seems there is some sort of weird issue with my motherboard as it can’t detect newer cards in the first PCIE slot but older cards (GTX 660) seem to work fine. This also explains why the card was not being detected in DOS at all as I kept getting the “no adapter found” message. But I am confused why the padded vBIOS didn’t work as it’s essentially the same thing right? Anyways, in a way it seems I’ve come full circle, if only I had tried that 2nd slot earlier. But, on the bright side everything is working fine now.

So, thank you so much for your help! You are actually a legend. I was so lost trying to figure it out.

@RoadToS - At least you got it working now! Yes, I would assume padded 59KB would work same as 59Kb, unless when you flash in that 59Kb the chip was not erased first, so whatever remains after 59KB was still there.
Try the original dump you sent me, this was the same as the 59KB too, except some data (Not legacy rom, or GOP, not sure what it is) after that at the offset I mentioned, maybe that remains there and reflash of this OG BIOS would work too?

First slot issue is odd, when you tested the other with GOP, did you wait long enough for windows to load? Sometimes BIOS/POST may be black, but then windows loads. This just means you need to get right/other settings in BIOS, then you’ll be able to see POST/BIOS
Does that slot show as full x16 width, when you test it with a known working card? If not, maybe this slot is damaged, or you have bent CPU socket pins?

You’re welcome, glad you have a bootable card now at least!