[Request] BIOS Unlock - Acer Predator Helios PH315-53-57VP

Hi, I really need assistance in unlocking bios, I wanted to check if my dedicated GPU is enabled in BIOS advance settings, but as I notice the advance settings is only limited to 2 options: Intel VTX and Intel VTD

My Bios version is: Insyde Corp. V1.09

Notebook Specs:
Acer Predator Helios 300 (PH315-53-57VP)
CPU: Intel Core i5-10300H
GPU: Nvidia RTX 2060
SSD: WD WDC PC SN730 SDBQNTY=256G-1014 256GB
HDD: Seagate ST1000LM049-2GH172 1TB
RAM: DDR4 16GB Dual Channel
MBD: Acer Predator PH315-53

Hello. I can help you. Is there a reason you are using old bios (latest is 2.04)?. And do you have hardware programmer?

Hello @peanutsareokay

Thanks for the reply, and no actually there was no specific reason why im using an old bios, its just that i haven’t check. let me check if I can update my BIOS

and sadly no, I do know have a hardware programmer, nor do I actually know how to use it.

I just updated my BIOS to 2.04. but I still dont see any other Options in Advance Settings in BIOS :smile:

Ok. First of all, I hope you fully understand, that your actions can temporarily break your device, especially if you dont have programmer near you. But, if it will happen, I’ll help you, but please follow instructions precisely. Better ask one more time, then have your device broken.


  1. Download this archive and unpack it: Download BACKUP_Tools20i2.7z from Sendspace.com - send big files the easy way
  2. Launch the exe inside (this tool will backup your bios and check, if you can write back to bios chip without programmer)
  3. On your desktop archive named result20.rar will appear. Upload it to filesharing service (i.e. sendspace) and post download link in this thread.
  4. !!!IMPORTANT!!! Save this archive (result20.rar) somewhere outside your laptop, so in case something bad happens you will have fully working bios backup on your hands

Then, I will try to mod your bios
If any problems will occur, dont hesitate to ask

Yes, I do know that this might break my device! Thanks for the heads up.

Question before I proceed with any of this, as I read on the step 4, if in case something bad does happen how can I proceed just in case?
I do have an external Hard drive where I can store the file.

Will that be enough to just plug the External Hard Drive to my notebook?

Or can you kindly explain further in detail to me.

Here’s the file for my result 20

Also, I can try to update cpu microcodes, if you want. But know that recent updates brought fixes for some large vulnerabilities, so fixes can, in some cases, lead to decreased performance in some tasks

If it might decrease the performance then you can skip in updating the cpu microcodes ^^

Ok, no problem.

So, first of all, check once again that you saved result20.rar somewhere outside of your laptop.

That do this:

  1. Download and unpack this: Download packed-mod.zip from Sendspace.com - send big files the easy way
  2. Launch “1. SET VARS”. Reboot. IMPORTANT: If laptop doesnt boot to windows - check, that you switched back to AHCI (if you are using this instead of Intel Optane Raid (you can reveal this submenu by pressing Ctrl-S)).
  3. Once booted back to Windows, launch “2. FLASH”. If no error was shown - reboot. It may reboot a little longer due to updating the bios (you won’t see any messages, its ok)
  4. Once booted back to Windows, power off laptop. Now you can access the bios. Settings will be in new Advanced settings tab. In some places you can find line without text, but with values. Better dont touch them, cause I’ve unlocked everything, but some settings are without descriptions.

If something goes wrong - dont hesitate to ask. But remember you are responsible for your actions and your manipulations with laptop.

1 Like

These are not settings. You could left them hidden. Also, in a stock BIOS, sensors information lines are greyed out. They represent data, read-only variables. Also could left them untouched.

Thank you for your work.

1 Like

Hey thanks for the instruction, All the procedures you have given worked and the advance setting was able to show the other setting which was hidden before.

After trying to changing the Graphics Mode: from MSHybrid to dGPU, seems like my laptop went black screen or rather it was able to boot up but no Visual was being shown. I had to make a rough SetUp Default in the BIOS menu and now it works again!

Lesson learned to not always mess with stuff like this i guess, but it was a fun experience! :joy:

Cheers for helping me out :smile:

Glad that I’ve helped!