[Request] Bios unlock for Aorus 15p xd

Hello! I have never unlocked a bios before but i am trying to enable XMP on my Aorus 15p xd and was hoping for some guidance!


Hi friend: use this tool , run it as Asmin and upload here the result file :


Let me know

Attached! Thank you

results20.rar (69.1 KB)

Hi friend, this result file is empty , try to do this …

It turns out the way to allow BIOS backup access is to disable secure boot which on this laptop does not have the normal menu.
Instead you need go to “BIOS->security->delete all secure boot variables”. After doing the backup you can then restore the variables for normal function.

Then make again the result file and upload it …

Or use this tool , run Dump.bat by double click on it :


Let me know

just attach the biosreg.bin file generated by dump.bat? or do you also need me to go through deleting the secureboot variables


Where is the file ? i need to unpack it to find the NVRAM Variables , i haven’t your pc and haven’t any bios file from your pc.
Please as you cannot do , link me to a stock bios download link …

I found this X5LVBFB01.rom here is the link :

Let me know if it’s right ?

Yes that’s right, that’s the current version I have installed

Ok friend, these are your NVRAM Variables to unlock , then follow the tutorials and use RU shell to do it.

FPRR VarOffset - 0x683

BIOS Lock VarOffset - 0x1C

Find this GUID PchSetup [4570B7F1-ADE8-4943-8DC3-406472842384] and then the offsets of varibles.

Look here :

[Request] Gigabyte Aero 15 OLED BIOS unlocked (36)

Unlock the Eeprom and make a bios backup using this tool , run Dump.bat by double click on it :


Let me know

sorry for hijacking the thread but how did you update it? i downloaded the file from gigabyte’s website and when i try to install the bios, it just restarts and doesn’t do anything. i tried using afudos but it says file is corrupted. tried downloading it again but no change. i am on FB03.

AORUS 15P XD 11th gen.


Hi friend, i didn’t understand what are you trying to do … so if do you want to unlock your bios , you have to make a result file using this tool , run it
as Admin and upload the file here :


Then if do you want to update your actual bios version it’s different thing.
So let me know

i am just trying to update from fb03 to fb01. thank you for the fast reply.

i have tried updating using UEFI SHELL, COMMAND BOOT, AFUDOS, AFUWIN, BGTWIN and a lot of other flashing utilities. always either unsupported or bios file corrupted.

weird thing i noticed was the bios date in the website is from May-2021 but the actual file downloaded is from June-2020



Hi friend, as i wrote before , use this tool run it as Admin and upload the file here :


If i cannot see your bios (bios backup) i cannot say nothing about the downgrade and if your actual bios is compatible with FB01 …
I know that everyone would to be understand and followed, but we cannot see into the crystal ball and know all :wink:
So please let me see your bios and i will reply about the downgrade, may be we can do it by FPT tool too …
So let me know

@BDMaster hopefully this is what you asked for.


It’s empty so not usefull , it means you are not running it as Admin or have a Secure Boot actived … look here :

[Request] Gigabyte AERO 15 OLED 3060 11800H KD (undervolt) (2)

Or friend, please use the HWINFO64 tool and post the ME version shown by tool :


Then i will give you the tool to make the Bios Backup …


@BDMaster i tired using the tool again but it is saying access denied even though secure boot is disabled, and i am running it as admin.

i used HWINFO64 to get the version.

Intel ME.png

Ok friend, try this onr, unpack and run the Dump,bat program by a double clivk on it , then upload the biosreg.bin file here :


Let me know

Here it is.

@BDMaster i tried updating the driver but it said that my version is newer.


Ok friend, your bios has this infos

BIOS platform - AMI Aptio 5

So it is version FB03 !

I saw for your pc there is only this version nb-bios-aorus15p-vb-win10-64bit-fb01-ec-f001.
I cannot get the real informations of this bios (it seems like you make some mod and the system data are corrupted).
I think you flashed the FB03 from Aero serie, this one nb-bios-aero15-vd-win10-64bit-fb02-ec-f003 ,
as the bios is the same, with few differeneces.
So if do you want to downgrade to FB01, we have to force this and you can risk the brick.
You can buy an SPI Programmer CH341a with Pomona clip , cheap $.15,00 and be sure to recover you eeprom, or try anyway to downgrade …
Before all , please using the tool i sent you, open an text editor and modify this command row, into the Dump.bat :

fptw.exe -d biosreg.bin -bios

With this one :

fptw.exe -d spi.bin

Then save and exit (check the extension .bat) and run the Dump.bat again to make the Full Firmware backup , then upload it here.
It will be the pc recovery firmware if we will need it.
Let me know

P.S. we can unlock it too, if you will unlock the eeprom write protection


This is the bios that came straight out of the box with the laptop. how is it possible to ship with the wrong bios? Aero has RTX 3070 105 tdp only while the Aorus 15p comes with 125 boosted to 130. is it possible that i am losing performance that i paid for because of it ?

can i recover from the brick and is it a high chance of brick?

if i order one i will have to wait at least a week to get one from amazon since i don’t live in the us.

i tried changing the code and running it but i got an error.