[Request] Bricked BIOS - Asrock X370 Taichi

Hi all,
i wanted to change my running system with Ryzen first gen CPU into a gen 3 this cristmas.

The Bios before the upgrade was only fit to run with the gen1 (Summit ridge) so to get it to run a biosflash was needet.

I flashed via EFI Shell but did not do a backup of the running Bios beforehand.
BIG mistake

before flashing i did the compability check and i got no errors.
fs0:\EFI\BOOT> AfuEfix64.efi existingbios.rom /d

the flashing i did with this command.
fs0:\EFI\BOOT> AfuEfix64.efi existingbios.rom /P /B /N /K /X /L

the flash failed on "Erasing/Uptating NBC Block around 40-50%

I tried multiple times to get it to flash properly but it always faild at the same point.

After N.tries i gave up and powercycled.
Now i have Fanspin, no postcode, ofc no post and power button + reset do not interrupt
It´s a BRICK


I did research on how to fix this,

so i bought a CH341A programmer(black pcb) with adapter and Probe-Clip

Software i use with the CH341A atm is: NeoProgrammer V2.2.0.10

Winbond 25Q128FWSQ
Supplyvoltage is 1.8V (datasheet of series says so)

Desoldered the Chip, because CH341A couldnt find/read Data from it.
I guess the lenght of the Datalane-traces on the Board is producing to much wave impedance to use the signals.

;Desoldering worked and the Bios images i saved for comparrison with HxD all match.

I tried/still try to unterstand how to translate the Bricked-Bios.bin with UEFITool NE 59a so i could backup Mac adress, UUID, SN… to put it into a Bios from asrocks supportpage but the HEX values i see in there, are gibberish to me.

Can someone pls help me i´m stuck here

If you have read this far, thx for your time
and may my enlish be readable

Post a link to your dump (some spaces will do for the link)

From which bios version to which version did you triy to update?

brick happened i think from 2.30 to 6.62

for some reason i get error warning im not allowed to post links so pls add https: at beginning


6.62 is a beta version with zen 3 support


You can see where the brick happened, you lost the structure of the second last EFI volume. Last EFI volume is still 2.30… There’s a lot of changes in structure since 2.30 and the website list 2 versions one shouldn’t miss- 3.30 and 5.10- when updating from older versions.


I’m sorry, but I can’t help you here in a good way. It’s unclear to me what these large padding areas contain and if the structure has been changed in 3.30 and / or 5.10. NVRAM is very short, doesn’t seem to contain machine specific data. They might as well have changed NVRAM data structure, too, and machine specific data are already overwritten because of new bios structure…

There’s one possiblity to add the last missing parts from 6.62, hoping that the update anyway kept the right things from the old bios in the fist part of the bios and just failed updating the last part. But that 's as optimistic as to update directly from 2.30 to 6.62…

If this won’t work it’d be flashing stock 6.62, check what’s missing make a new dump and compare it to stock, this way narrowing the area to search. Maybe nothing is lost anyway. Asrock has at least a tool for updating MAC address, which hopefully would work for this board, too.

If you want to try your backup with last volumes updated to 6.62: Rename the files to backup-rom-01 - 662.zip.001 backup-rom-01 - 662.zip.002

backup-rom-01 - 662.001.zip (6 MB)

backup-rom-01 - 662.002.zip (4.37 MB)

hanks for your help,

im gonna try your two variants first.
if this isnt the charm stock 6.62 it is

i found the mac adress + sn and maybe part number of the board

would it be easier to take a stock 2.30 put in the data i found, burn the bin and update incremental or
better use this asrock mac updater tool on the running stock 6.62?

Within the bios- dump? Which address?

no on the system ssd

i dont know if this helps any

No, that’s normally on a sticker on the board and/or the package, too. But one needs to know how the vendor decided to store it, that’s impossible to find out if you don’t get a dump from another working same version/ close to version bios. There’s one region from E8000 to F23B0 that’s not part of the stock bios, but looks more like settings- there’s at least no readable information in it. Maybe Asrock stores this information outside bios? Maybe it was stored a place where it’s already overwritten now because of changed structure?

It’s just to try now with the 2 steps described…