[Request] Dell ACPI patch for XP64

I’m trying to install Windows XP x64 on a Dell Inspiron 3542 laptop. I already slipstreamed the AHCI driver with nLite. I’m getting a 0xA5 BSOD about the BIOS not being ACPI compliant. I set the laptop to use Legacy boot but I don’t have any other options like IDE emulation or using an older ACPI table. I tried several patched 64-bit ACPI drivers, including one from 2019, but I get the same error. @AndrewB#6680 on Discord provided the recent ACPI driver and when it failed he said I should ask @daniel_k about it.

Has anyone else had success using patched ACPI drivers with XP x64 on recent Dell computers?


You would have better luck installing XP 32-bit than XP 64-bit.

There is absent good x64 acpi.sys driver. All modified drivers for WinXP of year 2019:

(01) acpi 5048 - 2019.5.15 - skullteria ((x86, x64))
(02) acpi 5048 - 2019.6.25 - infuscomus
(03) acpi 5048 - 2019.6.30 (Ryzen) - diderius6
(04) acpi 5048 - 2019.8.25 - daniel_k
(05) acpi 5048 - 2019.8.27 (Intel&AMD Final) - daniel_k
(06) acpi 5048 - 2019.9.1 (Ryzen) - diderius6 ((x64))
(07) acpi 5048 - 2019.10.11 - diderius6
(08) acpi 5048 - 2019.10.19 (Intel&AMD Final) - daniel_k ((x86, x64))
(09) acpi 5048 - 2019.11.1 - diderius6
(10) acpi 6666 - 2019.10.18 - OuterSpace, diderius6
(11) acpi 6666 - 2019.10.20#1 - OuterSpace, diderius6
(12) acpi 6666 - 2019.10.20#2 (Intel&Ryzen) - OuterSpace, diderius6

Of them, x64 are three:

(01) acpi 5048 - 2019.5.15 - skullteria
(06) acpi 5048 - 2019.9.1 (Ryzen) - diderius6
(08) acpi 5048 - 2019.10.19 (Intel&AMD Final) - daniel_k

Noone working on my Atom J1800.


I stopped working on XP 64 bit when I noticed,
that it is unstable as much as possible on newer compis, Ryzen and Intel.
I find only one board GA-H110M, where it is stable.
It is a hard job to get any version of XP to run on a Baytrail chipset (here for J1800 cpu).
This chipset comes on the market 2013/2014 and Intel did all in their Insyde Bios,
to keep XP, Win7 and even win8 out of it.
I succeed to flash new DSDT on the Lenovo Flex 10 with n2806 cpu (90006385 board)
and voila, now I have full acpi, ahci and usb support for XP SP3

PS: The Lenovo Flex 10 is not very good quality. But on this compi you can train everything for XP, USB and Bios,
because it is made XP, Win7 etc. unfriendly as much as possible.
The first Bios even does not have a CSM modul but 32(!) Uefi. Fun starts to install UEFI XP there or a CSM module.
And I want to mod the grafik driver for XP, all other works now.

@ diderius6

Thank you for answer. So you succeded to install WinXP x86 on Baytrail chipset. But to make the ACPI workable, it was needed to flash a new DSDT?
Which driver from the above list you have applied, or perhaps some other modified driver? I would like to try, (without modifying the DSDT, I don’t have such deep knowlege). Else there will be no choise but to use Win7, though it is undesirable.


I modded acpi.sys as much as possible. So at least I succeed to install XP SP3 without modding DSDT.
But without modding DSDT I have no USB, no mouse, and no harddisk can be seen in AHCI mode

@ diderius6

Could you please share your modded acpi.sys? I would like to play with.


This is the fresh modded acpi.sys from outerspace )
with which I can boot full acpi original XP SP3 on the Flex 10 Lenovo notebook without any mod in DSDT



He wanted the 64-bit version though, not the 32-bit, didn’t he?

@ infuscomus

I understood that to make an acpi.sys modification of WinXP x64 for Baytrail chipset is impossible (very hard to do, not worth wasting time).
Thus I have small hope to install WinXP 32-bit onto my SoC.