[Request] Disabled HPET MSI MAG Z390 TOMAHAWK (MS-7B18)

When I enable HPET via CMD i have really bad performance with my PC (i9-9900k/rtx-2080ti/32gb3200) disabling it helps a lot, but doesn’t remove my micro stutters, I was reading you should have it ON/ON or OFF/OFF in the BIOS/WIN because a mixed setting is causing some troubles. Unfortunately the HPET Setting is hidden in my MSI MB. Currently im running the latest Version of the BIOS.

@FYNE - I find best general testing results (just looking at timers, not a gamer) with it disabled in BIOS but default/enabled at BCDEdit command. See my comments and testing image here under the “Change Log” area
If you don’t care about BIOS version, I did V17 with chipset menu mod here - MSI Z390 MEG ACE BIOS REQUEST (2)

If you want same done to latest BIOS, let me know and I will redo to latest version

Thank you very much, so many more options comes with it!! Much appreciated

@FYNE - You’re welcome! Let me know if you need me to redo on latest BIOS version for you, I can

I also have z390 tomahack mag motherboard
But i don´t see any hpet option in the bios.
Is it possible to make the option appear so i can turn it off ?