[Request] Enable 4g decoding /resize BAR ASRock z170 k4/d3

Having a lot of trouble trying to add 4g decoding. Would greatly appreciate a modded 7.3 bios https://www.asrock.com/mb/Intel/Fatal1ty%20Z170%20Gaming%20K4D3/#BIOS

Trying to enable 4g decoding to enable resize BAR/SAM and then later mod bios to support coffee lake and get an appropriate CPU.

Currently running a 7700k and Rx 6800 w DDR3.

Bios Lock Offset (ig its unlocked):

Above 4G is at 0x385:

Also i think you need to use modded grub. its set_var 0x385 (since 0x385 is the varroffset for above 4g) 0x1 if u wanna enable above 4g.

Make suure before you do all of these, flash the bios i gave and if it worked, make sure your bios is running pure UEFI. CSM Disabled is a must.

Here is modded bios. flash it with your own risk:
z170gkd37mod.rar (7.1 MB)

1 Like

Cool I’ll go through this later. Yesterday I tried 0x385 0x1 but still had an error.

1 Like

you did use this right for the modded grub?: https://github.com/datasone/grub-mod-setup_var/releases/download/1.4/modGRUBShell.efi

Hey sorry busy week at work bout to read through this and try it now.

Just for clarification, flash bios, then make sure it’s pure Uefi /CSM then do the mod grub “set_var (offset) 0x385 0x1” ?

So far, i converted boot with mbr2gpt
flashed your bios
disabled csm
now im making a bootable to run modgrub and enter those commands

so what did the modded bios do if i may ask?

i added ReBarDXE.ffs for resizable bar support in the bios i gave to you.

if you flashed my bios and it worked (check cpuZ > Mainboard you’ll see a diff version and date, or open up DxDiag), you turned off csm making sure its pure uefi, and use modgrub to turn on above 4g decoding and it worked (guide is here, make sure you read from point 5), make suure on gpuz it said above 4g enabled in bios is Yes

and if it does say yes, use this app (run as admin) and enter value of 32 to make it unlimited rebar size, then reboot.

and if reboot sucess with no wierd thing happens, open up gpuz and see if resizable bar is enabled, like this:

also check on Device manager > View > Resource by type, and see if Large Memory list is present like this:

As a note, Resizable bar is supported from 8GB Polaris card (as low as RX 470 8GB) for AMD, and RTX 3000 series for nvidia, Intel ARC gpu also supported. also i suggest you to run the latest windows 10 version for minimum.

I did setup_var(offset) 0x385 0x1
Had error above
Tried setup_var 0x385 0x1
It sorta worked, now windows takes forever to boot and restart, no audio/network adapter etc
I also noticed an added area in bios added for amd diagnostic

I reflashed your bios and everything is normal again, checked cpu-z, assuming it went through due to the date

Maybe I’m entering the commands wrong in modgrub

Edit I did it again, modgrub changed 0x385 to 0x1 but gpuz shows

Whenever I do modgrub and set 0x385 to 0x1 this gets added to bios but still no above 4g

@madmanmarz gpu-z often reports 4g decode wrong

AMD driver still had SAM greyed out


I tried doing rebar state change to 32
Now windows is slow again and devices aren’t working but gpuz reports all the bar stuff as active


I guess I read about too large a number having issues with boards and that needs to be patched

@madmanmarz Z170 boards often need UEFIPatch applied yes

Well I bricked it with that last move. I was looking around for the pad files and they seemed to match what the old bios had but honestly no idea where I’m supposed to be looking. Flashed it and dead. Dual bios but other one musta been bad too, even tried using an older cpu for compatibility to no avail.

Guess I’ll have to buy a programmer or just build a new rig since this has been fighting me every step of the way anyway and haven’t even tried the coffee lake stuff yet.

This one is uefi patched (Remove <64GB BAR size limit, its on PCIBus, replaced using MMTool):
uefipatched.rar (7.1 MB)