(REQUEST) - enable Memory overclocking and XMP profiles/performance overclocking ASUS ROG G17 G712LW Laptop

so where are all these values being changed? in RU?

Yes, change with RU same as you did for XMP, and all settings in above post #20 are in same location I gave you before at post #14 >> SaSetup is in this GUID >> 72C5E28C-7783-43A1-8767-FAD73FCCAFA4
The only setting I’ve mentioned that is NOT in SaSetup, is the OC one I gave you at post #18 (it’s location is mentioned in that post)

Each bold black item above is the offset/location for that setting, which you find in SaSetup with RU, then change as you wish with above info

so let me make sure im doing this correctly, if i wanted to set dram multiplayer to 24 (24x133) i would enter 18 @ 0x0E?
QCLK Odd Ratio, 0x0F << Set 01 Enabled
could i only make these changes along with setting xmp profile to custom (01) and see if it changes, without making all other changes too to start with?

So as example in pic (0x0E) would be at this location in green?

also does this mean if bios gets updated these value would need to be inputted again?

on a side not whilst using RU the laptop automatically reboots after about 2mins, so i have to be quick entering all values, is this normal? it only does it whilst using RU

please could you check these values below before i input to make sure theyre correct


3200mhz@20-22-22-42 timings

0x134 set to 01 Memory profile (01 = custom), (02 = XMP 1), (03 = XMP 2)

0x0F set to 01 Qclk Odd Ratio

0x0E set to 18 Ram Ratio = 133x24

0x10 set to 14 cas latency = 20

0x16 set to 16 tRCD/tRP = 22/22

0x14 set to 2A tRAS = 42

3100mhz@20-22-22-42 timings

0x134 set to 01 Memory profile (01 = custom), (02 = XMP 1), (03 = XMP 2)

0x0F set to 01 Qclk Odd Ratio

0x0C set to 01 Memory Ref Clock

0x0E set to 1F Ram Ratio = 100x31

0x10 set to 14 cas latency = 20

0x16 set to 16 tRCD/tRP = 22/22

0x14 set to 2A tRAS = 42

Screenshot (17).png

@evofq360 - " if i wanted to set dram multiplayer to 24 (24x133) i would enter 18 @ 0x0E? " << Exactly! However, memory speed may not change, if chipset/CPU and or something else (Maybe Qclock ODD) is causing that to be limited to current speed, with that 133 multi (
You’d have to test and see if 100 multi goes any higher, AND Both 100/133 need tested with XMP Profile applied too, but maybe save that until then end once you’re more familiar with changing all this

As to your second question, YES, you can make any number of these changes in any combo you want, to try and see what works best for you and or this system.
I’d loosen up the timings and raise the voltage a bit before you try 3200, since it didn’t work right off the bat with XMP, but as mentioned there may be any number of reasons for that.
And yes, your example pic shows 0x0E selected

About the 2 minute reboot, not sure what you mean? Do you mean if/when using RU? If yes, not sure, maybe that’s normal for RU? I’ve only used it briefly, and maybe not for 2 minutes. I’ll test tonight and let you know
Yes, if you reflash stock BIOS, or even load optimal defaults, all this is reset to stock settings.
And yes, your examples all look correctly outline

update: neither of the two lots of settings i tried in previous post changed anything at all, 3100 or 3200mhz with or without xmp profiles enabled, so looks like im stuck at 2926mhz and just try to lower timings.

Yes, 2926mhz may be the limit. Did you also already enable OC setting I mentioned, and enable Qclk Odd Ratio too? Did you also raise voltage any?
Did system double reboot, or seem to take longer on save/reboot, any of the times you were trying that? If yes, then it may just be failing due to not enough voltage, or timings too tight for current speed+configuration (board, voltages, CPU itself etc)

If 2926mhz limit, then yes, your only option is to tighten timings carefully, or lower the memory speed and tighten timings there.
You may be able to get better timings, better performance/benchmark scores at a lower speed vs whatever you can get at max speed.

* Edit @evofq360 - This looks to already be set to nothing, ie not set, which is why I didn’t mention before, but go ahead and set this to much higher speed than you can run anyway, to rule this out as possible cause of the 29xx limit
Maximum Memory Frequency, VarStoreInfo (VarOffset/VarName): 0x132 << Set A0 0F = 4000MHz (Set 132-133 >> A0 0F)

why does laptop keep asking for bitlockerkey code on reboot? yes it did double reboot sometimes, i didnt increase voltage at all as kingston show 1.2v for 3200mhz

also when i enter into windows sometimes the timings arent set to xmp 1 eventhough its set in RU 0x134 02 for xmp 1 which previously worked with lower timings we tested.

do i need to keep secure boot permanantly off, if so how do i stop it asking for the bitlocker key on reboot once i remove usb drive

i did try to enable cpu overclocking you suggested post 18 but it didnt show in bios

@evofq360 Be sure you see my edit above
Bitlocker? Not sure, sounds like you enabled it in windows, disable it until you are done if this is something you use.
Remove any USB you have in there, or make a new clean USB Stick with your current RU stuff on it again, so there’s no bitlocker stuff on it.
I’ve never used it, so I can’t advise on that, you’ll have to google how to disable it if you are not sure.

If timings are not what you set, then it’s a failed OC situation, due to incorrect settings applied somewhere, or something too tight and it failed so defaults were loaded etc.
If you are setting things manually now, and done messing with XMP for testing purposes, you can disable XMP (ie set custom instead), that way XMP settings you are not changing are not applied and possibly causing issues with what you are changing
Secure boot needs to be off only while you are playing with RU

I never mentioned CPU Overclocking, only to enable OC Feature setting instead of it being disabled (This is not something you see in BIOS, since we can’t edit BIOS menu)

So I did as you instructed but now it won’t boot. I get black screen when switches on and that’s it. I can’t enter bios or anything

@evofq360 - Well, at least it lasted this long, I assumed you’d post that exact reply back, right after I very first showed you how to do any of this at post #20 (Due to trying wrong speed, or too tight of timing right away, etc)
What exactly did you do, that you’re saying I told you to do? Sounds like you may have pushed too far, too low of timings or too low on voltage etc. Or, possibly changed wrong offset value.
Sorry to hear this happened, you will now need CH341A + SOIC8 / SOP8 test clip with cable to fix, let me know if you need linked examples. Can you boot to DOS or Shell?

I’ll try boot to dos
I’ll try dos. Is there a way to flash bios back via usb automatically

No, just let me know if you can boot DOS and then if so I will give you info to fix the BIOS via FPT
You did not answer my question

Totally my fault. I think I pushed too far. Not an issue it was still under warranty so they’re sending replacement in 2 days :wink: so I’ll just enable xmp 1 like last time and leave at that​:+1:

I really do appreciate all help you’ve given. Is there a way I can donate?

It wouldn’t boot after I set the memory to 4000mhz But like I said it’s no problem. :+1:

@evofq360 - Ahh good you get replacement, still though, sorry to hear! Ohh wow, yes, it would never boot at 4000Mhz, that’s why I said "lets set the max allowed memory freq to something you can never do - 4000Mhz"
You did not have to send in for RMA, sorry to hear you ended up there! You could have fixed yourself with $7 worth of tools, and then you’d have those tools to fix any BIOS any time in the future
You should still order a set now, so next time you are ready in advance! Let me know if you want some linked examples on ebay

You’re welcome, and yes, I will send a PM your way, thanks

And yes, when replacement arrives, don’t set 4000Mhz! Just leave speed alone, and carefully adjust timings, testing for stability as you go, with memory testing software such as memtest86+ and or running prime95 for a few hours to make sure no errors
Do not try too low CAS right off the bat either, that will end up in same bricked place again Maybe 16 will be OK at 29xx, but I doubt 15 would be there, maybe at 2666-2800 you could try 15 but due to no auto-OC-Fail-recovery/fail-safe-loading, I probably would not try 15 at 2800 without programmer in hand.

Yes please if you could link to a programmer which could do various bios chips that would be great, really appreciate that

OK, would you prefer Amazon or ebay examples?

Either please

@evofq360 - Here, get one of these kits then, that way you get 1.8V adapter in case you need now or in the future ($14 shipped)

If you want, I can link you to all the items individually on ebay, slow shipped, would be about $10-11 shipped