[REQUEST]Extracted Rom file to flasheable file

The laptop does not start-up after updating the bios from windows (I don’t know how because I didn’t do it). At the moment I have only a file extracted with the Universal BIOS Backup ToolKit 2.0 from another laptop.

The bios chip is MX type but I don’t know which model (see spoiler for more details).

Laptop details:
Model: Samsung NP-R510
Motherboard LYON –EXT Rev. MP 1; BA92-05076A (BA41-00921A-NY)

Extracted bios file:
Download here
Password: samsungr510

Thanks in advanced.
Best regards.

New update. Test with a new ch341a programmer and with a 1.8v adapter and I have these screenshots:

The readings are “FF” only. I have tried to write the chip but it is impossible.

@junjoo - Read the ID off the chip with your eyes, flashlight, and a magnifying glass. It may also help to take more images, from different angles, with and without flash, then look them all over
Also, you can smear some white thermal paste over top, then wipe off, it may fill in the letters so you can read easier.

Please link me to the stock BIOS download page for this model, thanks

This is almost certainly not 1.8v chip, it’s too old/small BIOS, so no adapter needed

Plug in main battery and try to read, then if nothing, add power cable, then if nothing, reclamp 10 times on each one of those ways again trying again each time, you will get it (you know the drill )
If you cannot read or ID chip, no point in trying to write! If you have some pin on programmer clip disabled via tube like you have in the guide, stop that

Looks like it was ready and waiting on you in Colibri first image, 0x9C = "Ready, waiting on user input/next function"

If you continue to have software issues, use flashrom (it’s 100% compatible with MX25L1605, if that is the actual chip)
But, so should be 1.18, 1.30, v1.31(1.4) (CH341AFree), colibri, ASProgrammer (all those should also be certainly compatible)
But, if you can’t detect and ID, then clip/connection is not correct, or power not correct (batttery, PSU cables, or lack of is needed)
Rare cases you may need to remove chip from board. So, if you can desolder skillfully, then that may save you some headaches to just pull the chip and work with it directly.

Since this is legacy BIOS, sorry, I can’t look at the FD (if it even has such a thing) to be able to tell you what chips are compatible and thus be able to tell you what chip this is from that list.

Thanks for your help, but unfortunately the motherboard is damaged, so project abandoned.


Are you sure, what is damaged?

At the moment I do not know but I have tried to connect the battery and the charger, without turning on the laptop (of course) and it smells of burning . I have to look at where the problem is to notify the fire department.

Ohh, yes, it something smells burning, or very hot, then something is bad on the board.
It may be simple item to replace? Try turn on for a few seconds at a time, feeling around on the board, until you can narrow down what is bad.
Maybe start by smelling the board up close, without power, maybe your nose can lead you to correct area before you "feel test"