[Request] for vnme support for a Gigabyte GA-970A-DS3 Rev 1.0


I’ve reading this forum for the last days trying to figure out if there is a way to insert nvme module on a award bios. Tha mainboard is a Gygabyte GA-970A-DS3, using it’s very last bios update.

I used the “How to get full NVMe support for all Systems with an AMI UEFI BIOS” guide from this same forum and correctly moded a supermicro board with an AMI bios to boot from nvme.

Now, while tring to repeat the same process, I enconter some problems. For example, the bios is not the same brand. I tried to open the award bios file using MMTool, but it says “Error loading firmware image”. I suspect this is because MMTools can’t open award bios. So, I tried to use crom, and I correctly opened the award bios file, but now I don’t know which modules of the bios I can replace/delete in order to insert the same nvme module that I used for the AMI bios.
In the meanwhile, I found this post where Lost_N_Bios offered a modded version of the same bopard as mine, but another revision. This is the post, number #41


I tried to open that moded bios with cbrom and check it’s modules, but it’s not working. Seems like not compatible.

Also I found this other link to a similar mobo, but it is a ds3P intead of ds3, and I think that they are not competible as well:


I’m giving up with this, so I think that my last shot is for asking help to you, guys.

This is the link to the model of my mobo: hxxp://es.gigabyte.com/products/page/mb/ga-970a-ds3rev_10#sp and this another link is the direct mirror to it’s bios: hxxps://download.gigabyte.com/FileList/B…70a-ds3_f7d.zip

Please, let me know if you think that I can do anything else to get it working.

Thabk you very much!!

Bios for Gigabyte GA-970A-DS3 is legacy, not uefi. You can open it in Cbrom, and you get an error when trying to open in UEFItool that there’s no UEFI structure. Only way would (possibly) be Duet/ Clover.