[REQUEST] Gigabyte Aorus 15P XC (10870H, 3070P 130W), trying to undervolt, BIOS is locked

As title says I’m trying to undervolt my Aorus 15P XC, mostly to try and lower the scorching 90 degree CPU while under load. I’ve looked at another thread that had instructions on how to dump BIOS, but they required disabling Secure boot which this laptop’s stock BIOS does not seem to have options for. I’ve not changed BIOS before, but I’ve heard there are some helpful people around here that know what they’re doing.

So, I would greatly appreciate some help in unlocking the BIOS.

Edit: I looked in System Information (msinfo32) and saw that Secure Boot State is “On” but I don’t know how to turn it off.

Hi firend, use this tool and get a result file to make the bios mod, run it as Admin and upload the file here :


Here is some example, it depends on your bios backup variables, i will show you that after i will get it …

[Request] Gigabyte Aero 15 OLED BIOS unlocked (39)

Let me know

sorry for the late reply, forgot to keep checking after 1 day.

heh, Windows suspects the program is potentially unwanted. If Microsoft knew anything, they’d look at my CPU temperatures and say they’re unwanted.

https:// www . sendspace . com/file/vy3pr0

Edit: I looked at the post you linked, and looked at some of the information within. To use RU, you would need to disable Secure Boot first, no?

Edit 2 because it’s probably relevant: my BIOS version (according to msinfo32) is FB07, same as the up to date version on Gigabyte’s downloads site for my laptop model at https:// www . gigabyte . com/Laptop/AORUS-15P–RTX-30-Series/support#support-dl-bios


Ok friend, you have to follow the tutorials to unlock the Eeprom Write NVRAM variables :

[Request] Gigabyte Aero 15 OLED BIOS unlocked (39)

You’ll find under PchSetup [4570B7F1-ADE8-4943-8DC3-406472842384] GUID :

FPRR VarOffset - 0x6DD

BIOS Lock VarOffset - 0x17

Use RU shell and set to 0x00 them to unlock Eeprom and then you can flash the bios mod.

Here is the bios mod file , flash it running the Write.bat program by double click on it :


let me know

P.S. please upload a bios menu unlocked photo to check if all is ok.

Edit: nevermind, I had a question but it is irrelevant - I was looking at a step you had already kindly done. I will attempt to proceed with the RU steps.

Edit 2: as suspected, RU requires Secure Boot be disabled before it can be used (as described here in section 2.4). The current stock BIOS has no option to disable Secure Boot, and I am unable to find any information online on how to disable it. Also, if I try to run RU.EXE, Windows comes up and says that this program cannot run on your PC. I am unsure what to do here.

Ok friend, you can try this trick …

Here an user solved the issue by the Super UEFIinSecureBoot Disk …

[Request] Gigabyte Aero 15 OLED BIOS unlocked (39)




Let me know

I flashed Super UEFIInSecureBoot Disk onto my USB using Etcher with no problems, booted to USB and added key using MokManager. I then tried converting the .zip of Super UEFIInSecureBoot Disk with the updated RU to .iso for Etcher to use, and it produced this error when selecting the .iso file in Etcher. But, now I can open my USB in File Explorer and I can see the RU.EFI file in the D:\EFI\efi folder, so I will first try replacing that RU.efi directly before trying a second flash. I will edit this post with the results.

Edit: I got into RU fine after copying and pasting the contents of the .zip into my USB and overwriting files. Under PchSetup I found 0x0017 was set to 0x01 so I changed it to 0x00, but 0x06DD was already set to 0x00. I will now attempt to flash the BIOS file you provided.

missing partition table error.png

After running write.bat in the .rar file from post #4 in this thread, this is the result. The notebookcheck guide said to reboot twice before trying anything, so I will do that and then check the BIOS to see if the unlocked options are there.

result of write bat.png

Well, would you look at that. An unlocked BIOS, on a laptop. I had my doubts at first, not going to lie - but you delivered, and I cannot thank you enough.


Alright, small issue. Now my Control Center won’t open, and the on screen display that displays Caps Lock and Numlock status does not work. while these aren’t necessarily required, it is mildly concerning to not have the manufacturer’s software working on the laptop. But, everything in Control Center is setup how I wanted it, so I guess this is fine. But, if there is any way to solve this issue, please do tell.

Hi friend, you can try to set the Default Settings and reset all these, then try to modify these again, it will lock again the variables, but this time you can use
the bios unloacked to disable them , so into the Chipset >> PCH-IO Configuration >> set to disable Bios lock and FPRR …

Let me know

Oh for clarity I mean Gigabyte Control Center, not the Windows Control Panel. That works fine. I will try looking in the BIOS for those settings now.

Edit: in the BIOS I found FPRR to be disabled, but BIOS Lock to still be enabled. I disabled BIOS Lock, but Gigabyte Control Center still does not open.

Also, what did you mean by “set the Default Settings and reset all these”? Does “all these” refer to BIOS settings, as in I reset to BIOS defaults?

Yes my friend , it will reset the CMOS and will load all default settings for this bios !

I used “Reset to Defaults” and then “Save and Exit” in the BIOS, it reverted all the changes I made such as CPU locks to defaults, but my Gigabyte Control Center still does not function. I am unsure what could have caused this.

Edit: in Event Viewer, under Error -> Application Error, I find listings for ControlCenter.exe, one for each time I try to launch the program. They are all similar to the following most recent one, with slightly different Fault offset, Faulting process id and Faulting application start times.

Faulting application name: ControlCenter.exe, version:, time stamp: 0x606d7c97
Faulting module name: unknown, version:, time stamp: 0x00000000
Exception code: 0xc0000005
Fault offset: 0x00007ffd381c52c4
Faulting process id: 0x4748
Faulting application start time: 0x01d7af3acf5bf1c7
Faulting application path: C:\Program Files\ControlCenter\ControlCenter.exe
Faulting module path: unknown
Report Id: 5888ac74-0f2a-4c54-8426-9689ec87989c
Faulting package full name:
Faulting package-relative application ID:

Edit 2: under Error -> .NET Runtime, I find listings at the exact same times as those ControlCenter.exe errors, with the following information

Application: ControlCenter.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.NullReferenceException
at Intel.Overclocking.SDK.Tuning.TuningLibrary.ProposeChange(System.Collections.Generic.List1&lt;Intel.Overclocking.SDK.Tuning.ClientTuningProposal&gt;, System.Collections.Generic.List1<Intel.Overclocking.SDK.Tuning.ClientTuningProposalResult> ByRef, Boolean ByRef, Boolean, Boolean)
at Intel.Overclocking.SDK.Tuning.TuningLibrary.Tune(System.Collections.Generic.List`1<Intel.Overclocking.SDK.Tuning.ClientTuningProposal>, Boolean ByRef)
at Intel.Overclocking.SDK.Tuning.TuningLibrary.Tune(UInt32, System.Decimal, Boolean)
at CPUOC.CPU.OC(System.String ByRef)
at SmartDashboard.Dashboard.cpuprocess(Int32 ByRef)
at System.Threading.ExecutionContext.RunInternal(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object)
at System.Threading.ThreadHelper.ThreadStart()

For anyone curious on how I found these errors: after looking around for what to do if a program doesn’t even appear when trying to launch, one thread said to look at Event Viewer. After finding the Application Error, looking up the Exception code led me to look for a .NET error, which then displayed the problem was to do with Intel overclocking, and the solution was obvious from there

Aha! I fixed it. I had uninstalled Intel XTU after flashing the BIOS because it refused to let me undervolt due to my H model CPU, so I just thought “I’ll ditch that and use Throttlestop instead”. But when Event Viewer reported Intel overclocking components being missing, and I realised this issue only occurred after uninstalling XTU… well, I reinstalled XTU and now my Gigabyte Control Center opens just fine :smiley:

Nice to read it Mike, i am very happy for your goal and thanks for report this solution to help all users !


I can see that you have managed to unlock the bios. I am curious however, is there any option to change the GPU TDP maximum?


@heska I have tried flashing an MSI 140W vbios but it disabled my HDMI port, so I rolled back to our 130W vbios.
Perhaps someone experienced in vbios modding would be able to isolate the 140W part of the MSI vbios and apply it to ours?

I am not an expert but to be honest, the difference between 130-140 is minimal for sure.
Perhaps that 10 extra wats will create an amount of heat that is not proportional to the performance enhancement since you are pushing the device off the edge basically.
The bios unluck for a 130W device is perhaps relevant for CPU undervolting to enhance the temperature and reduce throttling.