[REQUEST] Gigabyte H310M S2V 2.0 ( rev 1.0 ) HPET problem

Hello, I need to disable hpet in my bios beacuse my games are gone wrong I got high fps but It doesn’t feel like that. I disabled it with bcdedit try to disable from bios but there is no setting like that.

Here is my link to the bios where I downloaded it : version f14a
gigabyte(dot)com/Motherboard/H310M-S2V-20-rev-10/support#support-dl

Direct download
download(.)gigabyte(.)com/FileList/BIOS/mb_bios_h310m-s2v_2.0_f14a.zip
-------------------

Bump
--------------------

Bump for second time plz help I disabled her in windows I need it bios for, too.

@ademCLK - I can only hard disable HPET (ie disabled by default) for you, and you will need to put BCDEdit back to defaults (it’s best timer result with >> BCDEdit.exe /set useplatformclock yes ) per/see my HPET comments, and testing images here under change log area
Do you want me to make you this BIOS?

Ok I want that bios thanks for answer. I will make my hpet default. Hope my problems will gone. even If I disable or uninstall hpet driver from device manager it comes back instantly. Thanks for helping me
------------------

@Lost_N_BIOS sorry I forget to tag you.

Yes, I want it. I checked timers with CPU-Z and QPC is 10 Mhz lower is better right ? If you just make a BIOS for me Do I need to just qflash it like normal BIOS installation? @Lost_N_BIOS Sorry I forget to answer you.

No need to disable HPET in BIOS.
10 MHz for QPC/QPF is not HPET, it is new usage of TSC.

@Lost_N_BIOS told me he can hard disable it to decrease that amount. I gonna wait for him to respond.

@mbk1969 - Yes, but BIOS disabled HPET still brings that down no matter what timer it is - see my HPET comments, and testing images here under change log area

@ademCLK - Sorry for the delay, here you go!
Yes, flash via Qflash and then you can test yourself and see BCDEdit.exe /set useplatformclock Yes/No (or True/False) with this BIOS vs stock BIOS using CPU-z timer, you will see timer result like I showed in my image at the thread linked above.
https://ufile.io/33pvm1gu

@Lost_N_BIOS oh sorry I solved thx for modding it for me.

@ademCLK - You’re welcome! So you don’t need HPET disabled in BIOS? If you test the mod BIOS, let me know if it’s all OK, for the next user that asks for this model/BIOS.
If you don’t need/test it, it’s OK, someone will eventually



You see in those CPU-Z screenshots that no matter how HPET is forbidden (by “useplatformclock no” or by disabling in BIOS) QPC frequency equals to 10 MHz (that`s TSC implementation).
And when HPET is disabled in BIOS with “useplatformclock yes” the QPC frequency equals to ACPI (platform) timer frequency - 3.580 MHz (this is not a TSC frequency).

Any platform timer used for QPC is worse than TSC (10 MHz one). Just because the time and amount of CPU instructions needed for platform timer access is much worse than time for one CPU instruction needed for TSC access.

And (btw) in older Win10 builds TSC implementation of QPC displayed 3.something MHz. This is not actual frequency of TSC, this is scaled down frequency. MS team just changed the division factor to increase QPC frequency from 3.something to 10 MHz.

Page from MS about all that stuff
https://docs.microsoft.com/en-us/windows…ion-time-stamps

PS
And some info about TSC
https://forums.guru3d.com/threads/a-bit-…ter-tsc.433977/

I updated bios didnt check it but mhz is not 10 it fixed it.

@mbk1969 - You very well may be correct, I know nothing about any of this and was just told that is best way to check enabled/disabled in BIOS.
Additionally, for everyone that asks about this kind of BIOS mod, or to enable them to disable directly when possible, issues which made them want it disabled are then fixed (AMD systems aside)
If this is what you mention, and not HPET now, why does developer of CPU-z not fix what it’s detecting and make it detect the correct things?

Yes, I know older win10 did things differently
Thanks for the links, none of it helped me on any of this, but I am not affected by any of this, I only know to disable for user in BIOS and what my testing of that shows when it’s not possible to make setting visible to user so they can change themselves.

@ademCLK - Sorry, I don’t understand what your reply says? Did you use mod BIOS, or just updated stock BIOS, and issue is fixed?



CPU-Z does not show any error behaviour, it shows exactly what is configured.
When you disable HPET in BIOS but force Windows to use platform timer with "useplatformclock yes" CPU-Z shows that ACPI platform clock is used for QPC/QPF.
When you enable HPET in BIOS but force Windows to use platform timer with "useplatformclock yes" CPU-Z shows that HPET platform clock is used for QPC/QPF.
When you do not force Windows to use platform timer with "useplatformclock yes" CPU-Z shows that TSC is used for QPC/QPF - regardless of HPET status in BIOS.

HPET can be used by any kernel mode code (device drivers, OS components) directly, so when you disable it in BIOS such code will either fail or switch to another platform timer.

Thx for helping me @Lost_N_BIOS but I’m using stock bios right now. My problem is weird I’m getting high fps in low monitor hz.

@mbk1969 Is 10mhz ok now right ?



It is. Consensus is 10 MHz is still TSC in use, which is better than HPET.