[REQUEST] GIGABYTE H55M-S2H need BIOS modding for SSD M2 NVME whit Adapter PCIe

Hi, i have motherboard Gigabyte H55M-S2H rev and i tried install SSD M.2 NVMe 128gb whit adapter NVMe PCIe x4 M.2…but my BIOS does not recognize the disk M.2 to install the operating system.
Maybe someone can help me? Needs a modified BIOS for my motherboard
My BIOS are this:
Flash memory tipe: Winbond 25Q64V
Flash memory size: 64M bits
BIOS sign on message: H55M-S2H F7
I already tried windows 7 and 10 but could not.

Award Software International, Inc. F7, 20/08/2010

Your motherboard/bios model is too old for NVMe protocol support or mod, only motherboard with UEFI can achieve modifications in order to support NVMe

Thank you very much, maybe it is so, could someone else confirm it for me?

@Kyo23 :
Welcome to the Win-RAID Forum!
Since your problem cannot be solved by a modification of the mainboard BIOS, I have moved your request into this better matching Sub-Forum.
MeatWar is right: Since your old Intel 5-Series chipset mainboard doesn’t have an UEFI BIOS, you will not be able to boot off an NVMe SSD (only exception: Samsung’s 950 Pro), not even by modifying the BIOS.
If you want to use an NVMe SSD as system drive with the OS on it without changing the mainboard, you have 2 alternatives:
a) Buy a Samsung 950 Pro SSD. AFAIK it is the only NVMe SSD model, which is bootable in Legacy (non-UEFI) mode, because it has a Legacy NVMe Option ROM in-the-box.
b) Use either >this< or >this< guide.
Good luck!
Dieter (alias Fernando)

@Fernando :
Thank you very much, if I was also investigating and came to a similar conclusion.
But is it possible to change the BIOS settings to UEFI? I understand that from Windows 10 version 1709 onwards there is an MBR2GPT application that allows the conversion.
Could you clarify if it is possible?

@Kyo23 There are two kinds a bios/ firmware can boot a computer:
- Legacy (the old ‘bios’ mode- your H55 board uses it)
- UEFI (newer, “Unified Extensible Firmware Interface”, your H55 board doesn’t have it)

A PCs legacy bios or UEFI firmware needs modules to recognize and initialise the hardware if it’s needed for system boot. These modules can be built into the bios or stored on explansion cards (like graphics cards), but they’re of different structure for the two types of bios/firmware.

A legacy bios uses OROMs. A legacy graphics card does have its own little OROM to establish communication with the mainboard bios at boot time and get initialised.

An UEFI firmware uses special drivers modules (not tu mistake with drivers an operating system uses). An UEFI capable graphics card does have an UEFI driver in its firmware to establish communication with the mainboard bios at boot time and get initialised.

There is a ‘trick’ to load legacy OROMs when booting an UEFI firmware- it’s called CSM.

There is no trick to load UEFI drivers into a legacy bios- these driver modules were not known when legacy bioses were developed.

Your bios is pure legacy, nothing in your bios is capable of UEFI. And there doesn’t exist an (universal) NVME OROM that one could insert into your bios. All existing modules for NVME are made for UEFI firmware.

- There does exist one single modell of NVME disk that has- like a graphics card- it’s own OROM built in that will be loaded by a legacy bios during boot: Samsung 950 PRO

- There are 2 solutions that allow loading the NVME UEFI- driver after the bios has completed its own start- process/ its hardware initialsiation. Those are explained in other threads: See the 2 links Fernando presented.

@lfb6 :
I thank you very much, the explanation you told me is very good. I’ll see to it

Edit by Fernando: Unneeded fully quoted post replaced by directly addressing to its author (to save space)