[Request] Gigabyte OEM Z370-HD3P - Option "HPET" missing in updated bios


I’m currently using a OEM (Hyrican) Gigabyte Z370-HD3P-CF mainboard.

After updating to bios-version F12 (supplied by OEM), the option “High Precision Event Timer” in the Category “Chipset” is missing!
After contacting Hyrican and them contacting Gigabyte I was told it was removed because of a “Intel Specification” - whatever that is supposed to mean…

I saw some people here had the same problem as me, and were able to solve it with a modded bios :slight_smile:

Here’s the OEM Bios (F12): http://s000.tinyupload.com/?file_id=03786887913735916271

Thank you for your help :slight_smile:

@Lost_N_BIOS could you maybe help me with this? :slight_smile:

@themememount - Sorry I missed your post until now!

Can you see PCH Config in Advanced section? This is where this setting is always located, well you may have also had a copy somewhere else too, but this is it’s main location
If you can see this section I can make the setting visible for you, if you cannot then I can either make the section visible or make you a BIOS with this disabled up to you.

I don’t think I can find PCH Config anywhere - here’s a picture of where the setting used to be located: https://imgur.com/a/ZdJtJxD

Thank you for your help!

PCH-IO Configuration would be it’s own page, I assume you didn’t have this, but needed to check to be sure. Where it used to be does not matter, it’s not there in current BIOS.
If you want to upload for me the old BIOS, I may be able to put it back there, otherwise you would need what I mentioned above done instead, or pick some setting at chipset that you don’t want anymore, I can replace a setting there
Pick one of these you want replaced, if there is one you can’t see, then great, we can use that one


Sadly, I don’t have the old BIOS!

I can’t see “DVMT Pre-Allocated” and “DVMT Total Gfx Mem” - if those don’t work, “IOAPIC 24-119 Entries” is great too :slight_smile:


They work, they are just hidden from you, I will make them visible too since you mentioned they’re missing, and I’ll replace the IOAPIC 24-119 with HPET
I’ll try to get that done for you tomorrow, have to head out of here right now, sorry

Okay, sounds good!

Thank you :slight_smile:

@themememount - Quick test first before I add the other setting, which of these make “DVMT Pre-Allocated” and “DVMT Total Gfx Mem” show in BIOS. Please test in order shown, stop at first BIOS that shows them and let me know which it is, no need to test the other
Flash via Qflash from within the BIOS - ONLY!



Also, please confirm, can you currently see that IOAPIC setting?

The first one (UserBCP) worked - I can see the 2 settings! And yes, I can currently see the IOAPIC setting aswell :slight_smile:

Thank you!

OK, thanks for test result, I will make you BIOS soon with rest of change. It’s an intricate mod, so will take me a little bit to do.

Okay, thank you! :slight_smile:

@themememount - here you go, flash via Qflash - http://s000.tinyupload.com/index.php?fil…521851212724466

Flashing worked perfectly, setting is there - amazing!

Thank you for your help!

Awesome, thanks for quick report back, and happy to hear it’s all as expected!