[Request] gigabyte z390 gaming x unlock hidden settings

New to gigabyte mobos so the bios is really confusing to me and cant seem to find a lot of options that were previously on my asus board, using the F9 bios verison and for example disabling vt-d seems to not work, and cant seem to find anything else to do with disabling virtualization, and cant find any settings to do with disabling spread spectrum. Any help would be much appreciated :slight_smile:

link to the bios: https://download.gigabyte.com/FileList/B…gaming-x_f9.zip

@cam198 - Did you start by loading optimized defaults? If not, do that now, save and reboot back to BIOS.
Disabling Vt-d should work fine, unless there is some BIOS bug (test older or newer beta and see if same issue, if so you need to report it directly to gigabyte so they can fix)

Which page do you see Vt-d on so I can check the one you are changing and see that changes apply when made.
Vt-d is the only virtualization setting in this BIOS, except for a hidden overall >> Intel (VMX) Virtualization Technology setting (default enabled)

Spread Spectrum is a hidden setting, default is disabled for both PCIE Spread Spectrum, the other is WiFi related per it’s help text >
Adjustment for OPVR RFI Spread Spectrum to mitigate EMI risk. Spread spectrum values are defined as center spread and total spread %. Default is 1.5%.
Additional OPVR EMI reduction can be achieved by increasing RFI Spread Spectrum % value. The use of spread Spectrum % value larger than 1.5% may introduce Wi-Fi RFI. Check Wi-Fi (2.4GHz-2.5GH) RFI condition.

I can disable RFI Spread Spectrum for you if you want?

A “general” Spread Spectrum setting is not included, you will have to bug Gigabyte directly and see if they will add for you.
They’ve already purposefully removed PWM Spread Spectrum (I can see, they left the text strings in there)

PCIe Spread Spectrum Clocking, VarStoreInfo (VarOffset/VarName): 0x85D, VarStore: 0x1, QuestionId: 0x650, Size: 1, Min: 0x0, Max 0x1, Step: 0x0 {05 91 BC 0F BD 0F 50 06 01 00 5D 08 10 10 00 01 00}
0x4873A Default: DefaultId: 0x0, Value (8 bit): 0x1 {5B 06 00 00 00 01}
0x48740 One Of Option: Enabled, Value (8 bit): 0x0 {09 07 03 00 00 00 00}
0x48747 One Of Option: Disabled, Value (8 bit): 0x1 (default MFG) {09 07 04 00 20 00 01}

RFI Spread Spectrum, VarStoreInfo (VarOffset/VarName): 0x763, VarStore: 0x1, QuestionId: 0x323, Size: 1, Min: 0x0, Max 0x64, Step: 0x0 {07 91 AC 08 AD 08 23 03 01 00 63 07 10 10 00 64 00}
0x3DA02 Default: DefaultId: 0x0, Value (8 bit): 0x0 {5B 06 00 00 00 00}
0x3DA08 End {29 02}

sorry for the late reply. ive loaded optimized defaults already, vt-d is under the advanced cpu core settings, i set it to disabled but in task manager it still shows as on

Thanks for the info. I see they’ve redone/re-structured these BIOS in some images from another model, none of the actual BIOS matches layout in setup or AMIBCP anymore, so it is possible they’ve screwed something up during this kind of restructuring
So, due to that, I do suggest you report this to them directly via email, so they can check, confirm, and fix on next BIOS release.

Meantime, I can probably fix and disable this for you Actually, now that I see what you mean in Task manager, what you set in BIOS (Vt-d) is not disable of Virtualization, only disabled Vt-d. Virtualization itself is a hidden setting, unless you also see that too?
Anyway, I can disable it for you.

* Edit @cam198 >> http://s000.tinyupload.com/index.php?fil…876705412752712

Change Log -
Intel (VMX) Virtualization Technology >> Disabled by default
VT-d >> Disabled by default

Flash via Qflash only, DO NOT FPT flash (This is stock BIOS edited)
After flash, enter BIOS, load optimized defaults, save and reboot back to BIOS to make any other changes you need