[Request] Help unbrick Samsung NP770Z5E - BIOS recovery

First post here, so please be patient with me: I tried reading many threads and guides but I’m not enough experienced on these subjects to put everything together.

So on with the question: the other day I was flashing a modded bios to my laptop, a 7 year old Samsung NP770Z5E with Intel i7-3635qm and HM76, using afuwin 3.07.00 and as it was not letting me do it I tried the “recovery” option, without knowing what I was doing. (Now I know that it should have been named the “Brick my PC” option )
Here afuwin asked me to reboot the PC, so I pressed OK and then after the reboot just a blackscreen. If I try to turn on the PC now it just stays on for less than a second and then stops. I tried reset CMOS, remove battery, various keypresses, to no avail.

So I started rading how to recover from this and I managed to get a CH341A programmer, connected and with the help of another PC I dumped the actual content of the BIOS chip (MX25L6406E) (I actually had to desolder it because the programmer was not able to provide sufficient power)
I also found a compatible bios dump on some other forum, which is from the same laptop but with an older bios release (P02ABU vs P07ABU)

I have read that now I should transplant serial numbers etc from my BIOS dump to the working bios dump, but how?
Tried looking in with UEFITool but I cannot understand what it shows me

Can someone more experienced help me, please?

Samsung NP770Z5E Bricked BIOS dump.zip (3.61 MB)

File doesn’t have correct length/ too long, that’s always suspect for read errors and you should have a correct dump/ backup of the original bios or latest state at least. Which program did you read the chip with?

Try another program in addition, read again, if results are identical you’re possibly good.

Yeah I noticed that when I first read the data with “CH341A - USB Programmer”, so I re-read it a couple times and then also verified with “AsProgrammer_1.4.1”.
The first 8.388.608 bytes of data were always exactly the same, it’s just the first program that for some reason reads 64 bytes more at the end of the dump. These 64 bytes however are all zeroed out. Maybe I used some wrong setting in “CH341A - USB Programmer”?

I attached the dump read with “AsProgrammer_1.4.1”

Samsung NP770Z5E Bricked BIOS dump 2.zip (1.19 MB)

Thanks for the confirmation. Would you mind posting the older version (P02) you found? Thanks!

Sure, here it is!

PS: Thanks for your help!

Samsung NP770Z5E NIKE2-15_DC.zip (3.56 MB)

HxD Is what I use to transfer information between BIOS dumps, hope that helps! also the guys over at bios-downloads.com can do it for you for cheap if you’re not comfortable, and they don’t charge unless it works.


Try the attached file. Please compare the written file in a separate read, best with another program, and compare the files byte for byte. And please clear the CMOS.

[edit: file deleted since no information if it was used/ did work]