[Request] How to get Win10 installed onto an Intel NVMe RAID0 array?


Hello. Help install Windows 10 on RAID 0. Windows sees the array, but the driver does not want to install it.

What lets you think, that it is the driver, which prevents the Windows installation onto the RAID0 array? Which message did you get?
Which is the version of the Intel RAID BIOS OROM/EFI modules and how do you want to get the OS installed (in Legacy mode using the Master Boot Record partition scheme or in UEFI mode using the GuiMode Partition Table)?

I tried different drivers. Windows does not install them.
Chipset HM370. Setup LegasyOS.
Intel RAID ROM / EFI BIOS: v16.0.1.3397



Wait a second… You did manage to install Windows?! Because it sounded (and your photo) like you couldn’t and that was the issue, quote: "Help install Windows 10 on RAID 0"…
And you do have an Intel AHCI driver installed for primary disk??

So what is your question exactly?
You only meant - no RAID disks visible? No driver will help, Windows must first recognize it itself and install a default driver!

Windows sees the driver, but doesn’t install it.








@I_Alex_1 :

If you want to install an OS onto an Intel RAID array, the Intel SATA Controller has to be set to "RAID" within the BIOS.
According to your screenshot of the Device Manager the on-board Intel SATA Controller is obviously running in AHCI mode.

EDIT: There is no need to load any Intel RAID driver during the OS installation. Win10 has a working Intel RAID driver in-the-box. Once the OS is up and running, you can install the desired Intel Drivers & Software Set version.

@I_Alex_1 : @MDM :
Since this discussion has nothing to do with the Sub-Forum “BIOS Modules”, I have created a new thread within the “Intel AHCI/RAID Drivers” Sub-Forum and gave it a meaningful name.
I hope, that this is ok for you.

@I_Alex_1 :
Thanks for the screenshots, which you obviously have attached to your last post after I had written my recent reply.
Unfortunately I can neither read nor understand the Russian text with cyrillic letters. Please try to translate the most important parts.
According to your screenshots you have created an Intel RAID0 array consisting of 2 NVMe SSDs. Why didn’t you mention that earlier?
By the way - >here< is video about how to create a bootable Intel NVMe RAID0 array.
Additional questions:
1. Did you disable the BIOS settings regarding “Secure Boot” and “Fast Boot” within the BIOS before you started with the OS installation?
2. Which *.INF file of the desired Intel RAID driver version did you choose, when you loaded the driver? It has to be the iaStorAC.inf (supports RAID) and not the iaAHCIC.inf one (supports only the AHCI mode).
3. Did you unplug all other HDDs/SSDs except the members of the RAID0 array before you started with the OS installation?
4. How (with which media and which tool) did you try to boot the Win10 image?

Everything worked out. Set the UEFI boot mode and no drivers were required.