[Request]HP envy M4 help unlock advance bios for sata settings. Insedeh20 f.02 rev 3.7.

To start Thank you to anyone who takes the time to read this. I am attempting to access the advance settings of my bios.
I’ve been trying to research this topic on my own before reaching out with no luck. I have tried hot key combinations and none have worked. My bios displays Insedeh20 f.02 rev 3.7.

I need to be able to access anything regarding sata options. The only option I can currently access is to enable or disable legacy. Off topic Im attempting to use an executable through ms-dos called hddhackr to modify a hdd for a xbox 360. But due to my limitation of settings im unable to do so.

Thank you in advance if anyone can help. I greatly appreciate it!

What is the exact full model of this system, look on bottom of case, sticker etc. Please add a link to your stock BIOS download page at HP’s site so I can look. And, what exact settings are you needing to change related to SATA?
Normally use of MS-DOS would not rely on SATA settings at all, unless maybe you are stuck in RAID mode, if that is case you could easily just do the HDD stuff on some other system then

DO NOT Flash to latest BIOS if you have not already, often with HP only the older BIOS can be modified, if at all. And, often you need flash programmer (like CH341A + SOIC8 test clip w/ cable)
But, we may be able to change some settings in other ways, without flashing mod BIOS, but I can’t say for sure until you link me to your BIOS download page.

The exact model is HP ENVY m4-1015dx. I can’t find a download link online for my specific bios. I’m not sure if there’s anything I can do to help provide that.

That is a comment from the tutorial I am following on why the executable through ms-dos may not be working.

Your BIOS download page is here - https://support.hp.com/us-en/drivers/sel…9/model/5312250
Choose Win8 - BIOS is there x2 (F14 and F18)

Do you see BIOS version on main page of BIOS? If not, download HWINFO64 and look int he motherboard section on left of main window, once motherboard is selected you should see BIOS version info on right

Let me know which you are using and then I will check BIOS settings for you. Sounds like you need to enable legacy per that quote. Some stuff in DOS just doesn’t work on all chipsets, what exactly are you trying to do?
Also, some DOS is better than others, if you are using FreeDOS now, try Win98 SE instead.

Thank you! I just checked and my bios version shows f.02. I was selecting windows 8.1 under hp’s driver page and it wasn’t displaying anything for BIOS.

I am attempting to reflash a hdd with a security sector for a xbox 360. I have legacy enabled but the executable still isn’t working. When I attempted to use FreeDos my drive refused to boot.

Thank you again for your time!

You’re welcome! So, what DOS were you using before trying FreeDOS? And, what error were you getting in DOS?
What do you mean when you attempted to use FreeDOS the drive wouldn’t boot? What drive? And why would using FreeDOS affect any drive booting?
Using FreeDOS you put on USB like any other DOS, then boot to DOS and do whatever you wanted to do, it wouldn’t go onto HDD/drive

Sorry, I can’t check BIOS f.02, since it’s not available for download. Since you are on super early BIOS, it’s probably buggy, I suggest you try latest BIOS and see if issue remains.
That may not help though, since this is more modern system some DOS stuff may just not be possible.

Something things you want to do in DOS just aren’t possible on some systems, no matter what settings you try to use, but sometimes the type of DOS you use causes the issue and not the system itself.
I’m still not sure what the error is you are trying to sort out, so I can’t advise much else yet. You may need to do what you want on some older system, like one that came with XP would be most ideal

I am attempting to follow THIS tutorial to complete the process of flashing security sectors and creating partitions needed for
a Xbox 360 to recognize a hard drive.

I am using a program called BootDrive tool to create a bootable drive from my HDD. I have two options for MS-Dos and FreeDos. The
tutorial states to use MS-Dos but I’ve seen comments online that if you’re using a laptop to use FreeDos. But when I attempt
to boot off of the drive with FreeDos it says the drive is not bootable.

So back to MS-Dos I placed an executable called HDDHACKR inside of the root alongside of the security sector needed to flash.
But when I attempt to execute the HDDHACKR it just goes down one line and flashes. Even after waiting for a long period of time
the executable won’t start. Some of the comments recommend changing various settings in BIOS. I understand it might not work on my computer
in particular. I will update my bios then try again.

@R3gulate - Can’t you just boot to a USB with DOS on it, and then do whatever to the HDD as a secondary drive? <<< Yes, this is exactly what your guide shows, see my comment below

Since freedos is failing for you, try win98 SE - here in post #10 is files (first try step 1-2 only, then it that does not work do 1-4).
This is similar to the guide, you point the USB Creator to the DOS files folder. See, even your guide is creating a bootable USB (not the HDD itself) << That may be your issue, your supposed to boot to the USB not the HDD, which is sounds like you are doing (booting to HDD, not USB)
<Request> Flagship X470 Gaming 7 Wifi Motherboard BIOS Fix

I would actually try on another computer entirely, this system isn’t really ideal to do this kind of edit. Best would be some old XP desktop system, or older Vista/Win7 may be OK too, but if you have some old XP system laying around collecting dust that would be perfect and wouldn’t give you any issues.
It may be OK in legacy mode on this system, once you boot to USB instead of the HDD (I don’t have high hopes of that, but this may be your problem >> booting to HDD, when you should be creating and booting to USB)