[REQUEST] Inject SN & MAC Address to ASUS Notebook BIOS


Can someone inject these SN & MAC Address to my BIOS? I tried using FD44Editor but there is "parsing error". BIOS dump is attached in this post.

SN: K5N0GR068560217
MAC: DC:F5:05:7D:C1:69


X407UA_304.zip (5.75 MB)

@tresdemontano - Is this Ethernet MAC ID, or Wireless? If wireless, it does not go in BIOS, except maybe only for information purposes/copy.
If this is WiFi MAC ID, it’s already stored on chip, once you program in the correct BIOS and update/install driver Wifi will work again.
Do you have ANY previous BIOS backup, from before you had the issue in other thread with incorrect BIOS Model flash? This can be made any time, with any tool. If you have, please attach.

This is a Wi-Fi MAC ID. The ASUS notebook does not have a LAN port.

I’m just bothered that the SN and MAC Address doesn’t show in BIOS.

I have created a previous BIOS backup. I will attach it here; you can check it.

ASUS_X407UA_BIOSBackup.zip (5.8 MB)

@tresdemontano - Isn’t ASUS_X407UA_BIOSBackup chip dump AFTER you flashed in UAR BIOS? If so, this is not ideal, I need any previous BIOS backup you made before anything happened, can be made with any tool, any time, long ago with AFU etc
I mainly need that to fix your NVRAM, especially if this is where it’s pulling the data from that you’re wanting to see in BIOS (serial/MAC stored in NVRAM and in padding area)
I cannot copy NVRAM from your bad UAR flash into new BIOS due to different BIOS regions for different models, so need old actual BIOS dump from your exact model w/ proper BIOS in use when you backed it up

Since there is no Ethernet then MAC ID is in BIOS only cosmetically, not for function.
Here, test this BIOS and see if serial/MAC show up where you wanted to see them now, if not, we need to find other “Actual” dump from user with your exact model (not "Fix BIOS type “Fake Dump” which is just stock BIOS not actual dump) maybe I can find
This is with padding are copied over only, if it’s a brick, then this too is due to can’t pull this from your ASUS_X407UA_BIOSBackup dump either

Yes, the backup that I provided was the dump after I flashed the UAR BIOS. I have no prior copy or dump of the original BIOS file before it happened.

I tried the BIOS that you provided and the SN is now showing in the BIOS, but the MAC is still missing which isn’t a big deal since I tested that the Wi-Fi still works when inside the OS.

I just noticed something unusual and weird. Every time I restart or power on the laptop, it freezes (I don’t know what’s the perfect term to use) for about 15 to 20seconds before the ASUS logo shows up. It’s just black screen and all LEDs (POWER, BATTERY, HDD) are lighting up.

Bummer you did not have any old backup Good to hear SN is showing up now at least! I expected Wifi would work, since it’s MAC ID is stored on chip
About the freeze, sounds like your ME FW is possibly messed up as well. Was it always doing that since you fixed it, and you didn’t notice maybe, or is that 100% for sure new issue from BIOS I sent you?
If it’s due to the BIOS I sent you, then ME FW is messed up in X407UA_304.bin (probably still ME FW from UAR possibly), I can redo, but we’ll need to find a complete BIOS dump from the UA model first.
I can try redoing/clean/update ME FW to see if it’s just a messed up ME FW issue, not mis-configured due to UAR stuff that happened, but if that does not help then it’s due to the UAR issue and we’d have to find full UA dump to get proper ME FW configured for this system to fix.

It was already doing that since I fixed it. It doesn’t happen when using the UAR BIOS.

Sorry just to make clarifications. The X407UA_304.bin I provided was a BIOS dump I got from a site (vinafix.com) so I believe that it is indeed coming from a UA model.

Here is the link to where I got the BIOS dump: https://vinafix.com/threads/asus-laptop-x407ua-bios.32129/

Maybe there is a difference with the ME FW versions of the UAR BIOS and the UA BIOS.

@tresdemontano - So, maybe messed up ME FW in that dump, especially since no one has replied much on that thread yet
First we try clean, update it, then if that fails I will either find a better dump source or use the ME FW from your dumped UAR Bad flash BIOS and see if that is OK for you.
^^ This should be your original ME FW anyway, since when you flashed UAR BIOS it did not touch ME FW. There may be ME FW difference between UA/UAR, but the BIOS download from Asus you flashed does not contain or flash ME FW, that’s why it was still OK previously.

Here, program this in, if still issue, let me know and I will make you the other BIOS instead which should be OK if this one is not

15-20 seconds freeze during power on is now gone! Thank you! :slight_smile:

I just have a question, there is a CSM Support option in the BIOS which is greyed out and is Disabled. Is this normal?

@tresdemontano - Great to hear that fixed the ME FW issue!!
That means in that dump from Vinafix, the ME FW is messed up, please let those users know on thread, so next person to download does not wonder what’s going on, how to fix etc.

On CMS - Do you have Secure Boot Control Enabled? If not, then let me know, I can make this not grey and changeable by you if you want.
This is suppress/gray from user if Secure Boot Control is enabled, and or if not “User” account I believe (ie so suppress by default, since all Asus BIOS Access Level = Administrator)