[Request] Intel UHD 600 +Goodix 1002 Touchscreen drivers for Win8/8.1

Hello everyone, I’m trying to get win8.1 working on my Lenovo IdeaPad D330, it’s a detachable laptop, with Celeron N4000 processor (or Gemini Lake, it’s an 8th Gen chipset). Comes with win10 v1809 pre-installed, I don’t think that I’ve to tell how much it sucks. So I installed win8.1 cuz I like it’s interface, it’s faster, and it’s very much like win7. Now, win8.1 installed successfully, the problem is that there ain’t no drivers for 1. The touch panel, and 2. The GPU. I can’t live without either of these since touch panel is one of the main reasons I bought the device, and GPU is obviously required for, let’s say adjusting the brightness. Now I’ve tried many solutions, none of it worked as intended. I’ve read another thread (sadly, I can’t put a link on here cuz it’s my first post) and I’m now able to run windows 10 v1507, the oldest (non-beta) windows I’m able to get. In win8.1, the correct HWIDs for both touch and GPU weren’t visible in Dev manager, let alone the drivers. Now in one of the win8.1 beta (build 9369), I’m able to get the GPU detected, so I tried driver from that thread mentioned above, signature enforcement disabled, it shows that it’s waiting for another device to start. Further investigation in win10 v1507, the one which worked, shows that it has something to do with Intel SIO drivers, there’s a dependency of some sort. So I hope that someone can help me with this. The ONLY condition is that the solution shouldn’t require bios modding or hardware changes cuz I don’t wanna screw up the firmware. Otherwise it could be ANYTHING else, any OS, any driver packages, literally anything except bios modding, because in case of os, I KNOW what I’m doing, but in bios, I literally have no idea what I’m doing so don’t want to mess that up, I ain’t got any important personal files on that machine either. So I hope that someone can help me with. Lol it’s too long to read, sorry about that.

PS:- pardon my english, it ain’t my first language
PS2:- I’m new to Win-raid, this is literally my first ever post on here

EDIT by Fernando: Thread title specified and shortened

@ojas763564921

You can get UHD 600 detected without yellow marks with build 9888 (last build with w8/81 taskbar & theme), if you port intelpep.sys (Intel Power Engine Plugin) from build 9369. I managed to get a non-black screen but a messed image with lot of letters (probably login screen) but with the blue background doing some tests with modded uhd 600 drivers. I’m sure a UHD 600 driver can be installed on w9888 but I don’t have time to do more tests and I don’t remember which driver worked with messed letters and images.

Intel UHD 600 on Windows 8.1 Help

You can also boot windows 8.0 (yellow mark on GPU in device manager) with an acpi.sys from this forum.

But touchpad is not recognized until 9926 or maybe in some previous one.

you can get a better experience in 1507 or 1511 compared to 1809.

Also some beta w10 builds are close to w8.1 and you can use wddm 2.0 drivers with a different performance and a similar experience to w8.1 U3 cause wddm development is close yo wddm 1.3 rather than wddm 2.0 rtm or wddm 2.0 1511.

In my opinion w8.0 is the best OS. I hope someday we can have a kernel extension for w8.0 so we can run modern drivers.

The best of w10 is the memory management of course but the GUI isn’t as nice.

The main problem of the GPU drivers not working on these early w10 beta builds are probably intelppm and intelpep in these type of CPUs cause are “underpowered”

Well, I’d say that you’re a little late lol. I got a new laptop, it’s HP-15S (2021 model), with AMD ryzen 3 3250U, and Vega 3(?) Graphics, I gave the older one to my mom. Now, in this case, I’m able to install 8.1, get the gpu detected, and I found a modded driver for amd from this forums, and somehow installed the gpu drivers without ANY problem, in 8.1. I think it’s due to the fact that Intel is much more “strict” than amd, like Intel would literally hate you for using windows version anything before 1709 lol. But the problem is, I can’t get the touchpad to work, in 8.1, I did test the gpu driver with tab key and lots of patience, it works, but no touchpad lol. Infact, even in 1607, the touchpad is not detected. It’s probably due to the touchpad being I2C, even with my older laptop, the touchscreen was I2C. Where can I find I2C HID drivers? Man it’s all set, just the touch and it’s done.

(Oh and btw, on the older laptop, the windows threshold beta builds, anything including, and above, 9888, didn’t boot up, even with changed bios date, they all have me “kmode exception not handle” so I couldn’t test even a single one of them)



@ojas763564921


What language do you speak?

kmode exception not handle can be solved I have had the same error the first time I tried to install it, but considering it’s possible to boot the installation (less drivers loaded) I realized it’s something related to the INF & Drivers folder, so you need to copy these folder from boot.wim once you have the windows installed with WinNTSetup from another partition (fast and easy method for trying beta builds instead of bootable usbs). so the steps are:

1 - select iso with winntsetup and a partition
2 - Rename “INF” and “Drivers” folders from c:\Windows and c:\Windows\System32
3 - copy INF folder and Drivers folder from boot.wim to c:\Windows\ and c:\Windows\System32\
Now the trick since the Windows it’s installed and registry is configured with a minimum of required services to boot successfully withous BSODs.

open the renamed folders and sort them by name, go to the bottom and copy all starting with X…sys to intelppm.sys to the drivers folder from renamed drivers folder and do the same with INF files to the INF folder

Well I will need to check it , cause I’m not 100% sure if you need to remove intelppm from driverstore, inf and drivers to boot it

but after that you need to put intelpep from 9369 to get the GPU detected and Windows will boot and the gpu appears on device manager

I can tell you exactly which files will you need but it’s more or less what I explained.



About touchpads and I2C, in case of Lenovo it’s working at least on 9926 this is because something related to the kernel, you can found more info if you search the solution for Linux.

I don’t know about AMD right now, but it’s interesting if you can get gpu drivers for ryzen in w8.1




Edit:

With 10074 or 10064 it’s easier. You won’t need to copy any inf or driver file, but you need to install it using WinNTSetup, after all with some tweaks and aero lite you will have an OS similar to w8.1 (you can also enable old w8/8.1 login screen on it)

This one it’s the fastest w10 I tried and very close to W8.1

Yeah but i think that threshold 10074 or 64 doesnt have win8.1 start screen does it? Also, the touchpad is dependent on AMD I2C controller (hwid ACPI/AMDI0010) and AMD GPIO controller (hwid ACPI/AMDI0030). When I clean installed windows 10 v1607, the ids were in devmgr and i was able to install those devices and as soon as they installed, it detected the touchpad and cursors started working. But in windows 8.1, none of them would show up in devmgr as “unknown devices”. I did find those hwid on drp.su, that were 8.1 compatible, but installing them using legacy hardware wizard just throws a “System Thread exception not handled”, in windows 8.1 can you help @Fernando ??. I think I should start this discussion in a seperate post cuz the title of this post is now quite irrelevant of the discussion we’re having

@ojas763564921

To enable w8/8.1 start screen on 10 beta go to:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Authentication\LogonUI\TestHooks

and change 1 to 0

@ojas763564921 you said "HP-15S (2021 model), with AMD ryzen 3 3250U, and Vega 3(?) Graphics", what AMD driver from this forum do you use? can you post a link to the thread, please?

thanks!

[Solution] Win 7/Win8.1 x64 Ryzen APU Video driver this one, though I highly doubt that It has anything to do with I2C+GPIO2 not showing up in the devmgr. And yes the driver does work when installed with legacy hardware wizard and driver signature enforcement disabled. The user claims that it can even work on windows 7.