[request] Modded bios for Tyan S5533 MoBo

at first sorry for my bad english but i had only german and russian at school :-/
I tried to change the bios myself, but i was only able to change the microcode with UBU
I still wanted to change the disk controller from orom IRSTe and EFI IRST from to I was only able to change the EFI IRST to that, the orom IRSTe is still…
Then i would change the Network OROM Intel Boot Agent GE form 1.4.04 to 1.5.62 (last supported by GUID) but nothing happened.

Can somebody help me?

Bios is here: https://www.tyan.com/Motherboards=S5533=…LE=downloads=EN

Thanks, regards Christian

P.S. Is it also possible to mod the ME Version?

What does this mean? >> Network OROM Intel Boot Agent GE form 1.4.04 to 1.5.62 (last supported by GUID) but nothing happened << What did you expect to happen?

If you want to update ME FW, use ME FW Update tool, editing BIOS ME FW does not always mean it will be flashed in.

Yes, I can update the microcodes and IRST roms for you.

Intel C222 server board- ME Intel SPS 3 - AFAIK no update tool available.

I expected to be able to update to the version 1.5.62. The UBU has nothing changed. (Filesize exceed?)

that would be nice if you could do that

@lfb6 - thanks, I didn’t notice I guess this will need done via FPT, with unlocked FD or ME/FD/Service jumper, or pinmod.

@wildgunman - thanks for explaining about Intel Boot Agent, see now that makes sense File size exceeded??? Indeed? Is that the error you got, or are you questioning??
Anyway, I can update that for you manually too. I will also update the ME, you’ll need to check board over to see if you can find ME/FD/FDO/Service 2 pin jumper to allow ME reflash via FPT, or I can send you interim BIOS to use with ME Reflash enabled (Thus ME Disabled), so you can then FPT flash ME region possibly.
I checked your board images and PDF, you have ME HDR 2-3 pin jumper (J50 ME Recovery / ME Header recovery signal), but the PDF is not clear if this can be used as we intend, or even what it’s default position is. It’s on page 16 ftp://ftp1.tyan.com/doc/S5533_UG_v1.0a.pdf

Can you flash mod BIOS with the included AFUDOS? If you are not sure, best to send me FPT Dump.
I see you’ll need to disable SMI Lock and BIOS lock before you can flash mod BIOS with FPT, so maybe if you can flash mod BIOS with stock AFUDOS then maybe easier for you?

I assume you want the 1.01 BIOS used, correct? Hope so , moving forward with that, for now

Do you know how to use FPT? If yes, please send me FPT dump of your FD (FPTw.exe -desc -d fd.bin) and dump of your BIOS region (FPTw.exe -bios -d biosreg.bin)

I’m sending you V4 SPS ME Tools via PM, do not use willy-nilly wait for directions before you try to write anything, you can brick your board in one click easy.
FPT must be ran from Admin CMD Prompt - Select the folder that contains the exe, hold shift and press right click, choose open command window here (Not power shell)

If you are stuck on Win10 and cannot easily get command prompt, and method I mentioned above does not work for you, here is some links that should help
Or, copy all contents from the Flash Programming Tool \ DOS folder to the root of a USB Bootable disk and do the dump from DOS (FPT.exe -bios -d biosreg.bin)

@Lost_N_BIOS He should be able to flash with afudos, the newer bios (1.01) contains an ME update and there’s nothing mentioning setting jumpers to enable writing ME region. (No readme in the bios-update, nothing in the manual). Flash bat is ‘afudos 5533V101.ROM /p /b /n /x /me’

My C222 SPS3 board (ASUS P9D-I) has 2 (3) ME jumpers:
ME recovery ‘allows you to force ME boot from recovery mode when ME become corrupted’ (SPS3 has a smaller recovery partition in its firmware- but never tried it)
FDO1 for unprotecting ME region
ME_PWRMODE1 for ???

Thanks @lfb6 I didn’t check the stock batch command to see if /ME was in there, slacking over here I guess

Well have to have him confirm current ME FW version before/after BIOS update to confirm it updates, but I do assume it will on at least this update, due to all you mentioned

@wildgunman - can you see current MW SPS FW version at >> Chipset >> Intel Server Platform Services >> SPS Version
If not, can you see if you can see it with HWINFO64 and on the large window on left side, expand motherboard and find ME area, inside that get the ME Firmware version. That may not work, I know HWINFO64 can’t see TXE type, so same may apply for SPS

FromTyan Bios page: "2.update intel ME from to" (SPS 3 for Xeon E3) One of those it should be… (Latest of this tree is AFAIK)

I did see that, but it doesn’t always mean it was applied, and we don’t know what BIOS he’s using, so best to check directly if we can. I guess it only matters afterward anyway, if he sees the one we stick in there


sorry for the late responce, but I was busy. I would disregard the ME Flash because it is too risky for me.
It would be enough if the Intel Boot Agents, the RSTe and the microcode were up to date.

@wildgunman - it’s OK, sorry for delay here too, will get you this BIOS tonight!

* Edit - What a dance that was! I now see why UBU failed to do many things here, and probably failed on what it did do (microcode update probably bricked BIOS due to padding file removal above second uCode GUID instance), I didn’t check, only assume
MMtool 5.02 and 5.07 both remove that padding after rebuilding CMSCore too (so UBU would cause issue on those replacements too), and 4.50 can’t replace certain things, 5.07 saves as unsigned while 4.50/5.02 does not.
It’s a fiasco to mod this BIOS and make sure it’s done properly!

ME Flash is fine, it’s part of the stock batch flash process. I have mod BIOS all done, except waiting on ME FW so I can do that part for you too before sending your way

Then all I have to say, many thanks for your efforts. I’m looking forward to the bios.

You’re welcome @wildgunman - will get your final BIOS tonight, thanks to @lfb6 and @plutomaniac for the files and discussions about this ME

by the way, afudos will flash modded BIOS when i use the /gan Parameter. :slight_smile:

I don’t know, or are you confirming that is OK? I would not suggest you use that unless you have read someone confirmed it was safe on this board, and that they also confirmed it actually flashed in the mod and not just appeared to do so
First I would try the stock flash method, then my suggestion is if that fails you dump BIOS region via FPT and send to me then we reflash that way.
AFU /GAN should only be last resort and I actually would not try that unless you have flash programmer in hand and backup made in case it bricks the system.

Sorry for delay, we’re still discussion the ME FW stuff, I wanted to be sure the update is safe before I handed to you. BIOS is done otherwise.

I referred to an earlier question from you. I have the BIOS in the past again and again supplied with microcode updates. Since without the gan command partly errors occurred, I used this. Until now that had always worked and the microcodes were taken over for the CPU.

/GAN may not give you errors, but it also may not actually flash the BIOS, or it can brick the board. Since you are confirming you’ve used it, and it didn’t brick, that is good. So you also sure updated microcode is used by CPU, what did you check with?

I checked in the BIOS himself (BIOS has a "CPU Tab" ) and i checked with HWINFO.

@wildgunman - Thanks, good way to check microcode then, sometimes Windows switches it out on you, so I was hoping you’d be able to check at BIOS or POST Screen etc.

Here is mod BIOS, without ME FW Update, if you want that done I’d feel more comfortable giving you that BIOS after you have a flash programmer and SOIC8 test clip cable in hand and a backup made and checked to be sure it was proper.

First try flash from DOS Using flash.bat (edited for mod file name), if that fails, then go ahead with /GAN method I guess


1. Updated CPU microcodes x3
2. Updated Intel RST EFI/oRom x1 each
3. Updated Intel/RealTek GBE/PXE Boot Agent x2
4. Updated Intel ME FW to latest version - Skipped, well it’s done, but awaiting programmer before sending your way.
5. Unlocked FD


many thanks for the Bios. I haven´t a flash programmer, but I know someone with one. :wink:

I have flashed the Bios, but with errors.
Here the Error Screens:

without /gan


with /gan


Regards Chris