[Request] Modded Bios to enable PTT on Maximus Extreme 8 + i7 6700k

Never tried but why no eneable it at startup in ME config? The firmware tpm is not permanently disabled (at least in latest images), so enabling at startup should meybe do the trick. Unsure if resetting the TPM with OS tools will work, but I think, it mght be possible?

See “Intel(R) PTT initial power-up state”:

1 Like

you need flash mod bios i have provided first.

Hi! Sorry my bad, I didn’t think of flashing first…

The option is now shown in bios, I have enabled PTT now, with PTP Aware. Windows still seems to think I don’t have TPM. Have you any idea how to fix this?

Thanks you for the nodded bios btw!

You might check with MEInfo. There should be information like

FW Capabilities 0x7DF6D147
Intel(R) Active Management Technology - PRESENT/ENABLED
Protect Audio Video Path - PRESENT/ENABLED
Intel(R) Dynamic Application Loader - PRESENT/ENABLED
Intel(R) Platform Trust Technology - PRESENT/ENABLED
Service Advertisement & Discovery - PRESENT/ENABLED
Persistent RTC and Memory - PRESENT/ENABLED

This is ME 12, might look slightly different on your version.


The option you reffering to seems to be active

Would have been first post of this thread and then paragraph C2:

C2. (CS)ME System Tools
Note: To extract the files below you need to use programs which support RAR5 compression!

* CSME System Tools v11
For CSME v11

If enabled in ME WIndows should theoretically be able to find the TPM?

What does device manager say, what does tpm.msc say?

In Bios TPM set to dTPM or PTT?

In Device Manager its not shown.
In tpm.msc its shown for a splitsecond, then it shows “not found” again
In BIOS its set on PTT

EDIT: Also tried disabling CSM, didn’t help

Well, I think you have to ask @ dsanke here.

The bios he provided may have a Coffelake mod which involves to messing with the Intel ME afaik.
At least his bios has the microcodes for Coffeelake and a ME version that never came from Asus, stock firmware were on (3703 and 3801) and (3504 and some more earlier), you now have

So I don’t know what modifications he did within the ME region / if he did modifications within the ME region that could compromise PTT function.

@dsanke Could you verify this please?

Unfortunately my technical know how on bios mods is not the best as i’m knew to this topic…

If i can/need to provide additional information i can surely do this!

EDIT: Reflashed original Bios (NOT via Flashback, just bios update). Now this is showing up, which is confusing af:

try flash mod bios again with flashback. flashback wont downgrade Intel ME, so the current ME state should preserve.
the mod bios have, coffee lake mod, but i just changed the ME version, i didnt change PTT related settings.

EDIT Just try first what dsanke proposed!

[You could try this firmware, it’s pure stock just with PTT automatic startup at boot changed to enabled in ME config.

outimage.zip (9.3 MB)

But I assume this won’t update now since it’s same version for bios region and ME, so you’d possibly would need to go back to the firmware from dsanke again for example.]

Indeed changed a little bit, still not working unfortunately, but really thanks for trying to help!

Sadly this is a bin file, but i have to use a cap file as far as i know, do you have this one too maybe?

Thanks in advance!

Well, this won’t get better with my file, the TPM seems to be enabled now in ME and that’d been the only difference to stock in my file:

One problem might be that the endorsement key is marked ‘revoked’.

There’s a lot of tools for TPM in Windows:

tpmtool getdeviceinformation (Powershell)
Get-TpmEndorsementKeyInfo (Powershell)
Get-Tpm (Powershell)
Get-TpmSupportedFeature (Powershell)
Clear-Tpm (Powershell)
Initialize-Tpm (Powershell)
Unblock-Tpm (Powershell)

Some usefull error messages there?

No device manager device?


Maybei it’s neccessary to enable this option, too, but that’s kinda guessing - as would be the frequency

Hi, sadly none of these cmdlets works (I was trying nearly every single potential “fix” i found or could think of). It just says that the module is either missing or that there is an access error - which i guess comes to the same conclusion).

Maybe the hint of yours could work (with this other option) but i have no clue on how to edit the bios to show hidden options.

BTW: Is it even possible to have an i7 6700k work with the M8E? I’ve read online that the i7 6700k lacks TPM 2.0, while the 6700 without k has it (So far i thought TPM is chipset things). Device Manager is not showing the Security Module.

EDIT: I will send you the error messages for the tpm cmdlets when i’m at home

Unfortunately the setting I mentioned is stored in FD and probably the FD is still write protected even in dsankes modded bios.

1.) I don’t know if flashback will overwrite the FlashDescriptor
2.) I don’t know if the caspule is specific for the complete content, I just changed one bit in FD without modifying the capsule
3.) This might brick the computer (but I think this might be the last setting missing?)

Just changed the one bit that enabled ‘TPM over SPI bus’ in FD in dsankes firmware, you can try to write it with flashback:

M8E.cap.zip (8.3 MB)

You can check if the FD is overwritten by dumping it with fpt(w/64)) -DESC -d FD.bin (it’s in the tools package you downloaded).

Checked TPM capabilities of the CPU but didn’t find any information that 6th gen K cpu would behave differently?

Here’s someone who claims he did it with a i7-6700K on an MSI Z170 board

Had a lock at MSIs Z170 board and it’s just the Z170A GAMING PRO where one can choose between dTPM and fTPM, and it’s bios doesn’t have the TPM over SPI bus option enabled.

Hi, i just flashed your file with bios flashback. But it seems that it didnt override flashdescriptor. I did a backup of the bin file before and after the flashing and compared it with fc.exe tool in commandline.

to EDIT 2: I have the dTPM option aswell, i can choose between PPT and dTPM, so far i always used PTT.

EDIT: It says “EK Revoke State”: Revoked down below. May this be the issue?
EDIT2: Do you know what “Verified Boot” is? Secure Boot should be enabled

dTPM would mean discrete, but afaik your board doesn’t have a header for a module?

Read several times that revoked doesn’t exclude proper function.

What options do you have for TPM in bios settings? Can you post a picture?

I see, no i dont have a TPM Header on my board…

I only have two options in bios for tpm:

ptp aware os/none ptp aware os

Thats it

EDIT: Actual State:

PTT enabled
PTP Aware OS: Yes
Secure Boot: UEFI Only
CMS: Disabled

The options above seem to be required for TPM 2.0 to work