[Request] MSI P45/P45D3 Platinum and P45 Diamond UEFI Bioses

Hello! I’ve been at my maximum on finding these uefi bioses, and i dont have any clue about where to download this bios and how to flash it from LEGACY Bios. I’ve tried wayback machine but no clue, cant even download the file or even know how to upgrade to UEFI bios from legacy. If anyone does have the motherboard UEFI Bioses file and know how to flash from legacy, please let me know.

Wayback Machine:

Edit by Fernando: Thread title shortened and specified regarding the mainboard manufacturer

1 Like


Here are the links:
1. >MSI P45 Platinum BIOS<
2. >MSI P45D3 Platinum BIOS<
3. >MSI P45 Diamond BIOS<
By the way - none of them is an UEFI BIOS.

@Fernando , these are not the ones that needed.

@Koekieezz , for now I only have 2 of 3 requested BIOS and another one is nowhere to be found, but one some chinese forum (paid). Would it be better if I pay for the BIOS for "P45 Platinum" or should I give you what I have already?

@Sweet_Kitten no need to pay for anything, you could give what you have. By the way, do you know how to flash these bioses? since wayback machine cant load the images on how to do legacy to uefi, and uefi to legacy. all i know is only P5Q Deluxe that does have UEFI Bios, do you know any other LGA 775 mobo that used to have UEFI bios? this is kinda interesting :smiley:

@Fernando P45 Diamond, Platinum, and D3 Platinum does have beta uefi bioses, but i cant find it and know how to flash it.

MSI P45 MSI 45D3 Platinum
MSI P45 Diamond

The search was performed on archive names from the waybackmachine saved copy of site.

BIOS with index "E" in filename, according to information from the network, are flashed using the MSIFLASH program for DOS. And BIOS with index "A" in filename are flashed with "AFUDOS". MSI P45 Diamond never had an "E" BIOS but that doesn’t mean the ones posted on the support page are the only ones.

thanks @Sweet_Kitten this is such an information! Also do you have the MSIFLASH for DOS you did said?

Try the one that is in E7513IMS.rar.

EDIT: Just found out that MSI had another utility with identical name but for flashing compact disk drives. Of course, it is not intended for BIOS flashing. And out of my ignorance, I put this particular utility in the archive. But now I’ve replaced it.

By the way the link for the efi bios for msi p45 platinum si wrong. The file should be E7512IMS.xxx. I was searching for it for a longtime but i’ve found it. İt seems new users can’t upload files on this forum. But here is the link https://driver.zol.com.cn/detail/34/338827.shtml#local-down
İ was reluctant to download but decided to give it o go and thanksfully no viruses or scam
İt’s the latest efi file for msi p45 platinum E7512ims.107

1 Like

You’re right. I should edit my post and give a different name.

Turns out i was wrong the latest efi bios for msi p45 platinum was E7512IMS.100
Sİnce i was new in the forum i couldn’t upload the file but i’ve been promoted :smile:
So here it is
E7512IMS.100.rar (3.1 MB)

I’ve been digging in the german version of the msi forum (P45 Platinum-EFI-BIOS | MSI Endanwender-Forum DE). İt is very usefull for old msi motherboards.

1 Like

EDIT: Not looking for the files, already have it long time ago, just posted an old capture with resumed bios versions.

Unfortunately the link on this page is broken you can search it through the link i’ve provided earlier.

1 Like

C’mon now,
Let’s do some work for these files with this old MSI P45 chipset but UEFI bios support.
@gokoum I tried to help you with your request on the thread I started here and the thread you also started.
But I noticed that there are some missing modules in the P45 Platinium UEFI bios file and MSI engineers left this work unfinished.
@Koekieezz P45 Platinum UEFI bios Did you review the file?
What are you thinking?
I don’t have much time to deal with.
Maybe a new study can come out of here.

I agree but so far i didn’t notice any strange behaviour. But i guess overclocking settings, fan settings do not work properly, ntfs support, and the lack of G.O.P. module are also a concern. The biggest problem is the lack of secure boot CSM disable options. But implemeting these is tricky and time consuming. And i don’t know where to start. I don’t have a programer either so messing with efi files is dangerous at some point because there is no way for me to recover. To be honest it’s fine with the addition of the nvme module. There is a guide here for ahci and raid roms that could be updated. According to the guide, >Intel RST(e) RAID ROM v11.6.0.1702 and >Intel AHCI ROM v2.00h (new, but its benefit has not yet been proved) (>MIRROR< ) are the most recent roms. Since i personally don’t use raid and that ahci drivers are ok, i didn’t need to upgrade the efi bios.

You can also share your idea of implemeting a pci rom (for nvme) for non uefi bioses like you did for the msi p45 platinum (which i didn’t try because i’m still using the efi bios). Thanks again for your help. I’ve learned a lot from you and thsi forum. It’s really good to see people helping each other. :innocent: :smiley:

1 Like

Why did I request this work here?
I love this forum.
Because there are sincere people here who produce different ideas.
Or so it seemed to me.
EFI-UEFI bios was given to these 2 organizations by AMI for the first time in 2007-2010 for MSI P45 Platinum series and Asus P5Q series motherboards, and the engineers worked on these different bios files for a while and I know that this job was discontinued when there was no demand from the users…
I could be wrong though.
This forum has extensive knowledge on Bios compilation and modding.
I can say that the UEFI bios designed by AMI for these series motherboard models that I mentioned above are the ancestors of the UEFI bios that many users currently use on their new generation motherboards.
The reason I don’t care about this is;
For those new to this business, it will be a very good guide to tamper with or analyze these 2 series old UEFI bios.
I have already prepared NVMe M.2 SSD bios with Legacy bios injected for MSI P45 Platinum and gave it to you.
I hope you are using it now without any problems.
But the downside of Legacy bios is that Hardware Credentials are required for each NVMe SSD.
So the universal Module does not contain this file I gave you.
But I still think it will be complete and achievable even though UEFI support is half to add universal module to MSI P45 Platinium motherboard.
Maybe it’s a futile effort. I don’t know.

Since i’am almost happy with the uefi bios i didn’t try your version with legacy bios. The fact that the nvme module that i added to my efi bios is universal was a selling point for my case. Since i have a few other nvmes that i could use with this mobo in the future.

I will try to update raid and ahci roms and the realtek network controller. I wonder if i could add an ntfs efi driver for ntfs detection in uefi shell. (i guess i could try to load it from the uefi shell first and see if it works) but i don’t know if there are other dependencies/factors for that.

I did learn that a gop module for video is difficult to apply. İt affects several efi drivers like pcie and others so it’s quite difficult. I guess it needs a complete modification of the uefi.

This is not true. According to the first post of your linked thead (latest update done on 05/28/2022) the v18.35.0.4635 is the latest available Intel RST RAID ROM BIOS module.
Nevertheless the v11.6.0.1702 may be the latest Intel RAID ROM, which works 100% with the Intel P45 Express Chipset of your mainboard.

I was in deed talking for this specific case of intel 4 series p45 board.

The Efi system on this board (msi p45 platinum) is incomplete and needs much more optimization. I’ve noticed some serious problems:

  • Cpu was running hot even in idle with default specs.
  • Had few unexpected reboot while updating windows
  • Hdds and the nvme was around 40C in idle mode
  • The gpt volume contained in the nvme drive couldn’t boot after enabling AHCI mode.
  • Any overclock attempt resulted in corrupted boot

Therefore i decided to revert back to legacy ami bios and found this. Before trying i tested the modded legacy bios you uploaded and failed to boot from the nvme drive. It turns out th pci option roms did have vendo/device ids for other nvmes but didin’t contain my nvme’s ids. So i extracted the option rom file from the bios added vendor/device id for the adata xpg 8200 pnp and successfully injected in the updated ami bios (A7512IMS.18B).

This bios is updated from the beta bios from the msi english forum (A7512IMS.17E) and has the following updates:

-  Update Version display.
-  Update MSI LOGO.
-  Update JMicron JMB36x RAID ROM.
-  Update LAN ROM.
-  Update Intel RST RAID ROM.
-  Update Intel Eaglelake SVGA ROM.
-  Update CPU Micro Code. From lga 771 to 775 (couldn't check)

I only added the pci option rom for my nvme with matching device id and vendor id.

I fırst tried to flash the bios with msi’s flash tool: msiflash.exe in DOS environment with the command: msiflash A7512İMS.xx /p . I couldn’t boot at first try although the nvme appeared as an ide nvme drive. The windows setup could start but the nvme drive was disappearing after the initial reboot.

Then i tried to flash the modded bios with Afudos using all of the following options /P /B /N /C /E /K and it worked.
I can now boot from the nvme, the windows installation was flawless. Enabled AHCI mode after successfull instalation by switching to safe mode (just in case) then restarted and entered bios and enabled ahci mode and switched of anything unnecessary (Firewire E-sata etc…)

  • CPu in idle mode has much lower temps (38-40C) compared to 50 in uefi bios.
  • The boot from usb for initial windows setup took an unusual time to boot. It took around 25 min for the setup screen for language selection. But everything went fast afterwards.
  • Compared to uefi bios the nvme speed is faster especially in seq18k read and rnd4k read in crystall disk mark 8.0.4 with the nvme setting/preset instead of default.
  • With the(U)efi bios i could install the nvme adapter to pciex 16 port 1 or 2 and had same transfer speeds. With the legacy bios when i put the nvme adapter to the second pcie port at the bottom of the motherboard, i have half the speed i’m getting in the pcie port 1 which is the close one to the cpu. According to this motherboard’s specs i should have pcie 2.0 x8 lane bandwith for each (the gpu and nvme). I guess there is a little bug there.

Anyway, i’m pretty happy with this result, i will stick to the legacy bios for now and see how it goes. It’s amazing to get these speeds on this board dating back to 2008.


(upload://oTcQqVYNf8lbrRynwGA7dG6UoDi.zip) (729.1 KB)