Request: MSI P67A-GD55 bricked, need to update the new Bios with the old values

Hello all,

I have currently a bricked MB from MSI: P67A-GD55 from my cousine, he was trying to update the Bios via the .exe File from Windows. That was the mistake, the Bios update went terribly wrong and now the PC is in a Boot-Loop and bricked. I could not reflash the Bios via the standard procedures as clear CMOS, put the .exe/.bin file to USB stick and tried to update it from UBS drive etc. The only possible way is to reflash it with the CH341A Programmer.

I got the programmer and I was able to connect to the Bios Chip (E7681 IMS140 is written on it) and during the connection process I am asked to specify the Chip further from these 3 options: W25Q648BV/W25Q648CV/W25Q648FV…I have choosen the first one…which one should I choose?

I now have the old Bios File downloaded (have all 3 variants) and I want to upload a new Bios to it via the Ch341A Programmer. The question is which version was the old Bios, which highest version of Bios can I flash to it and how can I edit the new Bios File to contain also the MAC Address etc. and all the values from old Bios. There is a great video on youtube for this, and it uses the software from LongSoft: UEFITool and FD44Editor and with these tools he is able to read out all the info from old Bios and paste them to the new Bios. The Problem is the FD44Editor works only for ASUS Bios and not MSI. Is there some similar user friendly tool to this FD44Editor that I can use for my MSI Bios? Or how can I proceed here?

I know it is old MB (there is the i2500K in it) but it was still going good till the BIOS Update and it is such a vaste to just throw it in the bin, when It can be repaired in like 1 minute when having the correct Bios.

Edit: The MB is: MSI P67A-GD55 (MS-7681 Ver 1.0) with Intel i5-2500K. After doing some research on this forum, I am still not able to update the new Bios myself, maybe @Lost_N_BIOS could you please help me here if you got some time? Thank you


Thank you all

Visual identification of the chip itself is the most accurate way to know, get the label out and u will see wot u need.

[[File:Captura de ecrã 2020-12-28 013305.jpg|none|auto]]

It is written im my post: E7681 IMS140 is on that Bios chip. Its almost the same as on your picture. But based on that I did not found out which of these 3 options should I choose: W25Q648BV/W25Q648CV/W25Q648FV. I have therefore downloaded the Bios with all 3 options, so I now have the 3 versions, but I think they look the same so it should not be a big deal.

The problem is, could someone control my downloaded old Bios, read out the values like MAC Adress, UUID etc out and write these values to the new Bios from the MSI Site? So I can update my MB with this new updated Bios.bin file.
------------------------

In the meantime I have modded my Ch341a Programmer to 3,3V mod, I just hope I did not damaged anything with the unmodded programmer that was putting 5V to com pins. I have now downloaded the old Bios with the Ch341a Programmer connected to RaspberryPi with flashrom app, and have it in a .bin file now. It says it is a Winbond flash chip W25Q64.V. The only thing I need is that someone verifies that the backup of the old bios is OK, and updates the new Bios with the UUID, MAC etc information that comes from the old Bios. Is anyone here capable of doing this? It would be great to put a youtube tutorial video for this so everyone can do it for himself and not ask for help and bother so other people. Thank you in advance

Really no one ho knows how to read out the values like UUID/MAC Adress etc from the old Bios.bin file and put them into new official stock Bios.bin file from MSI site? Do I have to put the old motherboard to the bin and buy new one? I thought that when this forum is about Bios modding, the thing in the first sentence would be a piece of cake for lets say 50% of memberes who read this post. Maybe I have to ask in a forum for bakers and cooks…going to order new MB with some AMD Ryzen processor. Thank you all

@Jay-t - You need to remove the sticker and read the ID off the BIOS chip, that’s what MeatWar is talking about.
Not all software/versions can read or write to all chip ID’s correctly, and sometimes you need to use incorrect ID with certain software version for some chips (including one you mentioned)

Hopefully you have NOT erased or written to the chip yet! Please attach your dumped BIOS too, put in a max compressed zip and upload somewhere and post the link
You say that you download BIOS with all three chip ID’s, I assume you mean dumped with all three ID’s using programmer? If yes, OK, but what version of the software are you using, this is what matters first, then chip ID

You also need to add, images from ALL stickers on your board (in a zip). Be sure to look on side of 24 pin, top/bottom sides of PCIE slots, and the back of the board.

@MeatWar thank you for you reply, I did not know that the green thing on the Bios chip is only a sticker. I have removed it and it says: winbond 25Q64BVSIG 1042. I have also done a Bios dump with raspberry pi with the flashrom app where you do not have to choose the Bios Chip variant, I have sent it together with the photos to @Lost_N_BIOS , if anyone else would like to help me just ping me with PM and I will send you the link as well.

I did not do any erase/write attempts with the CH341A programmer, I have only read the Bios out with the 5V original version, then with the 3,3V modded version. The only Bios write attempt was only the software one by my cousin, he has tried to update the Bios to the newest 4.3 Version with that Bios.exe file, he is not sure anymore if from the USB stick or directly from Windows 7. I think he should use the highest version of Bios the 1.19, as he has the Intel i5-2500K inside, but I am not sure of this…I think the Bios 4.3 will NOT run with i5-2500K SandyBridge.

The thing I need is to tell me if the bios dump is OK, to choose which Bios variant (1.19 or 4.3 or anything else) should I programm with the Ch341A programmer and to populate this new Bios with the values like UUID/MAC Adress etc with the values from the MB Stickers/values from old Bios.

Thanks guys for the help

@Jay-t - for W25Q64BV 1.30 or 1.34 and BV ID is OK, also Asprogrammer and Colibri work for this chip with actual BV ID too (I mention because with FV chip you need to use BV ID in some programs)
Flashrom from Linuz/Pi should be fine too, I will check the files you sent in PM (<< This = NOT, see below)

You can’t program anything from MSI directly with programmer, at least not an EXE file, BIOS must be extracted from the EXE first.
You can use BIOS 4.3 (430), and I suggest doing that, here is the extracted .430 BIOS - http://s000.tinyupload.com/index.php?fil…961504828390011

There is no system specific info is stored in this BIOS, at least not in your dumped BIOS, or others from this era that I checked, and MAC ID should be stored in chip so LAN should be fine once you are done

All your “old” dumps match and BIOS looks generally “OK”, so whatever method you used for 1, 2, 3 are confirmed OK for "Read"
Flashrom/Linux dump is BAD, corrupted microcode, and ME FW, and last volume is messed up somehow
BIOS crashes out program when trying to open in UEFITool 51-52, and wont open properly in AMIBCP either - So this method should not be trusted to write to chip.

What I mentioned in PM is the issue here, he updated BIOS to 4.3, but did not wait for ME FW update, so it never got updated V8 during the BIOS update process
It’s still on V7 ME FW, and that wont work with 4.3 BIOS, this is why it’s bricked now.

Use 1.30 and chip ID BV, do each step manually >> Erase >> Blank check >> Open BIOS file (choose file type - All File .) >> Write >> Verify

Hello all, finally I had some time to flash the new Bios from @Lost_N_BIOS with the CH341A programmer, put the MB back to the PC, connect all peripherals and YES IT IS RUNNING NOW. Thank you soo much guys, and big THANK YOU to @Lost_N_BIOS as well. Have a nice day guys

@Jay-t - You’re welcome!
Great to hear all is working again now