[Request] MSI Z390 MEG ACE BIOS

Hello all. First of all sorry for my English. I have MSI Z390 MEG ACE Mobo. And i want to disable HPET from bios. But default bios dont have any setting about HPET. I want to create my own bios but i never did something like that and afraid about brick my mobo. İf its possible could anybody share or make a bios for MSI Z390 MEG ACE to disable Hpet. Thnaks all.

@ozy007 - which BIOS version? - https://www.msi.com/Motherboard/support/MEG-Z390-ACE

Can you flash mod BIOS with M-Flash, have you tried before or not? If you try, always rename mod BIOS to stock BIOS name.extension for best chance it will work. If we can’t flash mod BIOS by M-Flash, then we can do with Intel FPT

Please zip for me some images of your BIOS, so I can see main BIOS “blocks/sections” shown, and then inside “Settings/Main” at a glance, and inside “OC” Section at top of page
You can use F12 hotkey to screenshot to USB, then zip for me

Hello Lost_N_BIOS AND Thanks for your quick answer. I didnt use mflash before But i can send you my bios flash zip and full name i installed last bios from msi web page but i m working on it and will send you my bios thanks again :slight_smile:

Hello again. I never used any software to edit bios before. But i know which bios i m using now. Its 7B12v16.

Maybe you can help me about to modify that bios version or if u need any photo or something different i can send. I m realy sorry for my english and less knowladge :frowning: But i couldnt find any motherboard with hpet bios setting in the market. (z390) And thats why i m requesting modified bios. I hope to help me i m realy appriciate :slight_smile:

@ozy007 - Moving thread to correct subforum (since this is not an “already modified BIOS”, but rather a request for a mod BIOS)

You used M-Flash before, didn’t you, to update to v16 BIOS? Or, did you just mean, you never tried to flash modified BIOS with M-Flash before?
If not, then it’s OK, we will try later once ready, then if it wont allow, I will show you how we can do with another method.

Yes, don’t worry, your BIOS has HPET in there, I already checked, and I can make it visible for you (probably only along with many other options too due to it’s location)

Hello. I updated v16 with usb flash stick. I download it from msi web page and its original bios not modified. I never flash any modded bios before all original. My screenshots here http://www.mediafire.com/file/s63jti0pcu…eg_Ace.rar/file
Thanks for everything :slight_smile:

@ozy007 - Here is mod BIOS to test, I think it should be correct!
Bad thing for us on this edit, with Z370/Z390 some BIOS (Asus/MSI), are not fully compatible with the only latest current leaked version of AMIBCP we have, many settings names are not correct or not in correct language etc
So, when trying to confirm mod changes it’s hard to tell due to wrong languages and gibberish shown due to BIOS not fully compatible. Meaning I can’t see to confirm this one like I normally can, but what I could decipher vs stock looks correct (handle ID’s correct, foreign name changed to match one I meant it to be etc)
There may be two more bytes need changed, if it freezes when you try to enter the new menu this is why, esc out or force reboot via CTRL-Alt-Del or force reboot w/ power button and either reflash stock BIOS or wait and don’t enter that section again until I sent you new BIOS

Flash via M-Flash, do not FPT flash this, it’s stock BIOS modified if you use FPT you will loose your board specific details.
If you can’t flash mod BIOS with M-Flash (inside BIOS, on USB like you did before), then stop and let me know, I will walk you through making a FPT BIOS region dump to send to me to edit, then you flash that back

Omg Thank you very muchhh :slight_smile: I m appriciate. Now i m trying and feedback. Thank you very much for your effort and appriciate again. Realy realy very helpful and great job for me and i m sure for all of others here :slight_smile:

1 Like

You’re very welcome! And if it’s not right, don’t worry, I’ll get it, just a little tough on this one due to can’t see in BIOS tools in English since board/BIOS is such a new model.
Thank you too, for all your supportive and kind comments

@ozy007 - This morning I was waiting for update/report back when you replied, I assumed you’d be back in a few minutes, luckily I didn’t wait too long (was dead tired anyway)
Surprised you didn’t post back yet. Let me know once you have time, hope all is OK!

* Edit - @ozy007 - Great to hear BIOS menu mod edit above worked as expected! I hoped you would reply about that here so others can see in future, but it’s OK, since I’m saying it now

* Edit 2 - @ozy007 - Sorry, new links added below, in case you download the txt files only at previous link (I left out BIOS )
Anyway, here is further edit you wanted to try, this has HPET forced disabled in all possible areas of the BIOS.
Flash via M-Flash, after flash shut down and clear CMOS, then boot to BIOS and load optimal defaults, save and exit, then reboot back to BIOS to make all changes you need.

^^ New links @ 5/21/2020 - PM me if dead later, thanks!

This worked for me thx.

@Chef_PR - did you test the BIOS in post #8 or #6? If yes #8, was HPET already forced disabled from your testing?

I am thinking of loading this BIOS. Does it have everything updated like CPU microcode, MEI, CSME, PMC, etc… or is it just an HPET edit?

Thanks @Lost_N_BIOS for all your hard work.

Post #6 because their are only 2 .txt files on post #8, but it worked for me HPET is disabled, Thank you!

Yup, no BIOS file in the link from post #8 - just two text files.

@Chef_PR - Thanks! And? BIOS in post #8 should be = MSI-Z390-MEG-ACE-7B12v16-Menu-Mod-ChipsetAdd-ForceHPETDis.7z
Ahh, downloaded, I see, forgot BIOS and sent notes/changelog only, thanks! New links added, thanks for heads up

@Exostenza - BIOS in post #6 is a menu mod BIOS with MUCH more than HPET added, BIOS in post #8 (now) is that same menu mod BIOS + Forced HPET disabled at all possible locations by default
No updates/mods added, stock BIOS menu edit only, change log is included with both downloads

Thank you! I goit it now.

Sorry please possible to have the bios mod also for the Msi z390 Mag Tomahawk version with disable hpet thanks>>>>>>https://download.msi.com/bos_exe/mb/7B18v17.zip

I found this thread on google because I have the same problem as the creator of the thread.
Your uploaded modded bios version of post #6 solved my problem and gave me the hpet bios option I’ve been looking for.
Now there’s a new bios version out there, version v17. Is it possible to add the hpet bios option for the new v17 bios as well?

Version: 7B12v17 Release Date: 2019-12-31
Thanks and best regards.

@forzic17 - MSI Z390 MAG Tomahawk v17 HPET Mod - http://s000.tinyupload.com/index.php?fil…528205015099813 >> Mirror 9/23/2020 due to tinyupload down that week - https://ufile.io/l7xsnoe5

@artiw0w - MSI Z390 MEG ACE v17 HPET Mod - http://s000.tinyupload.com/index.php?fil…923104947513291

* “Chipset” added at top of OC section, inside you will find HPET at following location
OC >> Chipset >> PCH-IO Configuration >> HPET

Good morning the bios in question does not detect me by enabling the Raid 0 stripe the third ssd m2 nvme samsung mounted on ASUS HYPER M.2 X4 Mini Card Pci-e Express Adapter purchased to make a raid with three identical samsung devices m2 nvme 960 evo but the bios only sees me 2 devices the third on pciexpress slot does not see bios 7B18v17 !!!

@forzic17 - please test stock BIOS 7B18v17 and see if you have same issue. Mod you asked for is HPET mod, this has nothing to do with RAID, NVME or PCIE ports etc
However, sounds like you have ran into common issue I read about when looking at reviews for the Hyper card. You need access to bifurcation controls in BIOS so you can set 4x4x4x4 for use of three devices on one port (or 8x4x4, or 4x4x8x), not sure if they are in this BIOS or not, I will look now.

Test other slots in meantime