[REQUEST] Need BIOS to flash onto my Dell G7 7588

Pretty sure I bricked my laptop (G7 7588)
I tried to use the Dell PFS Extract tool to force flash my laptop’s bios to an earlier version to mitigate some awful thermal limits that Dell has imposed since BIOS 1.4, and it failed. Now I can’t boot, it just lights up for a second, then powers off.
I totally admit this is my fault, I tried to go directly to 1.3 from 1.15.0, which is a huge no-no. I should’ve researched it before attempting, but I got excited at the thought of my laptop performing like it used to before I foolishly updated the BIOS a couple of years ago. My machine now won’t turn on, and I can’t get the BIOS to install via USB.
I’m going to order a CH314 machine today, but as I’m admittedly a total noob at BIOS modding (though I did manage to remove the undervolting lock a few months ago before I bricked the machine), I was wondering if someone here could help me get a good BIOS to put on the machine, as well as help with questions during the process so I don’t permanently damage my laptop. I’m fairly good at following directions and I promise not to give any attitude if someone offers to help. Thanks in advance.

EDIT: Can anybody help? I’m really desperate to get my machine working again.

Ok friend,
I will try to help you, if the bios not has Boot Guard active, we will recover your system … , but if you made a wrong update on Boot Guard active , then you bricked it
The Dell (Intel) Boot Bios Guard system on this series laptops have a check that use Fuses in Embedded Controller FPF and when you try to modify this UEFI Signed Bios
then , if your new bios is not signed (we haven’t RSA Key to make it) the the fuse (HW) are burned and EC go off use , so you have to change it , it’s the PCH and you
have to change with a a clean one without a hash burned into the FPF fuses, then there are two ways , write into the it the same ME hash or disable ME or cleaninig it …
I don’t think you can do the PCH replacement , as you need experience and Hot air gun …


Dell PCH.jpeg

Dell New PCH.jpg

Let me know

P.S. It’s better open the laptop and check the PCH state …

Thank you! I don’t think I had enabled boot guard, as I like to tinker with my machines (which is what got me into this mess in the first place). Boot guard is a BIOS setting, correct? I Googled a bit trying to find out if I can test to see if I messed up the PCH, but I don’t see any way to tell. Do you know a way? My CH314 is supposed to be delivered today. Do you need me to post a dump of the current BIOS?

Okay, so I tore down my laptop, and the PCH looks good, no cracks that I can see. I can’t post an image because I’m too new to this forum, but it looks like a clean die.
I’m trying to secure another computer so I can do the BIOS dump. I’ll post it here once I have it.

Okay, here are my bios files. There are two BIOS chips on the motherboard, so I named them backup and backup2. I think backup2 is the correct one, because it’s 16mb, but I could be wrong

Edit: Added the link since I can post them now

I fixed it!! I managed to flash a stock Dell BIOS .bin file onto it using a PFS Extractor and my CH314A device. Thank you all for your help!