[Request] Need Win7 x64 driver for Synaptics Touchpad SYN3286


I bought a new HP G7 250 notebook for my uncle, it’s a 6HM83ES#ABD with i5-8265U and UHD 620 graphics. Unfortunately there are only Win 10 drivers on the HP support site, so after hours of searching and modifying Win 7 discs, inserting several drivers with NTLite and other tools, I finally managed to successfully install Win 7 64x SP1 Pro.
USB 3.0/2.0, Intel UHD, Realtek LAN, Realtek WLAN and Realtek Sound are finally working now.

However, I can’t find any drivers for the Synaptics Touchpad. The touchpad works, but there are some issues:

1. I can’t turn off “clicking by tapping” feature. I know this can be disabled with the Synaptics software.
2. “Sidescroll” and other features don’t work.

According to devices manager, this is the device hardware ID:


I couldn’t find any Synaptic drivers for the SYN3286 model, can I use any other drivers?

Any help is much appreciated.
Thanks in advance, J.

EDIT by Fernando: Thread moved into the better matching Win7 Sub-Forum and title specified

@j41 :
Welcome to the Win-RAID Forum!
The only drivers I have found for the HardwareIDs of your Synaptics Touchpad have been designed for being used with Win10.
Please consider, that Win7 is very old. No Company is willing to develop, test and release drivers for an outdated OS.
My advice for users, who want to use Win7 as Operating System: Do not buy brandnew hardware!
Dieter (alias Fernando)

Hi Dieter, thank you for your reply.

Well, I understand your point that companies don’t like supporting outdated OS, however - in my opinion companies also should realize that many users are simply tired of updating their OS each, lets say, 5-8 years. It takes a while getting used to a new OS and even longer to really know how to work with it. Usually by the time they really learn how to deal with their OS, a new version is being released and they are more or less forced to update - but that’s a different topic.

For my touchpad problem: Do you know a site or users that modify drivers? For example, the official Intel UHD 620 driver is only available for Windows 10, however someone successfully modifyied so it runs on W7 as well. I guess the Intel UHD driver is much more complicated than a simple touchpad driver, or am I wrong here?
Do you know what the latest Synaptics Touchpad driver with official W7 64x support is? The only one I found is v17.0.19 but this one dates back to Nov 2013. How about using a “similar” driver or will only a proper SYN3286 work?

Many thanks, J.

Attach inf-file for Win10

@DeathBringer :
Attached is the INF file of the original Win10 x64 Synaptics driver v19.5.10.68 dated 05/21/2018.

SynPD.rar (76.4 KB)

Try to replace





@ DeathBringer: After replacing it looks like this, is that correct?





Yes, it’s correct. But now I think it will not help…

Try other method
1. Download this driver http://download.windowsupdate.com/c/msdo…c22181b0a61.cab
2. Unpack and open file SynPD.inf
3. Replace ACPI\SYN326F with ACPI\SYN3286 in it.
4. Save and try to install

No success. I changed the the inf file from the cab driver as said above, ran setup.exe, soon after the red driver warning message popped up → “Install this driver software anyway” but in the end the installation failed, showing a small red “x”.

Earlier today I tried installing the original not-modifyied SP81891 driver, this time it seemed to work and it showed a green “check symbol” and installation successful message in the end. However, in the Control Panel there is no Synaptics button, and when clicking on Mouse - Properties there is also no Synaptics tab - so I can’t access any settings - I guess even though it said installation successful, it’s not working.

SP81891 is the same driver with I’ve suggested using. Version is
Original driver hasn’t support for ACPI\SYN3286

You can try to modify sp85250 with

Ok, thanks I’ll try it later. For the SP85250 - replace the same string as from the cab file before?

“Replace ACPI\SYN326F with ACPI\SYN3286 in it”


Unfortunately same result as before in post #10.

Am I’m doing something wrong? I extract the sp drivers to a folder, I modify the inf file from the x64 folder and launch setup.exe from the same x64 folder. Is that correct or do I have to modify the inf file in the x86 folder as well?

Install driver manually by Device Manager->Update Driver->Browse my computer for driver software->Let me pick from a list of device drivers on my computer->Have Disk
Attach modded inf-file.

I’ve already tried that a couple of times, all I get is a message like “drivers are already installed - no update necessary” - it’s a German Windows 7 version so I’m not sure what the message says in English.

Read my previous message attentively.

Ok, my bad, did it the wrong way before.

So when trying to install it manually, it says something like "there is no compatible driver for the device in the folder. if there are any drivers in the folder, please make sure they support x64 systems"

Does this make any sense?

make a video