[Request] Nuc8i7hvk Bios Fix

please help i have problem with nuc8i7hvk after update bios. cannot run any 3d apps always hang then display driver restart. cannot restart windows (always stuck loading) but success if its shutdown process. sometimes cannot post after turning it on. before updating bios, system work flawlessly. i attached bios dump thank you

nuc8.zip (5.57 MB)

No error in bios update, one NVRAM volume very little space left, might be reason for some confusion. Try the attached file.

0067A12.zip (5.54 MB)

i see a lot data cleaned. is it ok to flash write with ezp2019+? i don’t have backup chip at the moment. thank you

This type of emptying the NVRAM worked before for similar types of NUC, but there’s of course no 100% safety in these things. Since you have a backup and a programmer…

yeah thats why i encourage myself to ask here, been watching this amazing forum searching for answer.
flashed the rom, thankfully can boot and log in to system. sad the problem still exists. thank you

Well, seems that you/ someone else worked on ME/ PCH settings already, FD is unlocked, some settings different to the configured ME that’s part ogf the update. Might be that later ME versions aren’t compatible with or react differently on these changes? You might clean your ME according to [Guide] Clean Dumped Intel Engine (CS)ME/(CS)TXE Regions with Data Initialization or use the FD and configured ME that are part o the Intel update file.

According to your description it might as well be an OS- issue…

Ok will try clean ME according to Guide and post result later. or we can change ME versions backward/downgrade?
Tried different OSes, distributions, still the same problem it hangs.

Unfortunately i broke one leg of the chip due to many time re-flash. Before that i managed to follow the guide on cleaning ME then flash and boot ok, but still no differences. Tried once change earlier ME version but cannot boot. Should i just try another ME versions until it boots? Thank you

Well, that doesn’t sound too good. I don’t think any longer that this is firmware related. If ME was configured correctly and it was cleaned properly, the firmware now should be completely fine. There’s still EC firmware that might get updated when updating the bios, but that wouldn’t generate problems like yours.

I’m unfortunately out of ideas…

Got the replacement chip, Yes flashed all ME versions one by one they all boot but no luck. maybe it has something to do with EC or microcode, i dont touch anything there yet cant find repository for its PCH.
Noticed in gpu-z that gpu load 100% and memory controller load 100% while idling. but in task manager it doesn’t show activity. Thank You

If I understand you right you’re at least booting again? If this is a ‘normal’ (stock production) NUC there is nothing more that can be done, firmware should be no issue any longer!

Yes thankfully booting was never the problem. This nuc i think is engineering sample with processor says intel 0000. Like you say that’s why maybe some modification done to it before, i don’t know which is which, and maybe the later bios update screw the system. Thank you

I don’t know when this began, but at least from ME12 and maybe from ME11, too, those ME- versions were exclusive- meaning pre- production hardware/ PCH requiring pre- production ME (and µcode?). Do you have another machine of this type, a backup of the old firmware?

Otherwise find a pre-production ME 11 and look if this does make any difference. But there was 11.0, 11.5, 11.6, 11.7, 11.8, it’s pure luck to find the appropiate version.

Can you run a MEInfo -verbose and try to find out which µcode this machine uses?

I don’t have another machine, but still looking for it maybe can backup its firmware.

Tried all the ME that has CON_H_DA_PRD_RGN , now on ME 11.0 at the moment, no luck yet.

I don’t see any line with “µcode” in results. Thank You

meinfo64.txt (7.63 KB)

meinfo32.txt (7.63 KB)

It seems that at least your PCH isn’t ‘pre-production’, should be HM175 and PCH Version 31 seems to be quite common? µcode isn’t related to ME, it’s within the bios region, often microcode code changes from pre- production to production.

But as written before, I’m not sure this is firmware related after all and in that case it might be something that hardly can be diiagnosed remotely.

Good luck!

Will looking for microcode for this ES nuc later meanwhile will use this nuc as is at the moment cant do anything serious basically hang every random minutes.

Thank you man really appreciate!!

Trying to change µcode to earlier µcode using ubu with optioon MMtool, then open the file with uefitool. In the parser it says potential to not boot so i not flash the file yet.
Then try again with tutorial in the forum tutorial, but confused between uefitool 59 and uefitool 0.28. I can see µcode in the uefitool 59 but not in 0.28. How to detect the µcode body and modify using uefitool 0.28? or just open the file in HxD then copy paste the µcode away?

Maybe its the last effort, then ill give up. Thank you


@bignotlive @lfb6 I am responding to bignotlive’s PM here so that we are all on the same page.

First I want to confirm everything about the hardware of your NUC - are there any items with a yellow bang in device manager?

Your NUC should be Hades Canyon, having the specs of one of these models;

1. NUC8i7HVK (BIOS Board Number NUC8i7HVB) + i7-8809G (CPUID 906E9) + Radeon RX Vega M GH (1536 shaders)


2. NUC8i7HNK (BIOS Board Number NUC8i7HNB) + i7-8705G (CPUID 906E9) + Radeon RX Vega M GL (1280 shaders)

Both models share the same BIOS (HNKBLi70) and use the same CPU microcode (including the 8809G ES).

bignotlive can you please post a CPU-Z screenshot of your ES CPU?

There are problems with Windows 10/11 and AMD’s latest drivers as they don’t support the Radeon RX Vega M GH or Radeon RX Vega M GL (read this AMD thread).

You must use the drivers supplied by Intel such as 18.12.2 or (latest).

Both of the Intel CPUs have an integrated GPU (HD630) that must be active and functioning in the NUC at the same time as the AMD Radeon RX Vega M chip.

You can download the current Intel HD Driver here.

bignotlive can you please post a GPU-Z screenshot of both the iGPU (HD 630) and the AMD Radeon RX Vega M?

Regarding changing the micocode- it’s just one microcode in PEI volume, so you can just exchange it with a hex editor, fill directly after microcode wit FF to size of old microcode = to correct filesize.

BUT all changes in this area wil result in a BootGuard hash mismatch. ME is configured FVME 0 and Meinfo states Retrieving Variable “Protect BIOS Environment Enabled” Disabled So maybe it’s really off (It’s hard to read these line breaks when the output is changed to text, there should be two columns with values both for FPF and ME, so it’s unclear that if this is really output for FPF or ME-configuration. Would be fine to see these last MEInfo lines as screenshot of the command window!)

Thank you for response from both of you,

here are some picture


there are no driver error all driver installs from intel nuc site no problem
problem is commonly amd gpu driver restart itself makes app crash, it happens after bios update
no matter windows version, linux version, all crash.


tried working on ucode past month like everyday some modded bios boot fine even bootguard mismatch some modded bios dont.
sometimes changing the ucode even after correct file size with filling ff, after open it with uefitool the volume topfile structure gone.
maybe its not firmware related like ifb6 stated. maybe its hardware maybe memory but im still curious.