[Request] NVMe BIOS for HP z820

Similar thread about z620 - [Request] NVMe BIOS for HP Z620

On my HP z820 Flashchip is Winbond 250128FVFG, a big chip with 16 pins.


Also, present jumpers (if I remember, memory lock) E14 dual pin, and J20 triple pin.


Several software possible to find to read Flash under DOS or UEFI, but I’m not sure in the fullest RAW dump.
And yes - CH341A flash writer works with similar chips (clips with 8 pin). I use it once with HP Elitebook.

Latest BIOSes:
HP z820 - https://whp-aus1.cold.extweb.hp.com/pub/…00/sp100128.tgz
HP zX40 (440, 640, 840) All support NVME boot - https://ftp.hp.com/pub/softpaq/sp111001-111500/sp111048.tgz

@Minzak - What is your BIOS chip ID? Read it with your eyes, don’t rely on software to tell you the ID. I will tell you best software/version to use to dump BIOS, you send to me, then we test the edit
Unless you already know what software can properly read and write to this chip?

@Lost_N_BIOS I searched already a little, but didn’t write- if it helps:

WInbond 25Q128FVFG, it’s visible on the pictures, too.

HP Z820 Workstations
E1/JP1 SPI BIOS ME/AMT Flash Override Header
E15/JP15 BIOS Crisis Recovery Header

(BIOS is easy to add NVME driver, too, but problem will be how to flash back, and this you know much better

Hm, for me used hardware flash chip writer - it is easy.
But hand-made BIOS can be in the wrong format and MB can brick or revert or just not boot.
Need triple recheck, or better automate it! to build an NVME injector in the new version of BIOS.
I want to be fully secured and sure in the file before flash it. (I haven’t second Z820 MB ))

@Minzak - Since system has ME jumper, put on jumper, reboot to windows three times, then dump BIOS region with FPT, do NVME edit, then flash it back.
If you are not sure, or do not trust your own NVME edit, then send me your dump BIOS region, or programmer dump if you want, and then I will do NVME mod for you

I’m waiting when arriving SOIC16 clip, and make the FULL RAW dump of my BIOS.

@Minzak - This maybe can be done with FPT, no need for programmer, unless you are worried to try and sort that way?
I don’t think @gloobox ever tried to dump and edit just the main DXE volume, instead of entire BIOS region.
It should be possible, you can confirm by showing me image of this FPT output (use FPT from V8 ME system tools package) >> FPTw.exe -i
Do this with ME/AMT jumper on, after you reboot to windows three times.

@Lost_N_BIOS At last, I got the SOIC16 clip, just need soldering to wire it.
But interesting - I haven’t 40 pin, “E1/JP1 SPI BIOS ME/AMT Flash Override Header”, only empty pins.



I got E1 and E14 for latest MB


But I got “FPTw.exe -i” once reboot under WindowsPE (I have only Linux and No Windows)

Intel (R) Flash Programming Tool. Version: 
Copyright (c) 2007 - 2013, Intel Corporation. All rights reserved.
Platform: Intel(R) Patsburg Chipset - Reserved DID 0x1D41
Reading HSFSTS register... Flash Descriptor: Valid
--- Flash Devices Found ---
W25Q128BV ID:0xEF4018 Size: 16384KB (131072Kb)
--- Flash Image Information --
Signature: VALID
Number of Flash Components: 1
Component 1 - 16384KB (131072Kb)
Descriptor - Base: 0x000000, Limit: 0x000FFF
BIOS - Base: 0x510000, Limit: 0xFFFFFF
ME - Base: 0x005000, Limit: 0x50FFFF
GbE - Base: 0x001000, Limit: 0x002FFF
PDR - Base: 0x003000, Limit: 0x004FFF
Master Region Access:
CPU/BIOS - ID: 0x0000, Read: 0x1B, Write: 0x1A
ME - ID: 0x0000, Read: 0x0D, Write: 0x0C
GbE - ID: 0x0118, Read: 0x08, Write: 0x08
Total Accessable SPI Memory: 16384KB, Total Installed SPI Memory : 16384KB
FPT Operation Passed

And one main question - if I haven't SPI pin, it is mean that I can reflash the BIOS only via SOIC16 clip?
Hm, One way is to use a pin to close the contacts.

I found this:

Need all to reread and to find one ideal way.

EDIT by Fernando: Unneeded double post removed and FPT results put into a "spoiler" (to save space)

Also, I have MEInfo DOS result:

Intel(R) MEInfo Version:
Copyright(C) 2005 - 2014, Intel Corporation. All rights reserved.

Intel(R) Manageability and Security Application code versions:

BIOS Version: J63 v03.96
MEBx Version:
Gbe Version: 1.3
VendorID: 8086
PCH Version: 5
FW Version:

FW Capabilities: 0x0C7A5445

Intel(R) Active Management Technology - PRESENT/ENABLED
Intel(R) Capability Licensing Service - PRESENT/ENABLED
Protect Audio Video Path - PRESENT/ENABLED
Intel(R) Dynamic Application Loader - PRESENT/ENABLED

Intel(R) AMT State: Enabled
Cryptography Support: Enabled
Last ME reset reason: Global system reset
Local FWUpdate: Enabled
BIOS Config Lock: Enabled
GbE Config Lock: Enabled
Host Read Access to ME: Disabled
Host Write Access to ME: Disabled
SPI Flash ID #1: EF4018
SPI Flash ID VSCC #1: 20052005
SPI Flash BIOS VSCC: 20052005
BIOS boot State: Post Boot
OEM Id: 00000000-0000-0000-0000-000000000000
Link Status: Link up
System UUID: 20395a00-0403-11e4-86dd-40a8f0c96c4b
MAC Address: 40-a8-f0-c9-6c-4b
IPv4 Address:
IPv6 Enablement: Enabled
IPv6 Address: FE80::7904:1F7:818:B8A7
Privacy/Security Level: Default
Configuration state: Completed
Provisioning Mode: PKI
Capability Licensing Service: Enabled
OEM Tag: 0x00000000
Slot 1 Board Manufacturer: Unused
Slot 2 System Assembler: Unused
Slot 3 Reserved: Unused
M3 Autotest: Disabled
Wireless Micro-code Mismatch: No
Wireless Micro-code ID in Firmware: 0x0082
Wireless LAN in Firmware: Intel(R) Centrino(R) Ultimate-N 6205
Wireless Hardware ID: No Intel WLAN card installed
Wireless LAN Hardware: No Intel WLAN card installed
Localized Language: English
Independent Firmware Recovery: Disabled

Also ME stat result 1:
Intel(R) MEInfo Version:
Copyright(C) 2005 - 2014, Intel Corporation. All rights reserved.

FW Status Register1: 0x1E040185
FW Status Register2: 0x12520100

CurrentState: Normal
ManufacturingMode: Disabled
FlashPartition: Valid
OperationalState: Bring Up
InitComplete: Initializing
BUPLoadState: Success
ErrorCode: No Error
ModeOfOperation: Unsecured mode by H/W jumper
ICC: No valid OEM data, ICC not programmed
PhaseStatus: UNKNOWN

Also ME stat result 2:
Intel(R) MEInfo Version:
Copyright(C) 2005 - 2014, Intel Corporation. All rights reserved.

FW Status Register1: 0x1E000245
FW Status Register2: 0x69000100

CurrentState: Normal
ManufacturingMode: Disabled
FlashPartition: Valid
OperationalState: M0 with UMA
InitComplete: Complete
BUPLoadState: Success
ErrorCode: No Error
ModeOfOperation: Normal
ICC: No valid OEM data, ICC not programmed

And I use flashrom on local (after some times I will use CH341)

dump.txt (6.32 KB)

And my dump is here - https://bizlevel.net/dump.bin.tar.gz
16777216 byte, md5sum - 70ee9d34b1b179f72d6f201a990c947e dump.bin

Thanks to try so many jumper work on Z820!
Actually I have tried almost all jumpers on Z620/Z420,but it still prompted error7 when flashing with FPT.

For me all jumpers is work. (for full dump read)

But I have some strange, after reboot and dump again BIOS - md5summ is different.
I think it always is similar behavior because in ME region rotated some data.
And for this reason on forums present messages about clearing ME region when making BIOSes.

Or I wrong, and each next dump must be with the same md5sum ?
I put in archive my dumps from flashrom(linux) and ftk8 fpt(dos) and some others - https://bizlevel.net/z820.tar.gz

Some strange, I can’t detect BIOS chip when using 16SOIC Clip, I rechecked wire, but nothing (








Your bios files dumped are OK,just add the NVME module in it and flash

Do you have raw dump? I need it to check if my bios is corrupted?

Not yet, I still not found how to setup a clip to got worked dump utils.

I Also have Z220 SFF PC,
Planned to make the test on in, before to do on Z820.
One bad thing - BIOS on z220 too closely to DIMM, because I cannot use CLIP ((

Hello Milzak, did you get it working?

I have the some problem, I tried many times and I count not able to detect the chip with
ch341a and soic16 clip

I have several times tried and have not lucked.
I think it needs to choose the correct pin.