[REQUEST] NVMe mod for ThinkCentre M81 (7517 IS6XM mb)

I have a Lenovo 7517B4U motherboard with bios version 9HKT50AUS dated 4/18/2012.
I have searched but cannot seem to find an update of newer bios.
The nvme drive that I have is a PNY cs2130 which is recognized in the Windows OS but not in the Bios. It’s a new drive and I would like to copy my Windows 10 64bit OS from my sata drive to the Nvme drive so I have everything just as normal.

The driver key for the PNY Nvme drive is {4d36e967-e325-11ce-bfc1-08002be10318}\0022.

As it is my first time, please let me know what other information is required for me to request a modded bios so that I can boot off my Nvme drive.
I am not comfortable making the mods myself so that’s why I am requesting.


PS I have managed to update the Bios to 9HKT58AUS dated 06/10/2014, therefore looking for a modded version of that please.

The Lenovo website is showing my computer as M81 Desktop (ThinkCentre) - Type 7517 but I have of course a different case.

Edit your post and please correctly identify the system model and motherboard model/revision.
Provide actual bios dump and link to original bios file from the OEM.
(Presumably could we be talking about a ThinCentre Mxx with a IS6XM motherboard…?)

EDIT: A dump is taken from the running system and its own bios, not taken from a bios file.

Theres 2 methods, no success guarantee for both, to update the bios with NVMe mod.
Using a dump with Intel FPT tool and using the motherboard ME_DIS jumper or using a CH341 programmer. Lenovo mod flashes are not easy…


Heres a brief description of the method using the ME_DIS on a M92
Modify the BIOS of a Lenovo M92 to enable native NVMe support (tachytelic.net)
The NVMe mod its easy to do, the hard part and with high risk to the user of a bricked system, is the mod flashing itself operation.
Mod files usually wont be accepted to flash using regular methods for each OEM/System model, due to security issues it will fail.

Users can share their own files here ont he forum (Compressed 10Mb MAX) or in their private shared services like GDrive, Odrive etc…

A user here on the forum, with a M93:
Lenovo M93p Nvme mod - BIOS/UEFI Modding / BIOS Modding Requests - Win-Raid Forum (level1techs.com)

Hi Meatwar ,

Thanks for the reply.It is a Lenovo IS6XM Rev 1.0 as you have suggested.I have now managed to update the bios to 9HKT58AUS and have bios dump from the zip file that I downloaded.

I got it from link and its the exe file 2nd to last from the bottom. Flash UEFI BIOS update (Flash from operating system version)9hjy58usa.exe .

I tried to upload the file but it says new users cannot upload attachments.
The file name is IMAGE9H.ROM

I have tried following the link this but am getting an error of

Blockquote Error 201: [FPTw64.exe] cannot be run on the current platform.
Please contact your vendor.

I have also put a jumper on the two-pin ME_DIS . Below is a pic of how I have done it

What am I doing wrong and how come I cannot get a back up of the bios from my computer ?

Must use the correct Intel FPT tool from Intel ME7 or 8 package (Ex. Bios 9HKT41A uses ME7):

Bios settings can show you, the ME version that the system uses, depends on models and bios UI. Its a Intel Q65 and can use both versions.

Tool runs from an ADMIN CMD window in Windows (Intel ME driver should be installed) or from USB Boot to DOS/UEFI environment.

The tool can only read/write depending on the access provided in FD, further guidance here:
[Guide] Unlock Intel Flash Descriptor Read/Write Access Permissions for SPI Servicing - Special Topics / Intel Management Engine - Win-Raid Forum (level1techs.com)

The ME_DIS jumper its the switch to provide this access, still OEM rules on the bios/fd will retain it.

We need a full backup or just the bios_region:
fpt.exe -d full_spi.bin or fpt -bios -bios_reg.bin

I do advise to work only in the bios_region, mod it and flash it again back with FPT
fpt.exe -bios -nvme_bios_region.bin

Do you understand the risks of getting a bricked system? Just to be sure that this is USER OWN RISK and choice only. If bricked only with a backup bios image (NOT Lenovo bios files, it wont work) and a CH341 programmer it can be recovered. Or OEM specific methods if avavaible.

Take it easy and read what is posted and linked, rush is the killer of all things…

1 Like

I am using CMD in admin mode but got stuck in this error and don’t know what to do next .

what version should I be using and where would I get it from ?

I have tried to run intel_me_7.1.80.1214_5Mo(www.station-drivers.com) but getting an error below . I start cmd as admin and I have it in drive C, so what am I doing wrong ?

Intel ME Firmware is not a Windows driver, these are 2 different things.
These tools report that the OS Intel ME driver is not installed, required as i said before.
Drivers ( on section D in the 1rst link i posted before.

1 Like

Thanks, MeatWar I managed to get the backup.bin but don’t understand what you mean by
" We need a full backup or just the bios_region:
fpt.exe -d full_spi.bin or fpt -bios -bios_reg.bin "

Where do I get the fpt.exe and do I install it on the C drive?
Is the fpt.exe the same as the UEFI Tool in the guide you told me to use in post 2 ?

In the guide where he says " Modify the BIOS and Inject the NVMe Driver "right-click on the item with the name 8D4AB7ED-99B0-4389-84D4-557C449610DC and choose Insert After ", he’s got different numbers to mine so where should I insert the Nvme Drivers?

After I have installed the Nvme drivers will the Nvme drive show in the bios even though it has nothing in there, it has just been formatted thru Windows ?

backup.zip (5.1 MB)

Well… the guide/example i linked is not from this forum, was just to get notion on a Lenovo system.

A full dump (8192kb) contains EC/BIOS/ME (Full size: 57D000h (5754880) FW etc… what and where we need to mod for NVMe is on the bios region (Full size: 280000h (2621440), we avoid and thats always my advice to work/mod the bios region ONLY, but as that example linked…its your choice only, not mine.

The tool can brief you the system firmware regions/components and read/write each one separate:

FPT.exe -i

-I Displays information about the flash image.
-DESC Load/verify/dump Descriptor region.
-BIOS Load/verify/dump BIOS region.
-ME Load/verify/dump ME region.
-GBE Load/verify/dump GbE region.
-PDR Load/verify/dump PDR region.

Careful with this tool and its use…the tool writes anything without verification, even with user error cmds… result, a bricked system with wrong/overwritten regions.

We have our NVMe and Flash guides here on the forum, presented by our GURU Fernando:
[HowTo] Get full NVMe Support for all Systems with an AMI UEFI BIOS - Special Topics / NVMe Support for old Systems - Win-Raid Forum (level1techs.com)

[Guide] How to flash a modded AMI UEFI BIOS - BIOS/UEFI Modding / BIOS Modding Guides and Problems - Win-Raid Forum (level1techs.com)

Modern Windows OS (w8> do not need driver for showing an NVMe disk (as storage device), this particularly NVMe mod is for the bios of an old motherboard can let a new fresh Windows setup to boot and install.
If theres a driver for a particular model, its user choice to install it or not.
Performance tests should be done but usually the built in (OOBE) MS NVMe driver performs well.

Sidenote… your current ME7 FW is version, available update from Lenovo page to version (2017), this should be updated before any mods, a new dump also should be made.

I am trying to update to version but its giving me an error of " Error 8193: Intel (R) ME Interface : Cannot locate ME device driver" and then aborts the update.
I don’t know where to get or install the ME device driver.

Also in my device manager the “Intel Management Engine Interface” is showing the orange triangle but when I try to update it , I get a message that its already up to date.

The Lenovo package notes, relies only on Windows 7 support for the operation.
The device driver he needs ( on windows device manager “Intel(R) Management Engine Interface” is installed because you need it for the previous operation with FPT and dumps, so it could be an issue from the Lenovo package.

Gonna be straight with you… we know when users lack the experience on advance operations and it can be a risk for them… theres other solutions for this, but by then theres a “Bible” written by me on this thread and a lot of time given… i cant and most users cant, sorry.
Any way all that is required was already linked and all it takes is user time to read, learn and take their own chances, all the best.


1 Like

I thought I would try this again with a fresh head today but I am getting the

Error 9470: Fail to load driver (PCI access for Windows)
Tool needs to run with an administrator privilege account.

I am confused as to why that is coming up again, please advise.

Sir… i dont want to be rude… but tell me, do you read whats in front of you or do you simple ignore it?
“Tool needs to run with an administrator privilege account.”

EDIT: Do you see the MEI loaded driver in Dev.Management? Is the ME_DIS as default or factory…

That’s the weird thing I thought that I was in cmd ADMIN.

sorry to sound dumb but whereabouts in Device Manager will I see this to check for it

Are you making fun of me? Its seems so… im about to leave it as it is…
What is the windows device manager? Where do you see the current state of an installed driver and hw devices of a system?
What is to you, that capture that i posted earlier?
This is an advanced forum with a minimum of user knowledge, at least… your out of your league sir

EDIT: Expand “System devices” → “Intel(R) Management Engine Interface”

If its loaded, and you had access to it when used FPT tool… dont know whats happening on your side, period.

1 Like

no I know where the device manager is and I am not making fun of you believe me .
After I have the device manager up I can’t seem to find the MEI driver so was wondering in which section of the device manager it was in …

Again I am sorry if I am not clear.

UPDATE … yes it seems that I have no Intel in my system devices.

UPDATE 2 … I managed to install it again but am having an orange/yellow triangle on it

… shutdown the system, put ME_DIS back to original position, CLR CMOS with jumper 5sec, take out CMOS battery, AC power unplugged 2m, restart, run FPT.exe -greset (It may not work now…no driver loaded), reboot. Did you flash anything?

You’re about to get a corrupted bios or its already corrupted…at least the ME FW image…
This is the issue with unexperienced users who dont know what their doing or paying attention to details…

1 Like

MeatWar , thanks for your help and bearing with me even though I am a Dumb**s.
I took a risk and used AMI AFUWin64 v3.05.04 with GAN support flasher which I used to make a backup, then used it again to reflash the modified bios.
I made my changes to the backup bios file using the UEFITool program.

When I go into bios, the Nvme adapter is recognized in the Boot Sequence as the letter H.
Is that normal ? I haven’t installed an OS on the nvme drive for me to test it out yet.